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Course Description

In this official course from Unity, you will learn to design and develop your own Virtual Reality (VR) applications.
You will create prototypes, attempt challenges, and complete quizzes to build and solidify your skill set. At the
same time, you will be guided through creating your own unique VR project from start to finish, beginning with a
blank design document and ending with a fully functional project. Whether you want to create an interactive
walkthrough of an ancient ruin, a product configurator for a car manufacturer, a simulator for operating dangerous
machinery, or any other experience, this course will help you bring those ideas to life in VR.

Thanks to Andrew, creator of the VR with Andrew YouTube channel, for collaborating with us on this course.
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Getting Started - Tech Setup
Lesson 0.1 - VR Software Setup

Lesson Link

Length

Lesson Objective:

Step

1- Overview

2- Course
requirements
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VR Software Setup - Unity Learn

1Hour 30 Minutes

Instructions

In this lesson, you will get all the necessary software for your computer and your VR device
installed and configured for VR development.

First you will install the recommended version of Unity to be able to follow along with this
course. Depending on which VR device you intend to use, you may also need to install
additional export modules.

You will also make sure that your VR headset is configured properly for development and
testing, including downloading any additional device-specific software that is required.

Note: If you do not have access to a VR headset, you can still benefit from this course, but
your ability to fully test the VR experience will be somewhat limited.

Your Unity experience

This course assumes you have at least a basic understanding of the Unity Editor. If you have
never used Unity before, welcome! The Unity Essentials learning pathway has been
designed to help you get set up and ready to create in the Unity Editor. We recommend you
complete this pathway to learn the Unity basics before continuing with this course.

Your VR experience

You'll get the most out of this learning content if you have some previous basic experience
with VR.. If you haven't explored any VR experiences before, try the basic tutorial content
created for your VR hardware.

You do not need any experience developing for VR to use this learning content.

Your VR hardware

This learning content is fully verified with Meta Quest model headsets.

You can use any other headsets that support OpenXR, including the Valve Index, HTC Vive,
and Windows Mixed Reality Headsets, but you are more likely to encounter obstacles along
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the way. Everything should function properly, but the learning content has not been fully
tested and verified on these devices.

Note: If you do not have access to a VR headset, you can still benefit from this course, but
your ability to fully test the VR experience will be somewhat limited.

3 - Before you | Update the Unity Hub

begin Before you begin to set up your Unity project, consider updating your Unity Hub to the latest
release. If you are using an older version of the Hub, there may be differences between the
guidance provided and your experience.

Install Unity 2021.3 LTS
Before you can follow along with this course, you must install a particular version of Unity
and, if using an Quest, an additional Android Build Support module.

1. Select Unity 2021.3 LTS:
e From Unity Hub, select to install Unity 2021.3 (LTS).
o This LTS (Long-Term Support) version of Unity is stable and will be fully
supported for two years, making it ideal for development.

2. If you are using a Meta Quest, install the Android Build Support Module:
e When prompted to install additional export modules, select Android Build Support.
o  This will enable you to build Android apps (.apk files), which run on Quest
devices.
e If you are not using a Quest, you can leave all export modules unselected.

3. Download and install the Unity Editor:
e Follow the prompts in Unity Hub to continue downloading and installing Unity 2021.3
LTS, then wait for it to install.

You should now have the recommended version of Unity installed along with any additional
required export modules.

4 - Quest If you are using a Quest or Quest 2, complete this step. Otherwise, skip this step.

device setup
Before you can begin development with a Quest, there are a few steps required to make sure
the device is configured appropriately.

1. Put your device in Developer Mode:
e Follow the instructions on Device Setup from the Quest Developer page to put your
device in Developer Mode.
o This will allow you to do testing and development on your device.

2. (Windows only) Install the Quest software and connect your device:
e If you are using a Mac, skip this step.
e From the Quest Setup page, download and install the correct application or software
for your device.
e Within the application, follow the instructions to add your headset, either by Link
cable or by Air Link.
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5 - Other
device setup
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3. (Mac only) Using Quest devices with a Mac:
e You won't need to download any additional software in order to use your device with
a Mac. There will be further instructions on how to test your app with a Mac in a later
tutorial.

You should now have your Quest device ready for development with Unity.

If you are using a headset that is compatible with SteamVR, like the HTC Vive, Valve Index, or
Windows Mixed Reality headset, complete this step. Otherwise, skip this step.

Before you can begin development with an HTC Vive, HTC Vive Pro, or Valve Index, you need
to install Steam and SteamVR.

1. Install Steam:
e Go to the Steam download page and follow the instructions to download and install
Steam.

2. Install SteamVR and link your device.
e Go to the SteamVR download page and follow the instructions to download and run
SteamVR.

e Plug your headset into your computer and make sure it is linked and recognized by
SteamVR.

You should now have SteamVR running with your device successfully connected and
recognized.
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*Optional* Using version control throughout this course is optional, but highly recommended to help
6 - Setup keep a record of your work and make sure you don't lose any progress.
version control
If you are unfamiliar, version control (sometimes called source control) is a system that
manages and tracks information. Version control software can be configured to store,
manage, and track changes to any kinds of files, software, websites, or other data.
If you want, check out this version control tutorial to learn more about it.

We won't walk you through this process during the course, so it's up to you to do it on your
own. Any time you're asked to set up a new project, you should set it up with version control.
After every significant change, you should push an update to your cloud repository. This will
make sure that you're able to recover previous versions of your project if you need to.

Version control is important for your own development, but it's also important for getting jobs!
Potential employers might even require that you submit a GitHub link in your application. So
it's a good idea to get familiar with using version control now.

Recap You have now set up your computer with the required version of Unity, the correct software

for your device, and you have configured your device to be ready for development. With
these tasks complete, you are ready to start working on your first VR project!
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Unit1 - VR Basics
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Lesson 1.1 - VR Project Setup

Lesson Link

Length

Lesson Objective:
By the end of this lesson, you will have a new unity
project with a big empty room that you will experience

in VR

This unit is part of the Create with VR course.

Step
Step 1- Open

anew VR
project

© Unity 2021

i ot S .

1Hour 30 Minutes

Instructions

The first thing you have to do is create a new Unity project configured
for VR.
1. Download and extract the Create with VR starter project:
e Click to download the file: Create with VR Starter Project.
e To extract on Mac: double-click the downloaded file.
e To extract on Windows: right-click the downloaded file and
select Extract All.

2. Rename and relocate the project on your computer:
e Locate the folder called “VR Room Project” inside the extracted
folder.
e If you want, rename the project folder to “VR Room - [Your
Name]”
e Move the project folder to a logical directory on your computer
(e.g. a folder called “Create with VR" on your desktop).

3. Add the VR Room project to the Unity Hub:

e Open the Unity Hub.

e Add your VR Room Project to the list of projects in the Unity
Hub.
If you are not sure how to do this, check out this tutorial on
adding projects to the Unity Hub.

e If you see a warning icon next to the Editor version of your
project, don't worry.

NAME MODIFIED A EDITOR VERSION

VR Room

e This just means that the project was created with a specific

Teacher Notes

Warning: Watch,
then do

Warning: Need to
use correct version
of Unity

Explain: Starter
project provided just
has packages and
settings configured -
if you want to set up
a project on your
own, there is a link
below. There is also
a VR Template for
LTS versions, but it
doesn't quite have
everything we need.
Explain: What can
you do with the
package manager?
Explain: Why URP?
For mobile, VR, good
optimized graphics.
For higher end
devices, might want
to use HDRP, but
that's much more
complex, too.
Warning: May take a
while to open the
first time- has to
build the entire
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version of Unity that you don't have on your computer. As long Library folder.
as you have installed a version of Unity beginning with 2021.3, Explain: What does
the project will run perfectly. XR Stand for?
Extended Reality,
includes Mixed,
Augmented, and
4. Open the project in Unity 2021.3 LTS (Long-Term Support): Virtual Reality.
e From the Editor Version dropdown, select a version of Unity
beginning with 2021.3, then select Open with 2021.3.X.
e If a window pops up asking if you want to “Change Editor
Version?", select Change Version.

Change Editor version?

If you change the Editor version of your project, the
scripts might change and the project library might be
rebuilt. Depending on the size of your project, this might
take some time.

Are you sure you want to change the Editor version of
your project?

Change version

¥

e If a warning pops up that you are Opening Project in a
Non-Matching Editor Installation”, select Continue.
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r 3

Opening Project in Non-Matching Editor Installation X
a Your project was last saved with a different version of
Unity.

C:/Users/Documents/Unity/QA/VR Room Project

The saved project (2021.2.1f1) does not match the
launched editor (2021.3.1f1).

This may require re-import. Please be aware that
opening in an older version is unsupported.

Note that if a build target installation is missing, this
may also cause a re-import.

If you proceed, some packages may be updated. For a
list of any changes made to your Project’s packages,
see the Logs/Packages-Upgrade.log file in your Project
folder.

Continue ﬂ Quit

e Your project should now open in Unity.
e If there are yellow warning messages in the Console window
about some of the assets, you can ignore them or clear them.

5. Explore the contents of the starter project and how it differs from a
typical empty project:

e From the top menu, select Window > Package Manager.

e In the left panel of the Package Manager, locate the packages
installed in this project (with checkmarks next to them),
including:

o XR Plugin Management
o XR Interaction Toolkit
o Universal RP (Render Pipeline)

e Note: to filter and view only packages currently installed in the
project, from the top-left corner of the Package Manager
window, select Packages: In Project.
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Step 2 - Open
and explore
the starter
scene

© Unity 2021

g o

XR Interaction Toolkit

2 - January 25, 2021

You should now have your new VR starter project open to an empty
scene and understand which packages allow for compatibility with VR.

Related Resources:
e Blog about the Unity XR Plugin Framework

Before you run the project, you should choose a more interesting
environment to experience in VR.

1. Rename and open the Starter Scene:
e From the Project window, open the Scenes folder.
e Rename the “Create-with-VR_Starter-Scene” as "[Your_Name]
Room".
e Double-click on your renamed scene to open it.
2. Explore the contents of this scene and how it differs from a typical
empty Scene:
e From the Hierarchy, select the XR Rig object and inspect the
XR Origin component.
e Select XR Rig > Camera Offset > Main Camera and inspect the
Tracked Pose Driver component.
e Select either the LeftHand Controller or RightHand Controller
object and inspect the XR Controller component.
e Select the Input Action Manager object and inspect the Input
Action Manager component.

Explain: What is this
course library?
What's included?
Demo: When you
add an XR Rig to a
default scene, it
steals the Main
Camera and makes it
a child object.
Explain: Roomscale
vs Stationary rig -
show difference on
Tracking Origin
Mode for XR RIg (6
DOF vs 3 DOF)
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Step 3-Adda
room and
background

© Unity 2021

You should now have your new scene open. You should also have a
broad understanding of the components of the scene that make it
different from a typical Unity scene.

Note: This scene and its settings have been pre-configured in this
starter project, since they are required for VR development in this

course. If you want to learn how to configure a VR-ready project similar

to this from scratch, there are instructions in this tutorial: Create a VR
Starter Project from Scratch.

This empty scene would be boring to explore in VR, so you should add

a room that will be a bit more interesting and will provide more
perspective when you're in VR.

1. Add aroom to the scene:
e In the Project window, expand Course Library > _Prefabs >
Rooms.
e Drag one of the Room_[style] prefabs into the Hierarchy.
e From the Hierarchy, delete the Plane object.
2. Add an environment outside the room's windows:
e Open the Course Library > _Prefabs > Environments folder
e Drag one Foreground object and one Background object into
the Hierarchy.
3. Adjust the sunlight in the room:
e Change the X and Y rotation of the Directional Light object to
change the way sunlight enters your room.

Demo: Show the
different styles of
rooms.

Demo: Show the
different
environments
(buildings vs hills)
for foreground and
background.
Demo: Different
creative options for
room with
accompanying
furniture for each
one.
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Step 4 - Run
the app with
the Device
Simulator

© Unity 2021

You should now have room, foreground, and background objects in
your scene from the course library, with sunlight entering the room at
the desired angle.

You can test the scene with a Device Simulator. This simulator allows
you to test the app in-editor using the mouse and keyboard, rather than
having to connect to a device and put it on. This can be helpful for
quick tests.

1. Add the Device Simulator to the scene:
e From the Project window, open Samples > XR Interaction
Toolkit > [version] > XR Device Simulator.
e Drag the XR Device Simulator Prefab into the Hierarchy.
e Click Play to test the simulator.

2. Experiment with the keyboard and mouse controls:
e Note: To use the simulator effectively, a mouse with a clickable
scroll wheel is required.
To control the camera: hold right-click.
To control the left controller: hold Left Shift or toggle with T.
To control the right controller: hold the Spacebar or toggle with
Y.
To pan around with a device: move the mouse.
To rotate a device: hold the middle mouse button.
To reset the position and rotation of devices: press V.
If you'd like a helpful guide, download the PDF of the Rig
Simulator Shortcut Cheat Sheet.

3. See more controls available for the device simulator:
e From the Hierarchy, select the XR Device Simulator.
e Inthe XR Device Simulator component, double-click on one of
the Action variables to open the Action Editor.
e Expand the Actions to view their Bindings.
e From the left Action Maps panel, select either Main or Input
Controls to view additional action mappings.

4. Important: disable the Device Simulator if you do not plan on
using it:
e Select the Device Simulator object then disable it in the
Inspector window.
e Having the device simulator active when running the project on
your device will cause problems.

Warning: Using this
is incredibly finicky
and can be
frustrating. You're
trying to operate 3
devices, each with 6
degrees of freedom,
thumbsticks,
buttons, etc with one
mouse and
keyboard.

Warning: You really
need a 3-button
mouse (with a scroll
wheel) to operate
this.

Warning: Your head
might start on the
ground by default.
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Step 5 - Test
in VR through
Unity

© Unity 2021
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You should now be able to look around your room with your mouse and
keyboard using the Device Simulator.

If you are using a Windows computer, follow this step to test on your device.
Otherwise, skip this step.

If you are using a Mac for development, this step is not relevant. You will learn
how to test your app in the next step when you build your app directly onto
your device.

In order to run the project on your device through Unity, you need to install the
correct plug-in for development. OpenXR is an open source API that connects
Unity to supported VR hardware devices. It is recommended that you use this
plug-in, since it allows you to deploy to multiple devices through a single,
standardized API.

1. Install the OpenXR Plugin for desktop testing:
e From the top menu, select Edit > Project Settings, then select the XR Plug-in
Management panel from the sidebar.
e In the Windows, Mac, Linux tab, select OpenXR from the list of available Plug-in
Providers to install that plug-in.

-
Initialize XR on Startup v
Plug-in Providers @

Oculus

OpenXR

Mock HMD Loader

2. Resolve any warnings by setting up an interaction profile.
e After adding the OpenXR plugin, there may be a warning or error icon that appears
next to the plugin Name.
e If there are no warnings or errors, you can skip to step 3 below to connect your device
through the Quest Link Software.
e If there is a warning, click on the warning icon to open the OpenXR Project Validation
window, which will tell you that you need to add an interaction profile for the device
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you're using.
e Select the Edit button to open the OpenXR settings panel.
XR Plug-in Management

o [ ) OpenXR Project Validation

. OpenXR Project Validation
Initialize XR on Startup Y

Issues (1
Plug-in Providers @ M
A Atleast one interaction profile must be added. Please select
which controllers you will be testing against in the Features
v OpenXR @ A menu.

Unity Mock HMD

Information about configurati

e In the Windows, Mac, Linux tab, make sure the Oculus Touch Controller Profile
appears in the list of Interaction Profiles, then enable all available OpenXR Feature
Groups.

e If you are using a different device, such as the Valve Index or HTC Vive, add its
interaction profile instead.

£ Project Settings

Burst AOT Settings a OpenXR

Editor

Graphics (] E
URP Global Settings

Input Manager

Input System Package

Memory Settings

Package Manager

Physics

Render Mode Single Pass Instanced

Depth Submission Mode None

Play Mode OpenXR Runtime System Default (None Set)
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Physics 2D
Player

Preset Manager
Quality

Scene Template

Script Execution Order

Services
Ads
Cloud Build
Cloud Diagnostics
Collaborate
In-App Purchasing
Legacy Analytics
ShaderGraph
Tags and Layers
TextMesh Pro
Time
Timeline
Ul Builder
Version Control
Visual Scripting
XR Interaction Toolkit

XR Plug-in Management

OpenXR

Interaction Profiles
Oculus Touch Controller Profile @

Valve Index Controller Profile @

OpenXR Feature Groups

v Mock Runtime @
(%]

v Runtime Debugger

All Features

e There should no longer be any warnings in the XR Plugin Management panel. If there
are, select them and follow the recommended steps to resolve them.

e If you are having trouble resolving warnings or errors, or if you need help
troubleshooting, check out this detailed documentation on configuring the OpenXR

plugin.

3. Connect your device through the Quest Link Software:
e Make sure your device is plugged into your computer using a compatible cable.
e Make sure the Quest App is running and has successfully recognized your device.
e If you have not yet downloaded the Quest App, you find it on the Link Setup page.
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4. Test the project on your device:
e Make sure the XR Device Simulator in your scene is disabled. If it is enabled, your
head tracking will not work.
e Select Play in the Unity Editor and put on your headset.

On a Windows computer, you should now be able to quickly test your app on your device
through Unity.
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Step 6 - Build | If you are using a Quest, follow this step to build the app onto your
your app onto | device. Otherwise, skip this step.
your Quest

Since the Quest is a standalone device (meaning it does not need to be
connected to a computer), you can build an app and test it directly on
the device, disconnected from your computer.

If you are on a Mac and cannot test your app through the Windows
Quest software as in the previous step, this will be the primary way for
you to test your app on your headset.

In order to build your app to the Quest headset, you will need to
configure plug-ins for the Android build target.

1. Install the OpenXR for Android builds:

e From the XR Plug-in Management settings, select the Android
tab, then select OpenXR from the list of available Plug-in
Providers to install that plug-in.

Note: You will only have an Android tab if you installed the
Android export module.

e If you don't see an option for OpenXR in the Android tab, first
go back to the Desktop tab and select OpenXR there, then
return to the Android tab.

XR Plug-in Management

&

Initialize XR on Startup v

Plug-in Providers @

ARCore

v OpenXR @ A
Unity Mock HMD

2. Resolve warnings by setting up an interaction profile.
e Click on the new warning or error icon that appears to open the
OpenXR Project Validation window, which will tell you again
that you need to add an interaction profile.
e Select the Edit button to open the OpenXR settings panel.

XR Plug-in Management

&
Initialize XR on Startup v
Plug-in Providers @

ARCore

(@) OpenXR Project Validation
v OpenXR @ A OpenXR Project Validation

Unity Mock HMD

Issues (1)

A Atleast one interaction profile must be added. Please select
which controllers you will be testing against in the Features

Information about configuratic menu.

e In the Android tab, select the + button to add the appropriate
© Unity 2021

Explain: Why select
Android? What does
Android have to do
with Oculus?
Warning: May take a
while to build the
first time.

Warning: If you get
an error saying that
the Min API level
must be set to
something - can be
set in Build Settings
> Player Settings >
Android > Other
Settings > Minimum
Api Level

Warning: Can be
very frustrating if the
device doesn’'t show
up or if building
doesn't work for
some reason - may
have to do some
troubleshooting.
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profile for your device, then enable all OpenXR Feature Groups.

Burst AOT Settings o OpenXR
Editor

Graphics (] E
URP Global Settings

Input Manager
Input System Package Depth Submission Mode None

Render Mode Single Pass Instanced \ Multi-view

Memory Settings
Pack‘age Manager Interaction Profiles
Physics
Physics 2D Oculus Touch Controller Profile @
Player
Preset Manager
Quality OpenXR Feature Groups
Scene Template
Script Execution Order All Features
Services
Ads
Cloud Build
Cloud Diagnostics
Collaborate
In-App Purchasing
Legacy Analytics
ShaderGraph
Tags and Layers
TextMesh Pro
Time
Timeline
Ul Builder
Version Control
Visual Scripting
XR Interaction Toolkit

v Oculus Quest Support @

XR Plug-in Management
OpenXR

e If any additional errors or warnings appear, click on the error or
warning icons to resolve them.

XR Plug-in Management

&

Initialize XR on Startup

Plug-in Providers @

ARCore

v OpenXR @ A
Unity Mock HMD

3. Prepare your scene for building:
e Make sure the XR Device Simulator in your scene is disabled. If
it is enabled, your head tracking will not work.
e From the top menu, click File > Build Settings.
e Click Add Open Scenes to add your scene.

4. Switch to the Android build platform:
e In the Platform section, select Android.
e Click Switch Platform, and wait for your project to switch to the
Android platform.
e Note: Android will only show up as a possible build target if you
successfully installed the Android Export Module during
installation of the Unity Editor.

5. Select your device as the build target:
e Make sure your VR device is turned on and plugged in.
e Next to the Run Device drop-down, click Refresh, then select
your VR device.
e Note: If your device does not show up in the list, try putting on
the device. It may prompt you to Allow USB debugging. If it is
still not showing up in the list, try restarting your device, making
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sure it's in Developer Mode, or restarting Unity.

6. Build and run your project on your device:
e Click Build and Run.
e When prompted to choose a location, create a new "“Builds”
folder, then Save your project as “[YourName] - VR Room - 1.1".
o Note: When you build your app for the first time, it may take
several minutes to compile.

Platform

-
I;l PC, Mac & Linu It Android

F =
|'| Android

Build App Bundle

Run Device jest {~ | Refresh

De

LZ4 v

Learn about Unity Cloud Build

Player Settings... Build Build And Run

You should now be able to test the app on your device, untethered from
your computer.

Note: The app is automatically saved onto your device in the
“Unknown Sources” section of your App Library. You may need to

follow steps to allow apps from unknown sources in order to locate
your app.

Troubleshooting tips:
e If the app runs, but it does not take up the entire field of view, it
is likely a problem with plug-ins.
e If the app runs, but the entire scene moves along with your
head, it is likely because you have the Device Simulator active
or you do not have the Input Action Manager configured

properly.
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Step 7 - Test If you are using a different OpenXR-compatible device, such as the

on other Valve Index, HTC Vive, or a Windows Mixed Reality headset, follow this
OpenXR-com | step to test on your device. Otherwise, skip this step.

patible In order to test the project on one of these devices, you need to install

devices the OpenXR plugin and enable the feature set for your specific device.

1. Configure the OpenXR Plugin for your device:
e Follow the instructions on the OpenXR Manual page to install
the OpenXR Plugin, enable it in XR Plugin Management, and
configure it for your particular device.

2. Connect your device through the SteamVR app:
e Make sure your device is plugged into your computer using a
compatible cable.
e Make sure the SteamVR app is running and has successfully
recognized your device.

3. Test the project on your device:
e Make sure the Device Simulator in your scene is disabled. If it
is enabled, your head tracking will not work.
e SelectPlay in the Unity Editor and put on your headset.

You should now be able to quickly test your app on your headset
through SteamVR.

Recap New Features:
- Projectis setup
- Scene set up with Room
- Tested with Device Simulator
- Runon device

New Concepts & Skills:

- Pipelines for different types of hardware
Packages required for VR Development
VR scene vs typical Unity scene
Rig Simulator vs on-Device testing
Tethered vs Standalone testing

Next Lesson:
- VR Locomotion

Extensions If you want to further develop your skills, explore new concepts, and improve your project,
check out some of the optional extension activities below.
Each one is tagged as [Easy], [Medium], [Difficult], or [Expert] and will also include a [Requires
Programming] tag if some coding is required.

Extension 1- 1. Play with Directional Lighting [Easy]

Directional Experiment with the directional light to achieve the shadow and color you want in your room:
Lighting e Try rotating the Directional Light about the X and Y axes
e Try adjusting the color of the Directional Light to match the color of light to the time of
day

© Unity 2021 Create with VR - Lesson Plans


https://docs.unity3d.com/Packages/com.unity.xr.openxr@0.1/manual/index.html

Extension 2 - | 2. Device Simulator Practice [Medium]

Device Get comfortable using the basic functions of the device simulator:
Simulator e Refer to the instructions in the step above for how to set up and use the device
Practice simulator.
e Note: Remember to remove or disable the Simulator before running the app in your
device.

© Unity 2021 Create with VR - Lesson Plans




See lesson related videos here

Extension 3- | 3. Add a functioning clock [Expert] [Requires programming]
Add a Add a clock on the wall that either (a) tells the current time for the user in their local timezone,

functioning or (b) tells the time you intend it to be your VR room world.
clock e Find a clock Prefab in the Course Library > Prefabs > Objects > Electronics folder.

e Hint: To access the system’s current time, use the DateTime.now property.

See lesson related videos here
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Lesson 1.2 - VR Locomotion

Lesson Link 1.1 - VR Project Setup - Unity Learn

Length 1Hour 30 Minutes

Project Objectives:

In this lesson, you will learn how to implement various
types of locomotion in VR. By the end of this lesson,
the user will be able to teleport around your newly
furnished room to admire it from all angles.

This lesson is part of the Create with VR course.

Learning Objectives:
By the end of this lesson, you will be able to:

e Implement various techniques for locomotion
in VR, including Roomscale, Teleportation, and
Continuous movement.

e Recognize the advantages and disadvantages
of different VR locomotion strategies in order
to choose one that makes sense for your
application.

e Appreciate the problem of “vection” in VR (the
illusion of movement) in order to predict what
might induce simulator sickness in users.

Step Instructions

Step 1- Fill You now have a room, but it's empty. You need to add spaces in the room
the room where VR interactions can take place.

with 1. Locate the furniture prefabs:

furniture e In the Project window, open Course Library > _Prefabs.

2. Define an entryway:

e In one corner of the room, add a mirror object and hook object.

3. Define a living area:

e In one half of the room, add a seating object, a television object, and

a fireplace object.
4. Define another area:

e Add a rug object and either a table object or storage object to

provide a surface.

© Unity 2021

Teacher Notes

Warning: You
might want to
put the mirror on
one of the side
walls so that it
doesn't have to
render the
background
buildings
Demo: Explain
how the mirror
works with a
camera and
render texture
Warning: You
can add lighting
objects, but
don't add any
actual Unity
Lights yet - we
will do lighting
later.
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Step 2 - Add
shap turning

© Unity 2021

You should now have: an entry area with a hook and a mirror; a seating area,
a living area with a television and a fireplace; and another area with some
surface space to hold objects.

You will next set up the ability to turn around in place so that you can
experience the room without physically moving and rotating.
1. Give your XR Rig locomotion capabilities:
e Inthe Hierarchy, select the XR Rig object and add a Locomotion
System component.
e For the XR Origin property, select and drag the XR Origin component
from the Inspector onto the slot that says “None”.
e Note: You can also select the object picker and double-click the XR
Rig object.

2. Allow your XR Rig to turn around:
e With the XR Rig object still selected, add a Snap Turn Provider
(Action-based) component.
e For the System property, drag and drop the Locomotion System
component onto the slot.

3. Fine-tune the snap turning experience:
e Experiment with the Turn Amount and Debounce Time properties.
e Select the Enable Turn Around property to allow the user to turn 180
degrees when they press the joystick down.

4. Experiment with continuous turning:
e Remove the Snap Turn Provider component and add a Continuous
Turn Provider (Action Based) component.

Explain: What is
"Action Based"
Vs
"Device-based"?
Action based
uses an
action-based
input system
which allows for
device-agnostic
actions to be
used instead of
a specific
controller button.
Warning:
Continuous
turning will make
a significant
percent of users
motion sick.
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Step 3 - Add
a
teleportation
area
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v Locomotion System

Timeout 10
XR Origin B XR Rig (XR Origin)

v Snap Turn Provider (Action-based)

System B XR Rig (Locomotion System)
Turn Amount 45
Debounce Time 0.5
Enable Turn Left Right v
Enable Turn Around v
Delay Time 0
Left Hand Snap Turn Action
Use Reference v
Reference & XRI LeftHand Locomotion/Turn (Inp @
Right Hand Snap Turn Action
Use Reference v

Reference & XRI RightHand Locomotion/Turn (In ©

You should now be able to use the joysticks on either hand controller to
rotate by a certain number of degrees. This makes your project possible for
a stationary experience.

Note: If you are using the XR Device simulator, you can simulate movement
by using T or Y to toggle one of the controllers, then A or D to simulate snap
turning.

Now that you can rotate, you should also be able to teleport anywhere within

a specific area.
1. Allow the user to teleport:

e Select the XR Rig object and add a Teleportation Provider
component.

e For the System property, drag and drop your Locomotion System
component to assign it to the property.

2. Make the rug a teleportation area:

e Select the Rug object and add a Teleportation Area component.

e At the bottom of the Teleportation Area component, for the
Teleportation Provider property, drag and drop the XR Rig object
from the Hierarchy to the empty slot to assign it to the property.

Now, when you point anywhere on the rug, the line renderer will turn white,
and you can use the grip button on the controller to teleport there. The grip
button is the lowermost button on the inside of the controller, usually
pressed with the middle finger.

Note: If you are using the XR Device simulator, you can use T or Y to toggle
one of the controllers, use the middle mouse button to aim your ray, then
press G to simulate pressing the "Grab” button.

Explain: What is
a teleportation
area

Demo: If you
double-click the
XRI default input
actions, you'll
see the default
button for
“Select" is Grip
Demo: Show
that there is also
a continuous
move provider,
but that would
likely make
users nauseous.
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Step 4 - Add | Sometimes, you want the user to teleport to a specific spot, facing a specific
teleportation | direction.

anchors 1. Add Teleportation Anchors to the scene:

e Go to Course Library > Prefabs > Rugs, then add smaller "Mat”
objects at key locations around the room.

e Rotate these objects so that their local Z axis (blue) arrow is facing
the direction you want the user to be when they teleport there.

e Note: You must be using Local coordinates to see the local forward
direction of the objects.

e In Unity 2021.3 LTS, the Local/Global settings are represented by a
Globe or Cube button drop-down in the top-left corner of Scene
view:

# Scene  @® Game # Scene  a@® Game
v @~y > A
v Global
Local
[ J
2. Save changes to all of the mats at once in Prefab Mode:

e Select one of the mat objects and click the Open button at the top of
the Inspector.

e To make sure your changes are saved in the top-right corner of the
Scene view, enable the Auto-save setting.

E Teleportation Area (Script)
raction Manager (XR Int: ©
Custom Reticle Mone (Game Object)
Teleportation Configuration
Match Orientation  World Space Up
On Select Exited
portation Provid B XR Rig (Te tation Provider) (=
nteractable Events
3. Turn the mat prefab into a teleportation anchor:

e Onthe mat Prefab, add a new Teleportation Anchor component.

¢ Note: It's not actually necessary to assign the Teleportation Provider
property - it is assigned automatically when the app runs.

4. Match the orientation of the anchor when you teleport there:

e In the Teleportation Anchor component, set the Match Orientation

property to Target Up And Forward.
5. Exit Prefab Mode:
e Select the Back arrow in the top left corner of the Hierarchy.
You should now be able to teleport to the mats around the room, re-orienting
to the direction of the mat when you arrive.
Note: To hide the colorful outlines of the objects in Scene view: in the
top-right corner of the Scene view window, click the Gizmos button to hide
the Scene view gizmos. You can also click the drop-down arrow next to the
Gizmos button to show/hide specific elements.
Step 5 - The Line Renderers from your hands change color when you are able to
Customize teleport somewhere. You can provide more visual feedback to the user with

© Unity 2021

Explain: How is
a teleportation
anchor different
from an area?
Warning: Make
sure you're
using local
coordinates
Demo: How to
determine key
locations?
Should be able
to get
everywhere in
the room with
easy access to
objects.

Explain: What is
a reticle?
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the
teleportation
reticles

‘Recap

Extensions

Extension -
1. Research

© Unity 2021

reticles. Basically a
1. Find the reticle you want to use: crosshair -
e Go to Course Library > Prefabs > VR > Reticles, and determine something for
which Reticle you prefer. aiming.
2. Assign a custom reticle for the Teleportation Area rug: Warning:
e Select the large Rug object with a Teleportation Area component. Double-check
e At the bottom of the Teleportation Area component, for the Custom that auto-save is
Reticle property, drag and drop your chosen Reticle to assign the enabled in
property. prefab mode.

3. Assign a custom reticle for the Teleportation Anchor mats:
e Open the prefab of one of your mat objects.
e Inthe Teleportation Anchor component, for the Custom Reticle
property, assign the Reticle.
e Exit Prefab Mode.

Teleportation Anchor (Script)

None (XR Interaction Manager)

tion Lav

yer Mask Everything
Colliders
Custom Reticle & VR_Reticle_Square

Teleport Anchor Transf A Mat_Rect_Black (Transform)

leleportation Configuration

Match Orientatior Target Up And Forward

On Select Exited

n Provid None (Teleportation Provider)

nteractable Events

The custom reticle should now appear at the location where the line
renderer meets the teleportation destination.

New Features:
- Designed room
- Turning rig
- Teleporting rig

New Concepts & Skills
- Types of locomotion
(Room scale / Continuous / Teleport)
- Vection & simulator sickness
- Teleportation areas vs anchors

Next Lesson:
- Grabbable objects

If you want to further develop your skills, explore new concepts, and improve your project,
check out some of the optional extension activities below.

Each one is tagged as [Easy], [Medium], [Difficult], or [Expert] and will also include a [Requires
Programming] tag if some coding is required.

1. Research other VR movement [Easy]
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other VR Look into other less common forms of VR movement, including projectile warping, scripted

movement movement, projected avatar, world-pulling, etc:
e Check out this vi ut movement t from our Design, Develop, and Deploy for
VR course

e Google "VR movement types” to find other interesting strategies for VR locomotion.

Extension - 2. Create your own art [Medium]
2. Create Add your own custom piece of art to the room to make it uniquely your own:
your own Art e You can create your own masterpiece or find one online that you have the rights to use

(search for “creative commons 0")
e Hint: You will need to create a new Material and assign your image as the Base Map of
that material, then apply that material to an object.

Extension - 3. Animate the reticle [Medium] [Requires Programming]
3. Animated | Make the teleportation reticle spin around and/or scale up and down to make the experience
reticle feel more dynamic:

e Hint: Create a custom rotation script and apply it to the reticle prefab
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See lesson related videos here: Extension Activities Lessons

© Unity 2021 Create with VR - Lesson Plans


https://learn.unity.com/tutorial/vr-locomotion?uv=2020.3&courseId=60183276edbc2a2e6c4c7dae&projectId=60183335edbc2a2e6c4c7dcb#60227453edbc2a001ff2b163

Lesson 1.3 - Grabbable Objects

Lesson Link 1.3 - Grabbable Objects - Unity Learn
Length 1Hour 30 Minutes

Project Objective:

In this lesson, you will learn how to configure objects
for basic grabbable interactivity in VR. By the end of
this lesson, users will be able to pick up objects in the
scene and throw them around.

This lesson is part of the Create with VR course.

Learning Objectives:
By the end of this lesson, you will be able to:
e Set up a grabbable object in VR with all
required components and properties in order
to be picked up and manipulated by a user.

e Configure a grabbable object's attach point in
order to ensure it is positioned and oriented
properly when it is picked up by a user.

e Use the relationship between units in Unity and
real-world scale in order to ensure that objects
in the scene are proportioned accurately.

e Understand the properties of a grabbable
object in order to ensure it behaves as desired
in VR (e.g. movement type, position smoothing,

You can choose the models to represent the user’s hands in VR rather

etc).
Step Instructions
Step 1-
Choose hand | than just using simple spheres.
models 1. Browse options for hand models:

© Unity 2021

e In the Project window, open Course Library > Prefabs > VR >

Hands, then determine which VR_Hand option you prefer.
2. Assign a model to your left hand:

e In the Hierarchy, select XR Rig > Camera Offset > LeftHand
Controller.

e Inthe XR Controller Component, for the Model Prefab
property, drag and drop your hand prefab of choice to assign
it.

3. Assign a model to your right hand:

e In the Hierarchy, select XR Rig > Camera Offset > RightHand
Controller

e Repeat the same step as above to assign a prefab for your
right hand.

When you test your app, you should now see the hand models you
selected instead of grey spheres.

Teacher Notes

Explain: These
prefabs are
instantiated when the
app is run.

Warning: Make sure
you assign the correct
left vs right hand
prefabs to the left and
right controllers
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Step2-Adda
grabbable
object

Step 3 - Hide
hands and
disable
anchor
control

Step 4 -
Fine-tune the
throwing
experience
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Now that you can see your VR hands, you should add objects to grab
with them.
1. Add a ball to the scene:
e Go to Course Library > Prefabs > Objects > Sports.
e Drag a ball onto an accessible surface in the room.
2. Make the ball grabbable:
e Add an XR Grab Interactable component to the ball.
e Note: This will automatically add a Rigidbody component to
the ball object as well.
3. Test your grabbable object:
e Reposition the XR Rig to be in front of the table with the
grabbable ball object.
e Run your application.
e Test grabbing the object by aiming your ray at it and pressing
the Grip button.
4. Make sure that the object is the correct scale:
e Inthe Hierarchy, create a new 3D Object > Cube object, and
rename it “Measuring Stick".
e Use Google to determine the correct official diameter of the
ball and then convert the dimensions you found into meters.
e In the Measuring Stick's Transform component, set the X and
Z Scale to 0.01 and the Y scale to the length you calculated.
e Position the measuring stick next to your ball to make sure it's
accurately sized. If it is not, use the Scale tool to correct it.
You should now be able to pick up the ball using the Grip button,
release the grip button to throw it.

Note: If you are using the XR Device simulator, you can toggle a
controller with T or Y, rotate it to point at an object by holding the
middle mouse button, then press and hold G to grab and hold an
object.

Currently, the hand model overlaps the object you're holding and you
are able to change that object’s position in your hand with the
controller. This is not optimal for interacting with the scene.
1. Stop the user from moving the object with the left joystick:
e Inthe Hierarchy, select XR Rig > Camera Offset > LeftHand
Controller object.
e |nthe XR Ray Interactor component, disable the Anchor
Control setting.
2. Make your hand model disappear when you grab an object:
e Inthe XR Ray Interactor component, enable the Hide
Controller on Select setting.
3. Apply these changes to your right controller:

e Repeat the steps above on the RightHand Controller object.
Your hands should now disappear when you pick up an object and
you should no longer be able to move or rotate the object with the
joystick.

The object can be grabbed, but there are some minor aspects of its
behavior that need to be tweaked.
1. Make the ball bouncy:
e In the Ball object’s Sphere Collider component, locate the
Material property.
e Click the circular button to assign one of the provided Physics
Materials.
2. Prevent a dropped object from going through the floor:
e In the Ball object’s Rigidbody component, set the Collision

Warning: It may go
through the ground -
that's OK.

Warning: It will be a
little weird to have the
ball intersecting with
your hand - we'll fix
that.

Demo: You can move
the object towards
and away from
yourself with the
joystick - we'll fix that.
Explain: Unity to
real-world scale - Im
= 1 Unity unit.

Explain: Why would
you want your hands
to disappear? It just
looks weird to have
your hand
intersecting with the
object and it looks
surprisingly OK to not
have them there.
Explain: When would
you want to be able to
move / rotate objects?
Maybe when
examining them, or in
a creative [ design
app where you can
position things.

Explain: Kinematic vs
velocity tracking vs
Instantaneous
movement

Explain: What is the
difference between
the “Is kinematic”
setting in the
Rigidbody and the
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Detection setting to Continuous Dynamic.
3. Allow the ball's rigidbody physics to work while in your hand:
e |nthe XR Grab Interactable component, ensure that the
Movement Type is set to Kinematic.
4. Smooth the motion of the object:
e |nthe XR Grab Interactable component, enable the Smooth
Position and Smooth Rotation properties.

& .~ Sphere Collider
Edit Collider s

Is Trigger

Material = PhysicsMaterial_Bounce_Medium O]
Center X -9.55537e- Y 0.0309761 Z 4.130043¢
Radius 0.0319775

@ Rigidbody
Y EES
Drag
Angular Drag
Use Gravity
Is Kinematic
Interpolate None
Collision Detection Continuous Dynamic
Constraints
Freeze Position
Freeze Rotation
Info

v XR Grab Interactable

Interaction Manager B XR Interaction Manager (XR Interactior @
Interaction Layer Mask Default v
Colliders

Size 0
Custom Reticle None (Game Object)

Movement Type Kinematic
Retain Transform Parent v
Track Position v
Smooth Position v
Smooth Position Amour
Tighten Position
Track Rotation
Smooth Rotation
Smooth Rotation Amour
Tighten Rotation

The ball should now bounce, not fall through the floor, and move
smoothly in your hand.

Step 5 - Add You have added a ball object that is held at its center and where
an object with | orientation is not important. Now you will add an object that will be
a handle grabbed at a very particular point and orientation.
1. Add a sports racket, paddle, or bat into the scene:
e Go to Course Library > Prefabs > Sports

Kinematic movement
type?

Explain: Go through
other XR Grab
interactable settings,
including Attach
Transform, Ease in
time, Movement type,
Interaction
LayerMask, Smooth
position/rotation,
Throw on detach / etc
Demo: Tooltips are
super helpful in
inspector

Explain: Imagine
making a fist with a
“thumbs up” gesture -
the front of your
knuckle should align
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e Drag one of the sports implements onto the surface next to
the ball.

2. Make the new object grabbable:

e Select the new object and add an XR Grab Interactable
component.

e |nthe XR Grabbable component, enable both the Smooth
Position setting and the Smooth Rotation properties to
decrease jitter.

e Inthe Rigidbody component (which was added automatically),
for the Collision Detection option, select Continuous
Dynamic to prevent it from going through the floor.

3. Create a specific attach point for the object:

e In the Hierarchy, right-click the object and create an Empty
child object.

e Rename this empty object “Attach”.

e Reposition and rotate the Attach object so that it matches the
position and orientation your hand model should be when you
grab the new object.

4. Assign the attach point to your sports implement:

e |n the Hierarchy, re-select the parent sports object.

e |nthe XR Grab Interactable component, locate the Attach
Transform property.

e Drag and drop your new Attach object to assign it to the
Attach Transform property.

@ Asset Store
e w2 v B0y

You should now be able to grab the sports implement object by the
handle and hit the ball with it.

Step 6 - Before you get too many objects in the Hierarchy, it's good to set up
Organize the an organizational system for your objects.
Hierarchy 1. Make organizer objects in your Hierarchy:

e In the Hierarchy, create new empty GameObjects named
"XR,” "LIGHTING", "STATIC," and "DYNAMIC,"
e Reset all of their positions to 0, 0 0.
2. Organize your objects into categories:
e Drag objects from your Hierarchy onto the organizer objects -
the advantage of this technique is that it keeps your Hierarchy
nice and neat.

© Unity 2021

with the z axis arrow
your thumb should
align with the y axis
Warning: This can be
extremely
counter-intuitive and
may need to be done
with trial and error

Explain: This will be
very helpful down the
line - especially with
lighting

Demo: Use
Ctrl/Cmd+Click to
multi-select or
Shift-click to select
many objects in a row.
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Recap

Extensions

Extension -
Fill your room
with objects
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e Alternatively, drag your objects underneath these organizer
objects - the advantage of this technique is that it keeps your
objects easily accessible.

= Hierarchy
+ v
& Carl Room*
D --XR--
& XRRig
&) Input Action Manager
&) XR Interaction Manager
& -- LIGHTING --
@ Directional Light
ce_Modern
i

vio n(1)
r

Die

Q -- STATIC --
6 -- DYNAMIC --

The Hierarchy should now be more usable, organized into categories.

New Features:
- Hand models
- Simple grabbable ball
- Grabbable tool with attach point
- Organized Hierarchy

New Concepts & Skills
- Unity vs Real-world scale
- Grabbable object properties
- Collision detection modes
(discrete vs continuous dynamic)
- Movement types
(kinematic, instantaneous, velocity-tracking)

Next Lesson:
- Sockets

If you want to further develop your skills, explore new concepts, and improve your project,
check out some of the optional extension activities below.

Each one is tagged as [Easy], [Medium], [Difficult], or [Expert] and will also include a [Requires
Programming] tag if some coding is required.

1. Fill your room with objects [Easy]
Add fun decorative and grabbable objects to your scene to make it feel more interactive, even
if those objects aren't fully functional yet:

e Browse through the Course Library > Prefabs > Objects folders for ideas.
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Extension - 2. Experiment with the grab interactable properties [Easy]

Experiment Add a new grabbable object to your scene and experiment with the various properties of the
with the Grab | XR Grab Interactable component, including:

Interactable e Movement type: Kinematic vs Instantaneous vs Velocity Tracking

properties e Smooth Position/Rotation Amount and Tighten Position

e Throw on Detach properties

Extension - 3. Add a magnifying glass [Difficult]
Magnifying Add a functional magnifying glass to your scene that you can use to pick up and examine
Glass objects:

e You could use a Camera Render Texture similar to the way the mirror works.
e Don't worry if the ray gets in the way - that will be resolved when we can toggle the
rays on and off.

See lesson related videos here

Extension - 4. Add a notebook that swings open [Expert]

Add a Add a notebook with a front cover that swings open when you grab it:

notebook that e Hint: The Notebook_Cover needs a hinge joint with its Connected Body property set to
swings open the notebook’s Rigidbody.

e If you want, try adding some text to the notebook.
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See lesson related videos here
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Lesson 1.4 - Sockets

Lesson Link

Length

Project Objective:

In this lesson, you will learn how to configure sockets
that objects can snap into in VR. By the end of this
lesson, users will be able to hang hats up on hooks -
and even wear the hats too!

This lesson is part of the Create with VR course.

Learning Objectives:
By the end of this lesson, you will be able to:
e Describe the functionality of a socketin VR in
order to propose potential use cases in an
application.

1.4 - Sockets - Unity Learn

1Hour 30 Minutes

e Configure a socket in order to have an object
snap into a particular orientation if placed
within a specific area.

e Use interaction layers in order to control which
objects can and cannot interact with each

other.

Step

Step 1- Add
grabbable
hats to the
scene

Step 2 - Turn
the hook into
a socket
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Instructions

Before making a functional hook for hats, you'll first need some
grabbable hats.
1. Some hats to your scene:
e Open the Course Library > Prefabs > Objects > Hats folder.
e Drag two hats you might want to wear onto a surface near the
mirror.
e Note: If you do not already have a set of hooks in your scene,
add one from the Course Library > Prefabs > Hooks folder.
2. Make the hats obey physics:
e Use Ctrl or Cmd to select both hats in the Hierarchy.
e Add Rigidbody components to the selected hat objects.
e Set the Collision Detection property to Continuous Dynamic to
prevent them from falling through the ground.
3. Make the hats grabbable:
e Add XR Grab Interactable components to each hat.
e If you want, enable the Smooth Position and Smooth
Rotation properties to reduce jitter.
4. Prepare for testing:
e Reposition and reorient the XR Rig to be in front of the mirror
within reaching distance of the hooks and the hats.
You should now be able to successfully pick up the hats.

To be able to hang the hat on a hook, the hook will need to behave like
a socket.
1. Position the socket correctly:
e In the Hierarchy, right-click the Hook object and create an
Empty child object.

Teacher Notes

Explain: You already
know how to do all
this - reminder that
all you need for an
object to behave like
a grabbable object is
a collider, rigidbody,
and xr grab
interactable
component
Warning: Don't get
emotionally attached
to the mirror - it's
really bad for
optimization and can
only be kept if our
app is well optimized
- in fact, if your app
already feels laggy,
try disabling it and
see how if that
helps.

Explain: What is a
socket?

Warning: Remember
to check the “Is
Trigger"” checkbox
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Step 3 -
Duplicate the
sockets and
attach hats

Step 4 - Put
hats on your
head

© Unity 2021

e Rename the child object “Socket 1"

e Reposition the Socket 1 object to the tip of the hook, where the
hat will rest.

2. Define the trigger detection area for the socket:

e Add a Sphere Collider component to the Socket object.

e Click the Edit Collider button and reduce the Radius to 0.1.

e Select the Is Trigger check box to prevent it from colliding with
the hat.

3. Make the Socket 1 object behave like a socket:

e Add an XR Socket Interactor component to the object.

4. Make the hat point downwards when attached to the socket:

e Create an empty child object of Socket 1and rename this child
object “Attach”.

e Rotate the Attach object to face downward.

e Assign the Attach object to the Attach Transform property of
the Socket Interactor component.

e Note: The local Z axis of the attach point should align with the
desired forward direction of the hat and the local Y axis should
align with its desired upward direction.

You should now be able to pick up and place any of your hats onto the
socket you set up.

Now that you have one fully functional socket, you can duplicate it for
the other hanging locations on the hook and have the hats start on
hooks when the scene loads.

1. Create sockets for all the hanging locations:

e In the Hierarchy, duplicate the Socket 1 object two times.

e Rename the copied objects to “Socket 2" and “Socket 3".

e Reposition the copied sockets for the other two hanging hook
locations.

2. Have your hats start on the hooks by default:

e In each of the Socket object's XR Socket Interactor components,
assign one of your hats to the Starting Selected Interactable
property.

e Note: If you only have 2 hats, one of the sockets should have
“"None" for its starting interactable property.

All 3 of your sockets should now be fully functional, with hats starting
on the hooks at the start of the scene.

These hats and this mirror would really be wasted unless you could
actually wear the hats on your head.
1. Position the head socket object correctly:
e In the Hierarchy, right-click XR Rig > Camera Offset > Main
Camera and create an Empty child object.
e Rename this new child object “Socket”
e Set the Y Position of the Socket object to 0.1 so that the hat
appears above your eyes.
2. Add a trigger detection area for the socket:
e Add a Sphere Collider component to the Socket object.
e Click the Edit Collider button and set the Radius property to 0.2.
e Select the Is Trigger check box.
3. Allow the hats to snap to this socket:
e Add an XR Socket Interactor component.

so that it can overlap
with other objects.
Demo: The Hover
Mesh Material
property - by default
is assigned Blue and
Red at runtime

Demo: Might want to
use isometric mode
for easy positioning
of the hooks

Explain: The
head/camera is on
the ground by
default - it gets
pushed up when you
enter the scene and
your position is
tracked.

Explain: The
distance from your
eyes to where your
hat should be
centered is probably
around 1/10th of a
meter (0.1 units).
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Step 5 -
Prevent other
objects from
acting like
hats
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You should now be able to put the hats on your head and see how they

look in the mirror.

You can currently put all objects on your head or on the hooks as if they
were hats. You can use Interaction layers to control which objects can
and cannot interact with each other.

1. Add a new layer for “Hats":
e Select a hat object.

e Inthe XR Grabbable Interactable component, from the

Explain: How do
layers [ interaction
layers work? If you
don’t want things to
interact, can't share
ANY layers

Interaction Layer Mask drop-down, select Add Layer.
e Add a new "Hats" layer in the first available empty slot.
e Note: Your hat will not yet be set to that layer. You have only
created the layer at this point.
2. Put the hats on your new Hats layer:
e In the Hierarchy, select all of your Hat objects using Ctrl/Cmd +
Click.
e Inthe XR Grab Interactable component, from the Interaction
Layer Mask drop-down, select Nothing to clear the layers.
e From the drop-down, select your new Hats layer to enable only
that layer.
3. Make sure the hook and head sockets can only interact with
objects on the “Hats" layer:
e Set each of the hook and head socket objects’ Interaction Layer
Masks property to only the Hats layer.
4. Make sure other objects cannot be used as hats:
e Select all of your other grabbable objects.
e From the Interaction Layer Mask drop-down, make sure only
the Default layer is enabled.
e This will prevent them from interacting with any sockets on the
Hats layer.

B v XR Socket Interactor

Interaction Manager B XR Interaction Manager (XR Interz &

Interaction Layer Mask Hats

Attach Transform
cted Inter:
r aints
XR Grab Interactable

B XR Interaction Mana
er Mask Hats

Kinematic

Continuous Dynamic

z ._
>
< Persp

XR Grab Interactable 0 i

Manager B XR Interaction Manager (XR In €
ayer Mas| Default
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Recap

Extensions

Extension -
Rearrangeabl
e art

Extension -
Rearrangeabl
e Bookshelf
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You should now only be able to put hats - and not any other grabbable

objects - on your head and the hooks.

New Features:
- Added hats
- Hang hats on hooks
- Put hats on your head

New Concepts & Skills
- Socket interactors
- Triggers to detect interaction
- Interaction layer masks

Next Lesson:
- Audio and Haptics

If you want to further develop your skills, explore new concepts, and improve your project,

check out some of the optional extension activities below.

Each one is tagged as [Easy], [Medium], [Difficult], or [Expert] and will also include a [Requires

Programming] tag if some coding is required.

1. Add rearrangeable art [Medium]
Allow the user to swap the position of art hanging on the wall:

e To make a simple hook, create an empty object with a Socket Interactor component,
then create a primitive cube child object, scaled and rotated appropriately, to represent
the mesh.

e To make the pieces of art hang at the correct height, you may need to add an Attach
Transform located at the position on the frame the art would hang from.

See lesson related videos here

2. Add rearrangeable books [Difficuilt]

Add books to a bookshelf that can be rearranged neatly in any order the user wants:
e In order to get the books to appear at the orientation you want, try creating an empty
object with the correct orientation, then making the book object a child object.

Create with VR - Lesson Plans
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Challenge 1 - Architecture Review App

Lesson Link

Length 1Hour

In this challenge, you'll apply the skills you learned
while making your VR Room in an Architecture review
app. In this prototype, the user can examine a building
at real-world scale, inspect a miniature 3d model and
floor plan of that building, and even use a ruler to take

measurements as they look around.

This challenge will assess skills learned in the

following lessons:
e VR locomotion

e Grabbable objects
e Sockets

Challenge 1 - Architecture Review - Unity Learn

This challenge is part of the Create with VR course.

Getting
Started °

1. Open the broken architecture review prototype Scene:
From the Project window, expand, Assets > Challenges > O1_Architecture > Scenes

R - o
—
w

e Double-click on the Architecture_Prototype_Broken Scene to open it.
2. Begin working on the challenge tasks:

e Work through the tasks outlined in the steps below.

e If you want to push your skills, attempt the optional bonus challenge tasks, as well.
e If you get stuck, there are hints for each task at the bottom of the page.

Challenge

1. The measuring stick and
clipboard aren't attaching
properly to the left wrist.

2. The house model is
snapping to the pedestal from
very far away.

3. You can currently snap the
ruler and clipboard to the

pedestal and the house model
the left wrist.

4. The dining table is too tall.

© Unity 2021

Task

The clipboard should be
flipped around and the
measuring stick should snap
to the spot just to the left of
the clipboard.

The house model should snhap
to the pedestal when you
place it on top of the pedestal.

You should only be able to put
the house model on the
pedestal, while the clipboard
and measuring stick should
only be able to snap to the
wrist.

The table should be exactly
0.74 meters (or 29 inches)
high.

Hint

1. Look at the position and
rotation of the Attach
Transforms for your left hand
sockets.

2. Look at the size of the
Sphere Collider on the
pedestal socket.

3. Look at the Interaction
Layer Masks of the sockets
and grabbable objects.

4. Try creating a measuring
stick that is exactly the right
height and putting it next to
the table.
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5. The teleportation anchor e Teleporting here should orient | 5. Look at the local

next to the pedestal puts the the player upright and towards | orientation of the anchor as
player upside-down and facing the pedestal. well as the “Match
away from the pedestal. Orientation” setting in its
Teleportation Anchor
component.
Bonus tasks
6. The ray on your right hand e Change the shape of yourray | 6. Look in the XR Ray
uses all the default settings. to a smooth bezier curve to Interactor component to edit
make teleporting easier and the line's shape and the XR
edit the valid and invalid colors | Interactor Line Visual
to fade from transparent to component to edit its colors.
opaque.
7. The scene should have some e Add an ambient wind sound in | 7. Make sure your audio
ambient sound. the background and source is set to the 3D
randomized bird sounds that "Spatial Blend," then, if you
seem to be coming from want, use the
different locations around the | OnTimedInterval and
house. PlaySoundsFromList

components to randomize
the bird sounds.
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Lab 1- VR Personal Project Basics

Lesson Link Lab 1- VR Personal Project Basics - Unity Learn
Length 2 Hours

In this first lab, you'll fill out a design document to lay
out your concept, and then set up a basic VR scene
using simple primitive shapes.

This lab will draw on skills learned in the following
lessons:

VR Project Setup
VR locomotion

Grabbable objects
Sockets

This lab is part of the Create with VR course.

Step Instructions Teacher Notes
Step 1 - Fill out Before you get working on your project, you need a plan for Demo: Even though
your design what you're actually going to create. The best way to do that is we're just filling out
document with a Design Document. Sections 1-3, give
1. Get a blank copy of the VR Project Design Doc them a quick tour of
e Click here to create a copy of a Google Doc the whole document.
e Click here to download as a Word document Warning: Keep your
e Click here to download as a PDF concept simple!
2. Fill out Section 1 (App Info) of the document: Explain: How will we
e Give your app a tentative title use this design
e Place a checkmark (using copy and paste) next to the document throughout
one or two categories that best describe your app. the process
3. Fill out Section 2 (Pitch) of the document: Warning: Don't do
e Describe the goal of the app. what the teacher does
e Describe why it will be especially effective in VR. - this is a chance to
e Describe what users will do during the app, at a high come up with your
level. own ideas.

e Specify whether your app will target devices with 3 or 6
degrees of Freedom
4. Fill out Section 3 (Basics) of the document:
e Describe where the app will take place and how users
will get around the environment.
e List the types of objects users will be able to grab and
any socket interactors you will likely use.
You should now have the first 3 sections of your Design
Document complete, providing enough direction to complete the
rest of this lab.

Step 2 - Openand | Just like you did at the start of the VR Room project, the first Explain: Doing the
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run a new VR
project

Step 3 - Set up the
basic scene with
primitives

Step 4 - Set up
basic locomotion

© Unity 2021

thing you have to do for your personal projects is create a new
Unity project configured for VR.
1. Create a new Unity project for your personal project:
e Follow the instructions in the VR Project Setup tutorial.
e Move the extracted folder to the same directory as your
VR Room project.
e Instead of naming your project “VR Room - [Your Name]"
- name it "VR Personal Project - [Your Name]".
2. Import the VR Course Library into your project:
e Follow the instructions in the VR Project Setup tutorial.
3. Configure your project to run on your specific device:
e Follow the instructions in the VR Project Setup tutorial.
4. Make sure you are ready to start developing your personal
project:
e Rename and open the Starter Scene.
e Make sure you can successfully run your project on your
VR device or with the Device Simulator.
5. If you do not want the Challenges in your project:
e Inthe Project Window, right-click the Challenges folder
and click Delete.
You should now have a hew project open to a starter scene and
be able to test it in VR or with the Device Simulator.

Rather than using assets from the course library, you can
develop this basic scene using primitives and simple colored
materials:

1. Create the ground:

e |n the Hierarchy, select the Plane object.

e Reset the Plane's position to O, 0, 0 in the Inspector.

e Rename it “Ground”.

2. Keep your materials organized:

e Create a new "Materials"” folder inside the Assets
directory.

3. Create a material for the Ground:

e In the Materials folder, right-click > Create > Material.

e Rename the new material “Ground”.

e Edit the Base Map color in the inspector.

e Drag the material onto your Ground object.

4. Block out the rest of your basic scene:

e Continue creating and scaling additional primitive objects
(cubes, spheres, planes, capsules, etc) and applying
simple colored materials.

e Do not create grabbable objects yet - only critical
environmental things like a room, a table, etc

Note: If you have objects that will be reused throughout the
scene, you should create a “Prefabs” folder and drag those
objects into it to make them prefabs.

You should now have your basic scene blocked out with
primitives at an appropriate scale.

Now that you have the basic scene blocked out, you need some
way of getting around it.
1. Allow the user to move around the scene:
e Follow the instructions in the VR Locomotion tutorial to
set up Teleportation Areas.
e It may be helpful to temporarily make your entire ground
object a Teleportation Area for testing and development
purposes.

same thing you did
with your room, but
just naming things
differently

Explain: Why do you
need the Course
Library? There are
scripts that will be
helpful and it's
sometimes useful to
have assets as well.

Warning - Don't add
grabbable objects yet
- we'll do that in a bit.
Explain: Why use
primitives?

Explain: Plane by
default is 10m (units) x
10m, cube / sphere by
default are 1, capsule
is 2m

Demo: How to use
prefabs the use of
prefabs, probably
Warning: Keep an eye
out for scale here!
Demo: For more
complex shapes, use
empty objects and
make primitives
children of those -
then probably make
prefabs (e.g. trees)

Explain: Even if you
don't intend on having
any movement, it's
kind of helpful to be
able to teleport
around, so err on the
side of being able to
teleport more.
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Step 5 - Setup
basic grabbable
objects

Step 6 - Organize
your Hierarchy

Recap
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e Alternatively, it may be helpful to use continuous
movement for testing and development purposes.
2. Allow the user to teleport to important locations in the
scene:
e Follow the instructions in the VR Locomotion tutorial to
set up Teleportation Anchors.
e Instead of using the mats like you did in your Room,
create 1x 0.1 x 1 cubes named “Teleportation Anchor”
e Remember to set the Match Orientation property to
match the anchor's forward direction.
You should now be able to move around your basic scene.

The last thing you'll do is create any grabbable object prefabs
you expect the user to interact with.
1. To make more complex objects with primitives:
e Create an Empty object.
e Rename the object.
e Create Primitive child objects to represent the mesh of
the form of the object.
2. To make your objects grabbable:
e Follow the instructions in the Grabbable Objects tutorial.
e Add components on the Empty parent object, not the
primitive child objects.
3. To add sockets to your scene:
e Follow the instructions in the Sockets tutorial.
4. To make your interactable objects into Prefabs:
e Drag each new interactable object into the Prefabs
folder.
You should now have basic functioning prefabs for the main
grabbable objects in your scene.

Before your Hierarchy gets too crowded, you should take a
moment to re-organize it
1. To make organizer objects in your Hierarchy:

e Inthe Hierarchy, create new empty GameObjects named
"XR," "LIGHTING", “STATIC,” and "DYNAMIC,"”

e Reset all of their positions to 0, 0 0.

2. To organize your objects into categories:

e Drag objects from your Hierarchy either onto the
organizer objects (to make child objects) or underneath
the organizer objects (to use the organizer objects as
headers)

Your Hierarchy should now be organized by category.

New Functionality:

VR project set up

Scene blocked out with primitives
Locomotion around the scene
Grabbable objects

Socket interactors

New Concepts & Skills:

Explain: Probably
good to use a prefab
for your teleportation
anchors.

Warning: Don't go
crazy designing
primitives - should
just be representations
of these objects -
should just be enough
so you know what it
is..

Demo: How to look up
scale online and apply
that scale - scale is
critical for objects
you'll hold in your
hand

Warning: Make sure
you're adjusting the
scale of the primitive
child objects- NOT the
parent object

Explain Even if it kinda
works without the
attach point, it's good
to have the control in
case you need to
adjust it down the line.

Explain what objects
should go into “XR,"”
"LIGHTING", "STATIC,"
and "DYNAMIC," and
why.
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e Applying VR basics, such as locomotion and grabbable objects in your own VR
app.

Next Lab:
e Implement core functionality and interactions.
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Quiz 1

Lesson Link

Quiz 1- VR Basics - Unity Learn

Length 15 Mins

In this quiz, you will test the knowledge and skills you

learned in Unit 1 related to VR Basics.

This quiz is part of the Create with VR course.

This quiz will assess skills learned in the following

tutorials:

e VR Project Setup
VR locomotion
Grabbable objects
Sockets

# Question

1 If you are targeting a
mobile VR headset (as
opposed to a tethered
headset), which
scriptable render
pipeline (SRP) is most
appropriate?

2 | When a VR Device
claims to support "6
Degrees of Freedom” (6
DOF), what is “6"
referring to?
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Answers
A. The Universal Render Pipeline
(URP)
B. The High-Definition Render
Pipeline (HDRP)
C. The VR Render Pipeline (VRRP)
D. The Mobile Render Pipeline (MRP)
A. The 6 degrees of freedom are:
1. Move head
2. Move left controller
3. Move right controller
4. Rotate head
5. Rotate left controller
6. Rotate right controller
B. The 6 degrees of freedom are:
1. Move up
2. Move down
3. Move left
4. Move right
5. Move forward
6. Move backward
C. The 6 degrees of freedom are:

1. Move along x axis
2. Move along y axis
3. Move along z axis

Explanation

The Universal Render Pipeline
(URP) is a prebuilt Scriptable
Render Pipeline, made by Unity.
URP provides artist-friendly
workflows that let you quickly and
easily create optimized graphics
across a range of platforms, from
mobile to high-end consoles and
PCs. HDRP is not recommended
for VR, since performance is so
critical for user experience.
Mobile and VR Render pipelines
are not real.

The degrees of freedom refer to
the number of axes that are
tracked for position and rotation.
Older headsets were mostly
3DOF, since they would only track
the rotation about the 3 axes, but
not any of the position axis data.
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Which of the following
can be done through the
Package Manager
window?

Select all correct
answers.

You have an empty Unity
scene with only a
Directional Light and a
Main Camera in it.

€ SampleScene

What would happen if
you added an XR Origin
object to that scene?

Listed below are four
types of locomotion that
are possible in VR.

Which two of these are
least likely to induce
simulator sickness?

Select the two correct
answers.

You want to make a ball
that the user can grab
and throw around the
scene. The ball should
bounce off of the walls
and floor.

Which components and
properties would the ball
likely have?

Select all correct
answers.
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o o

4. Rotate about x axis
5. Rotate about y axis
6. Rotate about z axis

Add the XR Interaction Toolkit
package, which enables you to
more easily develop for VR.
Add the XR Plugin Management
package, which allows you to
deploy to different VR devices.
Configure your Build Settings in
order to deploy to your device vs
the device simulator.

Configure whether your scene is
using either 3 DOF (Degrees of
Freedom) or 6 DOF.

The Main Camera is duplicated so
that there is one for each eye.

A new object is added called an
XR Origin and the Main Camera is
made a child object of the XR
Origin object.

The Camera component on the
Main Camera is replaced by an XR
Camera component.

The Directional Light is removed
from the scene, since it cannot be
rendered in VR.

Physical (Room-scale) movement
- the user physically moves in the
real world in order to move in VR.
Continuous (Controller) movement
- the user uses a thumbstick or
D-pad to smoothly move through
the scene.

. Scripted movement - the user is

automatically moved around the
scene, controlled by a script.
Teleport movement - the user
clicks and is instantly transported
to a new location.

A Sphere Collider with “Is Trigger”
enabled.

A Physics Material assigned to
the collider.

"Is Kinematic"” enabled in the
Rigidbody component.

"Use Gravity” enabled in the
Rigidbody component.

An XR Grab Interactable
component with “Kinematic"”
movement type.

Both the XR Interaction Toolkit and
the XR Plugin Management
packages can be added through
the package manager. Build
settings are configured through
the Build Settings window.
Degrees of Freedom are
configured through properties in
your XR Rig.

When you add an XR Origin
object, the Main Camera is
automatically relocated in the
Hierarchy as a child object of the
XR Origin. A new Tracked Pose
Driver component is added to the
Camera, which applies the current
Pose value of a tracked device
(headset) to the transform of the
GameObject.

Simulator sickness tends to occur
when the visual field makes it
appear as if the user is moving,
but the user is not actually moving
in the real world. This illusion is
known as “vection”. Both
Continuous and Scripted
movement have this quality.

If you enable “Is Trigger” for the
collider, the collider will no longer
be able to collide with other
objects.

If “Is Kinematic" is enabled,
Forces (like gravity), collisions or
joints will not affect the rigidbody
anymore. The rigidbody will be
under full control of animation or
script control by changing
transform.position.

Create with VR - Lesson Plans



You made a socket A.

interactor for a phone

charging dock in VR. B.

However, the phone

object is not snapping to C.

the socket.
What could possibly

explain why this is D.

happening?

Select all correct
answers.

In the screenshot below,
you can see the way the
hand should be oriented
when it picks up the
lantern.

The local direction of the
lantern is shown by the
axis gizmos in the image.

Which of the following
orientations for an Attach
Point for this lantern
would achieve the
desired effect shown in
the image?

B.
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A.

The collider does not have "Is
Trigger"” enabled.

The collider is a box collider
instead of a sphere collider.
The socket and the phone
interactable only share one
interaction layer.

The socket has a Rigidbody
component.

Green arrow pointing forwards and

blue arrow pointing right.

Green arrow pointing left and blue

arrow pointing forward.

In order for a socket to detect
another interactable object, its
collider needs to have “Is Trigger”
enabled.

Otherwise, the collider will act like
a solid object that cannot overlap
with other objects.

If you are holding your right hand
out in a fist with your thumb
straightened as if you are giving a
"thumbs up" signal, the front of
your fist should align with the blue
(Z axis) and your thumb should
align with the Y (green) arrow.
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9 | Which of the following is
true about mobile vs
tethered headsets?

Select all correct
answers.

10 | What does “"XR" stand
for?

© Unity 2021

C.

Oow>

Green arrow pointing forward and
blue arrow pointing down.

Green arrow pointing forward and
blue arrow pointing up.

A mobile headset can support
higher-end graphics than tethered
headsets.

A tethered headset gets its
processing power from a gaming
console or computer.

A tethered headset supports 6
degrees of freedom (6DOF), while
mobile headsets do not.

Some mobile headsets can be
plugged in and operate as
tethered headsets.

Extreme Reality
Extra Reality
External Reality
None of the above

A tethered headset is plugged into
a more powerful computer or
console, which provides all of the
processing power. This allows
tethered headsets to support
higher-end graphics.

The lines between these types of
devices is sometimes blurred with
devices that can act as mobile
and tethered devices.

XR refers to any technology that
blurs the line between real and
digital worlds. The Xis a
placeholder letter for various
types of these technologies,
including VR (Virtual Reality), AR
(Augmented Reality), and MR
(Mixed Reality). There is debate
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over what the X stands for, some
claiming the X stands for
eXtended Reality.
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Unit 2 - Events & Interactions

ton to get started

press the OK but

Unit Link 2 - VR Events and Interactions - Unity Learn

Length 9 Hours 15 Min

In this unit, you will implement more complex interactions in VR based to make the experience more immersive.
In these tutorials, you will:

Implement audio and haptic feedback

Apply new functionality to specific objects

Allow the user to toggle between multiple types of interactors

Add user interfaces to world

In the Challenge for this unit, you will apply your skills in a 3D painting prototype. Then, in the Lab, you'll
implement the core functionality of your personal project. Finally, in the Quiz, you will test your new knowledge.

This unit is part of the Create with VR course.
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Lesson 2.1 - Audio and Haptics

Lesson Link 2.1 - Audio and Haptics - Unity Learn

Length 1Hours 30 Mins

Project Objective:

In this lesson, you will learn how to increase the
immersion of your project through touch and audio
stimuli. By the end of this lesson, the user will receive
haptic and auditory feedback when they hover over or
grab an object. There will also be 3D spatial ambient
sound in the scene.

This lesson is part of the Create with VR course.
Learning Objectives:

By the end of this lesson, you will be able to:
e Implement haptic vibrations or sound effects

on controller-based events in order to provide
tactile or auditory feedback to the user in
certain situations (e.g. when the user hovers
over or selects something).

e Understand the difference between 3d and 2d
audio (diegetic vs non-diegetic) in Unity in
order to distinguish scenarios where each
might be appropriate.

e Modify the spatial blend of an audio source in
order to change it from 2D to 3D sound.

e Modify the roll-off of an audio source in order
to specify how it should change in volume as
distance from the source increases.

e Implement reverb zones in a specific area of a
scene in order to better simulate the quality of
sound in different environments (e.g. a cave vs

a living room)

e Understand the purpose of audio spatializer
plugins in order to appreciate the importance
of realistic audio in VR.

Step
Step 1- Add

haptics on hover
and select

© Unity 2021

Instructions

You can add haptic on hover enter and select enter to provide
physical feedback to the player's hands.
1. Edit both controller objects at the same time:
e Inthe Hierarchy, expand XR Rig > Camera Offset.
e Ctrl/Cmd+select both the RightHand Controller and
LeftHand Controller so they are both selected.
2. Locate the haptic events:
e At the bottom of the Controller objects’ XR Ray Interactor
components, expand the Haptic Events fold-out.
3. Create subtle haptic feedback when the user hovers over an
object:
e Click the On Hover Entered check box to enable it.

Teacher Notes

Warning: If you
make the vibrations
long, it stops being
meaningful and
also gets very
annoying.
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e Set the Intensity to a low value (e.g. 0.1-0.5).
e Set the Duration to a very low value (e.g. 0.1 seconds).
4. Create more noticeable feedback when the user grabs an
object:
e Select the On Select Entered check box.
e Set the Intensity and Duration values to slightly higher
values (e.g. 0.25 seconds).

Haptic Events

On Select Entered
Haptic Intensity
Duration

On Select Exited

On Hover Entered
Haptic Intensity
Duration

On Hover Exited

The controller should now vibrate subtly when you hover over an
object and slightly more so when you select an object.

Step 2 - Add audio
on hover or select

Now that you have haptic feedback, you can enhance the User
Experience (UX) with audio feedback.
1. Select the sound you want to use:

e From the Course Library > Audio > FX, determine which
subtle Ul sound effect you want for the hover or select
event.

e To preview the sound, you may need to drag up the Preview
panel from the bottom of the Inspector window.

2. Apply this sound effect to both controllers:

e From the Hierarchy, select both the RightHand Controller
and LeftHand Controller objects.

e Inthe XR Ray Interactor component, expand the Audio
Events fold-out.

e Click to enable either the On Select Entered or the On
Hover Entered setting.

e and then assign your chosen sound effect.

Audio Events
On Select Entered v
AudioClip To Play 52 SFX_UI_Click_3

On Select Exited

On Hover Entered
On Hover Exited

You should now hear a sound effect either when you hover over an
object, or when you select an object.

Step 3 - Add 3D
audio from the
fireplace

© Unity 2021

In addition to audio feedback on events, you can add 3D spatial
audio into the scene emanating from the fireplace to increase
immersion.

Warning: Want this
to be subtle and not
get in the way - you
just want to alert
the player that
something has
happened.

Demo: Might need
to pull up the
preview window to
play sound.
Warning: Do not
apply a sound for
hover AND select -
it will likely be
annoying for the
user.

Explain: Difference
between 2d and 3d
sound.
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Step 4 -Adda
reverb zone

© Unity 2021

1. Give the fire a sound effect:

e Add an Audio Source component to the particle object.

e For the AudioClip property, assign the SFX_Loop_Fire
sound effect from the Course Library > Audio > FX folder.

2. Make the sound play automatically and loop:

e |nthe Audio Source component, make sure both the Play on
Awake and Loop settings are enabled.

3. Configure this component as a 3D sound:

e Adjust the Spatial Blend property by dragging the slider all
the way to the right 3D setting (or by setting the slider to 1).

4. Edit the overall volume and volume roll-off of the fireplace:

e Edit the Volume property.

e Expand the 3D Sound Settings fold-out, then adjust the Min
Distance and Max Distance values.

Py Particle System

i{ v Audio Source

AudioClip

Output

Mute

Bypass Effects

Bypass Listener Effects
Bypass Reverb Zones
Play On Awake

Loop

Priority
Volume

Pitch

Stereo Pan
Spatial Blend

Reverb Zone Mix

The fireplace should now make a crackling sound, which should
change in volume and left/right balance depending on where you
are located and oriented in the scene.

Related resources:
- Audio Source Settings

7 SFX_Loop_Fire

None (Audio Mixer Group)

To maintain a sense of presence in VR, it's especially important to

make sure audio behaves the way it would in the real world. This

includes considering how sounds might reverberate around

different kinds of rooms.

1. Add a new Audio Reverb Zone as a child of the Room object:

e Inthe Hierarchy, right-click the Room_[style] object.

e Click Audio > Audio Reverb Zone.

2. Make sure the reverb zone encompasses your whole room:

e Inthe Audio Reverb Zone component, make sure the Min
Distance property is set to at least the width of your room

(10).

Explain - you can
mess with the
Volume Rolloff, but
the default tends to
be fine.

Explain: Min
Distance is the
distance you can be
from the Audio
Source before it
starts to decrease.

Explain: What is a
reverb zone?
Explain - We don't
need a transition
from reverb zones,
so the Max value
isn't important - we
just care that the
min value is larger
than the size of the
room.
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Step 5 - [Optional]
Experiment with
spatializer plugins

© Unity 2021

e Note: To visualize the zone, you may need to turn on
gizmos and zoom out.
In Unity 2021LTS, the Gizmos button is represented by a
sphere icon with dots on its vertices:

3. Make your reverb zone match your room:
e Use the Reverb Presets drop-down to experiment with
different styles of reverb.
e Select a setting that matches your room (Room or Living
Room).

& v Audio Reverb Zone

MinDistance
MaxDistance Iis)

ReverbPreset Livingroom

You should now have a reverb zone set up in your room to make
the 3D sound even more realistic.

Related resources:
- Audijo Reverb Zones

[Optional]
In addition to Unity’s built-in 3D sound, which changes the volume
in the left and right ears depending on player distance and
orientation, there are additional spatializer plugins that you can
install to make the sound even more realistic.
1. Download and import a plugin:
e From the links below, download the relevant spatializer
plugin for your platform.
e Import the package into your project.
2. Enable the plugin:
e Click Edit > Project Settings.
e Select the Audio section from the left panel.
e Use the drop-down next to Spatializer Plugin to select your
plugin.
3. Implement the plug-in on your fire particle:
e Follow the instructions relevant to your device to implement
spatialized audio.

Demo: To visualize
the zone, you may
need to turn on
gizmos and zoom
out.

Warning: This is
not necessary - for
the most part, the
default 3d setting
will get the job
done.

Explain: How is this
different from the
default setting? If
you put a
microphone in
someone’s ear, it
sounds different
from if the mic were
outside the ear -
that diff is the HRTF
(head related
transfer function).
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Recap

Extensions

Extension - Add a
speaker

© Unity 2021

[ X} Project Settings
£ Project Settings

Audio Audio
Editor

Graphics Global Volume
Input Manager

Input System Package
Package Manager

Volume Rolloff Scale
1

Physics a e d Stereo

Physics 2D Sys 2a 0

Player

Preset Manager

Quality

Script Execution Order /ol 32

Services g er P None
Ads
Analytics
Cloud Build
Cloud Diagnostics 7
Collobors

Best performance
512

jer Plugin None

You should now have even more realistic sounding audio in your
scene, taking into account the user’'s Head Related Transfer
Function (HRTF).

Related resources:

- Unity Audio Spatializer
- Downloads

- Oculus Spatializer
- Microsoft HRTF Spatializer (supports UWP and PC
running Windows 10)
- Oculus Spatializer Info
- Oculus 3D Audio Spatialization Guide
- Oculus Spatializer Features
- Apply Spatialization in Unity

New Functionality:
- Haptic feedback on controllers
- Audio feedback on controllers
- Realistic 3D Audio from fireplace
New Concepts & Skills:
- Importance of haptics and audio for immersion
- 3dvs 2d audio
- Reverb zones
- Spatialized audio with head-related transfer function (HRTF)
Technical Skills:
- Audio & Haptic events

If you want to further develop your skills, explore new concepts, and improve your
project, check out some of the optional extension activities below.

Each one is tagged as [Easy], [Medium], [Difficult], or [Expert] and will also include a
[Requires Programming] tag if some coding is required.

1. Add a speaker [Easy]
Add a speaker to the room that plays music - or even a record player that actually rotates:
e Find a speaker from the Course Library > Prefabs > Objects > Speakers folder.
e Find music options from the Course Library > Audio > Music folder.
e Bonus - If you use the Record Player, you'll need a simple script to rotate the
platter the record spins on.
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Extension - Ball
bouncing sounds

© Unity 2021

See lesson related videos here

2. Add realistic bouncing sounds [Medium] [Requires programming]
Add a bouncing sound for your ball so that you hear it bounce every time it hits the floor:
e You may want to download and import a new sound effect
e Add a 3d audio source to your ball just like you did for your fireplace.
e To make it play a sound when it hits the ground, you will probably want to use the
OnCollisionEnter function and PlayOneShot method.
e Bonus - if you want to make the volume change based on the speed the ball is
moving, try using rigidbody.velocity.magnitude.

See lesson related videos here
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Lesson 2.2 - Activation Events

Lesson Link 2.2 - Activation Events - Unity Learn
Length 1Hours 30 Mins

Project Objective:

In this lesson, you will learn how to add unique
functionality to an object when the user interacts with
it in a certain way. By the end of this lesson, users will

be able to pick up a remote and press a button on a
controller toturnona TV.

This lesson is part of the Create with VR course.

Learning Objectives:

By the end of this lesson, you will be able to:
Trigger actions based on interactions with a specific
object in order to add additional functionality to an

object (e.g. when an object is selected, when it is

activated, etc).

Step
Step1-Add a

grabbable remote
control
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Instructions

Up to this point, you have only been able to pick up and put
down objects. Now, you will add an object that you can do
something with - or "activate” - once it's in your hand.

1. Add a remote control to your scene:

e Go to Course Library > Prefabs > Objects >
Electronics,

e Drag the “"Remote"” prefab object onto a surface in your
scene.

2. Allow the object to be picked up:

e Add a Rigidbody component with Collision Detection set
to Continuous Dynamic so it doesn't fall through the
floor.

e Add an XR Grab Interactable component.

3. Position the remote correctly in the player’s hand when it

is picked up:
e |n the Remote object, create a new, empty "Attach”
child object.

e Position and orient the Attach object appropriately.
e Assign the Attach object to the Attach Transform
property in the XR Grab Interactable component.

Create with VR - Lesson Plans

Teacher Notes

Explain: You probably
want the remote to be
more vertical in your
hand rather than
pointing straight ahead
so that you have to tilt
your hand forward to
use it.

Warning: It's very easy
to forget to actually
assign the attach point
to the XR Grab
Interactable.
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Step 2 -Play a
sound when the
remote is
activated

© Unity 2021

EA  XRGrab Interactable

Interaction Manager B XR Interaction Manager (XR Interaction ®
Interaction Layer Mask Default v

Colliders

Movement Type Kinematic
Retain Transform Parent v
mbined Track Position v
Smooth Position v
Smooth Position Amount
Tighten Position
Track Rotation
Smooth Rotation
Smooth Rotation Amoun
Tighten Rotation
Throw On Detach v
Throw Smoothing Duration 0.25
Throw Smoothing Curve
Throw Velocity S 1.5
) Indicator_Light

@ Attach

Rac

Throw Angular Vi ywSc 1
Gravity On Detach

Attach Transform A Attach (Transform)

Attach Ease In Time 0.15

You should now be able to pick up the remote in a way that
looks natural.

Now you will make the remote make a click sound when you
are holding it and press the trigger.
1. Allow the remote to emit sound:

e On the Remote object, add an AudioSource component

e In the AudioSource component, slide the Spatial Blend
property all the way to full 3D ("1") to allow for 3D audio.

2. Give the remote the ability to play a sound:

e Add a Play Quick Sound component to the remote.

e For the Sound property, assign an audio clip you want
from the Course Library > Audio folder.

3. Locate the remote’s “Activated” event:

e At the bottom of the remote's XR Grab Interactable
component, expand the Interactable Events fold-out to
see all of the event options.

e Locate the Activated event

4. Play a sound when the remote is activated:

e Inthe Activated event, click the + to add a new action.

e Drag and drop the Remote object to the empty Object
slot in order to access its components.

e Click the No Function drop-down to select a function,
then select Play Quick Sound > Play ().

On Activate (XRBaselnteractor)

Runtime Only v PlayQuickSound.Play

Remote (Play Quick ®

On Deactivatel(XRBaselnteractor)

Listis Empty

EA  Play Quick Sound (Script)

Sound 7 SFX_UI_Click 1

Volume 1

Random Pitch Variance

Demo: What are the
other interactable
events (On Hover,
Select Enter, Activate,
etc)?

Explain:
PlayQuickSound is one
of the custom scripts
that we provided for
this project - all of
these are located in the
Course Library >
Scripts > Actions folder.
Demo: If you are
familiar with
programming, check
out the scripts - you
can use themasa
template for creating
your own. If you're not
a programmer, no
problem - you can still
read through them and
read comments to see
what's going on.
Demo: Open the
PlayQuickSound script
and show them that
there are functions in
the script that we'll get
to choose from

Demo: If you open the
XRI Default Input
Actions objects, you
can see that the
activate action is
binded to the trigger
button.
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Step 3 - Flash a
red light when the
remote is
activated

Step 4 - Allow the
TV to play video

© Unity 2021

With the remote in your hand, you should now be able to press
the activate button, the controller trigger, and hear a sound.

To provide additional feedback that the remote has been
pressed, you can also turn the indicator light red when the
remote is activated.

1. Add the capability for the indicator light to turn red:

e |n the Hierarchy, expand the Remote object and select
the Indicator_Light child object.

e Add a Change Material component.

e Assign a Red material to the "Other Material” property.

2. Change the material color to red when the trigger is
pressed:

e On the Remote parent object, at the bottom of the XR
Grab Interactable component, expand the Interactable
Events fold-out to see all of the event options.

e Inthe Activated event, click the + to add a new
function.

e Assign the Indicator Light child object to the Object
property.

e Click the No Function drop-down to select a new
function, then click Change Material >
SetOtherMaterial () function.

3. Make the material revert when the activate button is

released:
e In the Deactivated event, click the + to add a new
action.

e Assign the Indicator_Light object, then select the
Change Material > SetOriginalMaterial () function.

On Activate (XRBaselnteractor)

Runtime Only
B Remote (Play Quick S

v PlayQuickSound.Play

hangeMaterial.SetOtherMaterial

B Indicator_Light (Change ©®

On Deactivate (XRBaselnteractor)

Runtime Only ¥  ChangeMaterial.SetOriginalMaterial
B Indicator_Light (Change ®

When you activate the remote, the indicator light should turn

red and then revert to its original color when the activate button

is released.

Before you get the button set up to turn the TV on, you should
make sure the TV in the scene can successfully play video.
1. Allow the tv to emit 3D audio:
e Inthe Hierarchy, select the Screen child object of the
Television.
e Add an Audio Source component.
e Drag the Spatial Blend property to full 3D (1.0) to
enable spatial audio.
2. Allow the TV to play video:
e On the Screen child object, add a Video Player
component.
e Change the Material Property to _BaseMap (instead of
_MainTex) to project the video to its material rather than
its texture.

Explain: You could
toggle an actual red
light, but you should
avoid realtime light
changes whenever
possible.

Demo: Open the
ChangeMaterial.cs
script and show them
that there are functions
in the script that we'll
get to choose from
Explain: Deactivated -
this is when the trigger
is released.

Explain: These videos
are low resolution to
keep the size of the app
down. You could get
your own videos if you
want - you just need to
make sure you have the
rights to use it.

Explain: The PlayVideo
script is one we supply
for yout to add
additional
play/pause/next
functionality.
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3. Add additional video control functionality:
e On the Screen child object, add a Play Video
component.
e Select the Play At Start check box to play the video
automatically.
4. Select the video to play on the screen:
e Inthe Play Video component, expand the Video Clips
fold-out.
e Set the list Size property to 1 and press Enter to reveal
an empty Video Clip slot.
e Assign one of the videos from the Course Library >
Videos to the Video Clip property.

o4 v Video Player

Source Video Clip

Video Clip None (Video Clip)
Play On Awake 4

Wait For First Frame v

Loop

Skip On Drop v

Playback Speed L

Render Mode Material Override
Renderer f8 Screen (Mesh Renderer)
Material Property _BaseMap

Audio Output Mode Audio Source

1, v Audio Source
EA v Play Video (Script)

Play At Start v
Video Material ® Universal Render Pipeline/Unlit
Video Clips

Element 0 “\/ideo_Unity-for-everyone

Now when you run your application, the video should play
automatically on the TV Screen with 3D audio.

Step 5 - Control Now that the TV is working, you need to be able to control it Demo: Open the
the TV with the with the remote. PlayVideo script to see
remote 1. Stop the video from playing automatically: the functions within.
e Inthe Play Video component, clear the Play At Start
check box.

2. Locate the Remote’s Interaction events:

e Select the Remote GameObject.

e Inthe XR Grab Interactable component, expand the
Interactable Events fold-out to see all of the event
options.

3. Trigger the TV when the remote is activated:

e In the Activated event, click the + to add a new action.

e Assign the Screen object to the empty Object property,
since it has the Play Video script.

e Click the No Function drop-down and select the
PlayVideo > TogglePlayPause () function, or the
PlayVideo > TogglePlayStop () function, depending on
whether you want it to pause or stop when pressed a
second time.
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On Activate (XRBaselnteractor)
Runtime Only. v PlayQuickSound.Play
B Remote (Play Quick SoL ®

Runtime Only v ChangeMaterial.SetOtherMaterial
Indicator_Light (Change ®

Runtime Onl v PlayVideo.TogglePlayPause
®

B Screen (i

On Deactivate (XRBaselnteractor)

Runtime Only ChangeMaterial.SetOriginalMaterial
Indicator_Light (Change ©

When you activate the remote, the video on the TV should
alternate between playing and pausing or stopping.

Recap New Functionality:

Grabbable remote

- Play sound action

- Change material action
Play video action

New Concepts and Skills:
- Object activation
- Events & actions
- Scripts & functions

Next Lesson:
- Direct and Ray Interactors

Extensions If you want to further develop your skills, explore new concepts, and improve your
project, check out some of the optional extension activities below.
Each one is tagged as [Easy], [Medium], [Difficult], or [Expert] and will also include a
[Requires Programming] tag if some coding is required.

Extension - Adda | 1. Add a phone that plays video [Easy]
phone that plays Make a phone that plays a video when you press the trigger:
video e You can find phone prefabs from the Course Library > Prefabs > Objects >
Electronics folder.
e You will need to make a new separate "“screen” child object with a material similar
to the way the TV screen is set up.

e Bonus: Try making the phone cycle through multiple videos using the Play Video
> NextClip () function.
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See lesson related videos here

Extension - Adda | 2. Add a functioning flashlight [Medium]
functioning Add a working flashlight into the scene that toggles on and off when you press the trigger,
flashlight including making a clicking sound to provide audio feedback:

e You will need to add a child SpotLight object to the flashlight.

e Try using the ToggleLight > Flip () function to flip the light on and off.

See lesson related videos here

Extension - Adda @ 3. Add a dart gun or stapler projectile [Expert]
dart gun or stapler = Add a dart gun that shoots darts or a stapler that shoots staples when you press the
projectile trigger:
e Locate the prefabs for the objects and projectiles in the Course Library > Prefabs
> Objects > Launchers folders
e Use the LaunchProjectile script provided in the Course Library
e If you want, use the DestroyObject script provided in the Course Library to make
the projectile disappear after a certain amount of time.
e Bonus: Make the stapler swing open with a hinge joint
e Bonus: Add sounds for when the object is launched
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Extension - Add a
functioning
polaroid camera
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See lesson related videos here

4. Add a functioning polaroid camera [Expert] [Requires Programming]
Add a functioning polaroid camera that allows you to preview on a viewfinder screen and
print a photo using the trigger:

For the viewfinder screen, look at how the mirror is set up with a render texture.
Look at the documentation for Camera.Render().

Don't worry if the camera is currently rendering your rays for now - we'll learn
how to hide your rays in the next tutorial.

If you want some help, download an example script for the polaroid camera and

the photo

See lesson related videos here
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Lesson 2.3 - Direct and Ray Interactors

Lesson Link 2.3 - Direct and Ray Interactors - Unity Learn

Length 1Hours 30 Mins

Project Objective:

In this lesson, you will learn how to implement Direct
Interactors and how to switch between interactors on
the same controller. By the end of this lesson, the user
will be able to grab things directly with their hands,
and then toggle a ray to point at things when they

need to.

This lesson is part of the Create with VR course.

Learning Objectives:
By the end of this lesson, you will be able to:
e Implement direct interactors on a controller in

order to allow a user to pick things directly
with their hands.

e Understand the need for a variety of interactor
types in VR in order to allow the user to
interact with the environment in different ways.

Toggle between multiple types of interactors on one
controller in order to expand the range of actions a
user can do with a single hand (e.g. switch between a
ray and direct interactor).

XR Interactor Line Visual component, the Line Renderer
component, and the XR Ray Interactor component.
2. Enable direct interactions on the right controller:
e Add a XR Direct Interactor component to the RightHand
Controller.
e Select the Hide Controller on Select check box to have the
object you pick up replace your hand visual.
3. Enable detection of the Direct Interactor:
e Add a Sphere Collider component.
e Select the Is Trigger check box.
e Reduce the Radius to 0.05.

Step Instructions Teacher Notes

Step 1- Add a | Rather than using the ray interactors that come by default with the rig, | Explain: What is a
direct you can set up a “Direct” interactor for one of the controllers. Direct interactor?
interactorto | 1. Remove the Ray Interactor from the right controller: Explain: We'll be doing
the right e In the Hierarchy, select the RightHand Controller object. this for both hands,
controller e Remove the three components related to the ray interactor: the | we're just starting with

one for now so we can
make sure we get all
the settings right.
Demo: It won't let you
add a Direct Interactor
on the same controller
as the Ray Interactor
Warning: You have to
remove the
components from
bottom to top or Unity
will get mad at you
because of
dependencies

© Unity 2021
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@ XRRig
@ Camera Offset
& Main Camera
& LeftHand Controller
&3 RightHand Controller

v XR Controller (Action-based)
v XR Direct Interactor

Interaction M B XR Interaction Manager (XR Interaction Manager)
Everything

None (Transform)

State

v

None (XR Base Interactable)

Audio Events

Haptic Events

Interactor Events

& .~ Sphere Collider

Edit Collider

Is Trigger %

Material
Center X 0 Y 0
REGITS 0.1

None (Physic Material)

You should now be able to pick up all the grabbable objects in your
scene using the hand with the direct interactor.

Step 2 - Add | Just like you did for the ray interactor, you should add the same haptic | Explain: Unfortunately
haptics and and audio feedback for hovering over and selecting objects. can't paste component
audio to the 1. Recall how you set up haptic and audio feedback originally: values from ray to
direct e From the Hierarchy, select the LeftHand Controller object direct - you just have
interactor (which should still have a Ray Interactor component). to do it manually.
e In the XR Ray Interactor component, expand the Audio Events
and Haptic Events foldouts.
e Note the intensity and duration of your haptic events and the
audio clip you selected for your Audio events.
2. Apply haptic and audio event settings to your new Direct
Interactor:
e From the Hierarchy, select the RightHand Controller object.
e In the XR Direct Interactor component, apply the same haptic
and audio event settings to match your other controller.
Audio Events
On Select Entered v
AudioClip To Play & SFX_UI_Click_5
On Select Exited
On Hover Entered
On Hover Exited
Haptic Events
On Select Entered
Haptic Intensity
Duration
On Select Exited
On Hover Entered
Haptic Intensity
Duration
On Hover Exited
Your Direct Interactor should now have haptic and audio feedback on
hover and select events.
Step 3 - Right now, you can pick up everything with your ray, which doesn't Explain: Let's not use

Prevent ray
from picking
up objects

feel natural. You should only be able to teleport with your ray and pick
up objects with your hand directly.
1. Add a new layer for your Rays:
e In your other hand's XR Ray Interactor component, from the
Interaction Layer Mask drop-down, select Add Layer.

Ignore Raycast
because it's a negative
(double-negative is
confusing) - if we're
using the affirmative

© Unity 2021
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[

e Add a new "Raycasts” layer in the first available empty slot.

e Note: Your Ray Interactor will not yet be set to that layer. You
have only created the layer at this point.

2. Prevent your ray from interacting with your grabbable objects:

e Still on your controller object’s XR Ray Interactor component,
for the Interaction Layer Mask property, assign only the
Raycasts layer.

e To do this, you need to first select “Nothing” and then
re-select the "Raycasts” layer.

[

3. Make sure your ray can interact with teleport objects:

e For each Teleportation Anchor and Teleportation Area object,
in the Interaction Layer Mask property, make sure the
Raycasts layer is enabled.

4. Prevent your hand model from disappearing when you teleport:

e Inthe XR Ray Interactor component, disable the Hide
Controller On Select setting.

Note: If you can still use your ray to pick up objects, make sure your
grabbable objects are not on the Raycasts Interaction Layer.

B v XRRay Interactor

Interaction Manager B XR Interaction Manager (XR Interaction Manager)
Interaction Layer Mask Raycasts

Enable Interaction with Ul GameObjects v
Force Grab v
Anchor Control

Attach Transform None (Transform)

Raycast Configuration
Line Type Straight Line
Max Raycast Distance 30

Raycast Mask Everything
Raycast Trigger Interaction Ignore
Hit Detection Type Raycast

Selection Configuration
Select Action Trigger State
Keep Selected Target Valid v
Hide Controller On Select
Hover To Select

Starting Selected Interactable None (XR Base Interactable)

Teleportation Anchor (Script)

Interaction Manager None (XR Interaction Manager)
Interaction Layer Mask Raycasts

Your ray interactor should no longer be able to pick up objects, but
should be usable for teleporting.

"Hats" - let's be
consistent with our
layering system.

Step 4 -
Create a
direct and ray

In order to be able to pick up objects with both hands, you should
have direct interactors on both hands. Then you can just enable the
ray when the joystick is moved. To achieve this, you will need to
create the Direct and Ray interactors for each hand.

Explain: This is a very
common interaction in
VR - joystick toggles
Ray.

© Unity 2021
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interactor for | 1. Make alternative ray controllers for each hand: Explain: This is just a
each hand e Duplicate the controller with the Ray Interactor two times. temporary setup until
e Renaming these objects “LeftHand Ray” and "RightHand Ray”. | we get the toggle
2. Control each ray with the correct hand: functionality.
e For your new RightHand Ray and LeftHand Ray objects, in the | Demo: Show that both
XR Controller component, make sure the Input Action types of interactors
References preset is set correctly to Left or Right for each are now usable on
object. both hands
e To edit the preset, in the top-right of the component, click the | simultaneously.
Presets button and select the appropriate preset for the hand.
3. Make the LeftHand Controller behave as a Direct Interactor:
e On the LeftHand Controller object, remove the components
related to the Ray interactor (the XR Ray Interactor component,
the Line Renderer component, the XR Interactor Line Visual
component).
e Copy the Direct Interactor and Sphere Collider components
from the RightHand Controller to the LeftHand Controller.
Note: To copy a component:
e Select the context menu in the top-right of that component
and click Copy Component.
e To paste the component on another object, select a context
menu of one of the receiving object's components and click
Paste Component As New.
4. Make sure that you only have one hand model for each hand:
e On your new LeftHand Ray and RightHand Ray objects, in the
XR Controller component, change the Model Prefab object to
None.
&2 XR Rig v XR Controller (Action-based)
€9 Camera Offset
@ Main Camera
@@ LeftHand Controller TaCRin @ Select Preset
gfgm:igig;mm”e' L;)date?lackfng Type Updi o\‘
@ RightHand Enable Input Tracking v None
==== LIGHTING = & XRI Default Left Controller
STATIC (s = XRI Default Right Controller
==== DYNAMIC = Enable Input Actions v
Position Action
Use Reference
Reference ference)
Rotation Action
Use Reference
Reference ference)
Select Action
Use Reference
Reference
Activate Action
Use Reference
Reference ference)
Ul Press Action
Use Reference
Reference Save current to... ference)
Each hand should now be able to teleport with their Ray Interactors
and grab objects with their Direct Interactors.
Step 5 Now that you have both Direct and Ray Interactors on each hand, you | Explain: What are
-Toggle ray will add the ability to toggle the Ray on and off when a button is bindings?
with button pressed. Explain: ToggleRay is
press 1. Add the ability to toggle the left ray: a custom script. It only
e On the LeftHand Ray object, add a Toggle Ray component. adds this potential
e For the Direct Interactor property, assign the LeftHand behavior - you still
Controller object. have to call it on some
2. To be able to detect if a button is pressed: event (on button
e On the LeftHand Controller object, add an On Button Press press).
component.

© Unity 2021
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3. Specify the button to bind to this action:
e In the On Button Press component, in the Action box, click the
+ and choose Add Binding (Note: It is very easy to miss the
Action box - look closely).
e Double-click where it says No Binding.
e In the Path drop-down, select XR Controller > XR Controller
(Left Hand) > Optional Controls > primaryButton.
4. Activate the ray when the button is pressed:
e Inthe On Press event, click the + to add a new action.
e Assign the LeftHand Ray object, since it has the Toggle Ray
component.
e From the function drop-down, select the ToggleRay >
ActivateRay () function.
5. Deactivate the ray when the button is released:
e Inthe On Release event, click the + to add a new action.
e Assign the LeftHand Ray object.
e Select the ToggleRay > DeactivateRay () function.

Q
(D Camera Offset v On Button Press (Script)
@ Main Camera
& LeftHand Controller
& RightHand Controller Action
(D LeftHand Ray I primaryButton [LeftHand XR Controller]
D RightHand Ray

On Press ()

Runtime Only v ToggleRay.ActivateRay
LeftHand Ray (Toggle Ra ©

On Release ()

Runtime Only v ToggleRay.DeactivateRay
B LeftHand Ray (Toggle Ra ®

The ray on the left hand should now only appear while the primary
button is touched and disappear when the button is released.

Step 6 - Add | One controller is working with one button. You can give the player Warning: If your

an additional | more options of buttons to push depending on their preference, and controller batteries are

binding and then apply this functionality to the other hand. low or your joystick is

repeat for 1. Add an additional binding that detects the thumbstick: malfunctioning, this

other hand e Inthe On Button Press component, in the Action box, click the | behavior may not work
+ button to add an additional binding to this action. as expected.

e Follow the same instructions as the previous step to select a
binding, but select select XR Controller > XR Controller (Left
Hand) > Optional Controls > thumbstickTouched instead of
primaryButton.

2. Add this same ray toggling functionality for your right hand:

e Repeat all of the instructions from the previous step, but for
your RightHand Controller and RightHand Ray:

o Add a Toggle Ray component to the RightHand Ray
and assign the RightHand Controller to the Direct
Interactor property.

o Add an On Button Press component to the RightHand
Controller and add bindings for the Right Primary
Button and Right Thumbstick

o Inthe On Press event, call the Toggle Ray >
ActivateRay() function on the RightHand Ray object.

o Inthe On Release event, call the Toggle Ray >
DeactivateRay() function on the RightHand Ray
object.
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&P Main Camera

@ LeftHand Controller
& RightHand Controller
D LeftHand Ray Action
& RightHand R

B v OnButton Press (Script)

I primaryButton [RightHand XR Controller]

STATIC thumbstick Touched [RightHand XR Controller]

P ==== DYNAMIC = = On Press ()

Runtime Only v ToggleRay.ActivateRay
RightHand Ray (Toggle R ®

On Release ()
Runtime Only v ToggleRay.DeactivateRay

BRightHand Ray (Toggle R @

The rays on both hands should now only appear while the primary
button or thumbstick are touched.

Recap

Extensions

Extension -
Customize
theray
interactor
lines

Extension -

Watering can

© Unity 2021

New Functionality:
- Direct interactors on each hand
- Toggle direct interactors on/off with button

New Concepts and Skills:
- Direct vs Ray interactors
- Detect button press

Next Lesson:
- User Interfaces

If you want to further develop your skills, explore new concepts, and improve your project,
check out some of the optional extension activities below.

Each one is tagged as [Easy], [Medium], [Difficult], or [Expert] and will also include a [Requires
Programming] tag if some coding is required.

1. Customize the ray interactor lines [Easy]
Edit the Ray Interactor line colors and transparency colors, including gradients and
transparency:
e Itlooks good to make the start of the ray transparent so it doesn't overlap with your
hands.
e To customize the colors of the rays, look in the XR Interactor Line Visual components
Valid and Invalid color gradient properties
e In the Gradient Editor window, use the markers below the color bar to edit the color and
the markers above the color bar to edit the transparency (Alpha) value.

ent Editor

Blend

See lesson related videos here.
2. Add a functional watering can [Medium]

Add a watering can that generates a water particle when you tilt it:
e Use the OnTilt script provided from the Course Library > Scripts > Conditions folder to
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Extension -
Door hinges

© Unity 2021

7 N

detect tilting.

Find a Particle_Water object from the Course Library > Prefabs > Particles folder
Use the ToggleParticle > Play() and Stop() functions to control the particle.
Bonus - Add in pouring sound effect using the PlayContinuousSound script.
Bonus - Use the OnVelocity script to also add a splashing sound when you shake it -
Hint: add a separate audio source for this to not interfere with the pouring sound.

See lesson related videos here.

3. Add hinges to cabinet doors [Expert]
Allow the user to open cabinet doors or chest lids using Unity's physics hinges:

You will need to add a Hinge Joint and rigidbody to the door, and customize its angular
limits

You will need to add an XR Grab Interactable component to the handle and may want to
add a Eixed Joint connected to your door's rigidbody.

Make sure your door’s colliders do not overlap any other colliders, which could cause it
to get stuck.

Warning: joints are very tricky and can be frustrating.
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See lesson related videos here.
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Lesson 2.4 - User Interfaces

4 face - Unj

1Hours 30 Mins

Lesson Link

Length

In this lesson, you will learn how to implement world
space user interfaces in VR. By the end of this lesson,
the user will be greeted by a welcome screen that
provides basic instructions. They will also be able to
bring up a simple reset menu that allows them to
reload the scene.

This lesson is part of the Create with VR course.

Learning Objectives:
By the end of this lesson, you will be able to:

e Recall best practices for Ul in VR in order to
design an experience that is comfortable and
intuitive for the user.

e Add a simple world space Ul into the scene
with text and a button in order to allow the user
to read and interact with a user interface.

Step Instructions
Step1-Adda
world space Ul

into the room 1. Add a new Canvas to your scene:

Welcome to your VR Room!

Click the Next button to continue.

To create some welcome screen text, the first thing you need to do
is add a canvas with text and position it in the room.

e Add a new empty object in your Hierarchy, reset its position,

and rename it "INTERFACE".

e Create an XR > Ul Canvas object within that organizer

object.

2. Position the canvas appropriately in the room:
e Inthe Canvas’' Rect Transform component, set the XYZ

Scale to 0.01.

e Setthe Pos Y and Pos Z properties so the canvas is at the

back of the room

3. Add a semi-transparent black background for the Ul:
e |n the Hierarchy, create a Ul > Image and rename it

“"Welcome Background”.

e |nthe Image component, click the Color box.

e Change the color to black.

e Use the Alpha (A) slider to reduce the color’s transparency.
4. If your windows are rendering on top of your text:

e In the Canvas component, set the Order in Layer property to

M’III'
5. Add text to the panel as a child object:

e |n the Hierarchy, right-click Welcome Background and
create Ul > Text - TextMeshPro as a child object.
e Note: you may have to click "Import TMP Essentials” if

prompted.

© Unity 2021

Teacher Notes

Explain: This will
add an Event
System object.
Explain: Since it's
an XR canvas, it
will be
“"Worldspace" by
default (instead of
“Screen space”
Explain: Screen
space - overlay vs
camera vs
worldspace.
Explain - default
text vs
TextMeshPro for
lower resolutions -
always choose
TextMeshPro.

Create with VR - Lesson Plans


https://learn.unity.com/tutorial/2-4-user-interface?uv=2020.3&courseId=60183276edbc2a2e6c4c7dae&projectId=601834b9edbc2a4418546660
https://learn.unity.com/course/create-with-vr

Step 2 - Edit the
welcome text

A1 -- DYNAMIC --
@ -- INTERFACE --
& Canvas
& Welcome_Background
@ Welcome Text
) EventSystem

You should now have a semi-transparent box in the room with huge
off-center text that says “New Text".

Related Resources:
- Canvas Render Modes

Now that you have the canvas in place, it is time to make a more
useful welcome message.
1. Edit the shape and placement of the background image:

e Inthe image object's Rect Transform component, edit the

Width, Height, Pos X, and Pos Y properties.
2. Edit the appearance of the text:

e On the text object, in the TextMeshPro - Text (Ul)
component, change the Font Asset, Font Size, Vertex Color,
and Alignment properties.

3. Change the contents of the text:

e Inthe TextMeshPro - Text (Ul) component, change “New
Text" to a short, but informative welcome message about the
scene.

4. Edit the size and spacing of the text box:

e In the Rect Transform component., set the Width, Height,
Pos X, and Pos Y to position in your text's Rect Transform
component.

e Note: Make sure to leave some margins and space for an
"OK" button.

@--XR--
@ -- LIGHTING --

@ Welcome_Background
@ Welcome Text
D EventSystem

Welcome to your VR Room!

Press the thumbstick of primary button/

to toggle your rays:|

Your welcome text should now look the way you want it in the
scene.

Step 3 - Add an OK | You don't want the welcome text displayed forever, so you will add

button to the panel

© Unity 2021

an "OK" button that hides it.
1. Add a button to the panel as a child object:
e In the Hierarchy, right-click the Welcome Background and
click Ul > Button - TextMeshPro.
2. Edit the button'’s text:
e Select the button's child Text object.
e Change the text to "OK" or “Got it!".

Explain: There's
lots of other
settings you can
play with as well in
the TMP
component.

Explain: How does
the color tint
work?

Warning: The
button won't work
yet - you will click
it and nothing will
happen - we will
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e Edit the Text settings to match your other text. fix that soon.

3. Position the button appropriately: Demo: If you
e In the Rect Transform component, edit the button’s position, | wanted to change
width, and height. the image, could
4. If you want to change the color of the button as you interact do that in the
with it: image component,

e |n the Button component, edit the Normal, Highlighted, and too
Pressed Color properties.
5. Prevent your ray from appearing active when it is over the
background panel:
e In the Background Image component, disable the Raycast
Target setting.
e In the Text object’'s TextMeshPro component, in the Extra
Settings section, disable the Raycast Target setting.

AIC --
INTERFACE -- Welcome to your VR Room!

4
Press the thumbstick or primary button |
to toggle your rays.

You should now have an "OK" button that changes color when it is
highlighted and clicked with the trigger.

Step 4 - Make the | Now that the button looks the way you want, you should make it Explain: SetActive
OK button remove ' remove the welcome panel when clicked. is a bool, which
the panel 1. Locate the On Click event for the button. can be true or
e On the Button object, at the bottom of the Button false. If you leave it
component, locate the On Click event. unchecked, that is
2. Deactivate the welcome panel: false, which means
e Inthe On Click event, click the + button to add a new action. | it will be set as
e Assign the Welcome Background to the Object slot. INACTIVE.

e From the “No Function” drop-down, select GameObject >
Set Active (bool) function and make sure the check box is
deselected so that it is deactivated.

@ v Button

Interactable v

Transition Color Tint

® 4

Target Graphic =l Button (Image)

Normal Color

L3

DT T R Y

Highlighted Color

.

Pressed Color

»

Selected Color

LY

Disabled Color

)

Color Multiplier ®
Fade Duration 0.1

Navigation Automatic

Visualize

On Click ()

Runtime Only * GameObject.SetActive

@ Welcome_E ® S
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Step 5 - Make a
reset Ul canvas

Step 6 - Show
reset panel on
button press
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When you select the OK button with the trigger, the welcome panel
should disappear.

Now that the welcome Ul works perfectly, it will be easy to duplicate
and repurpose the Ul elements to make a Reset Ul that reloads the
scene.
1. Make new text for your reset screen:
e |n the Hierarchy, duplicate the Welcome_Background object
and rename the new object “Reset_Background”.
e Temporarily deactivate the Welcome Background To be able
to edit it more easily.
e Edit the text to be about resetting the scene to its original
state.
2. Add a second button for your reset screen:
e Duplicate the button, then reposition it next to the original.
e Rename the buttons and edit their text to make one a
“"Cancel” button and the other an affirmative "Yes" button.
3. Make the Yes button actually reset the scene:
e Add a Load Scene component to the Yes button object.
e In the On Click event, assign the Load Scene component
and choose the Load Scene > ReloadCurrentScene ()
function.

Are you sure you want to reset your il
room to its default state? lavigation Automatic
Visualize
On Click ()
Runtime Only v  LoadScene ReloadCurrentScene v

B Confirmatic @

Load Scene(Script) o i i
" n

From the Reset canvas, you should now be able to be able to click
Cancel to hide the panel or click Yes to reload the current scene.

There's currently no way to return to the reset screen. To execute a
reset, you can teleport the player back to the starting point when
they press the secondary button.
1. Only show the welcome panel at start:
e Re-enable the Welcome Background object and disable the
Reset_Background object.
2. Test for a Secondary Button press:
e Onthe XR Rig object, add an On Button Press component.
e Click +to add a new Action Binding.
e Assign the binding path to XR Controller > Optional Controls
> secondaryButton.
3. Show the reset panel on the button press:
e Inthe On Press event, click the + to add a new action.
e Assign the Reset_Background object.
e Select the function GameObject > Set Active (bool), and
make sure the check box is enabled.
4. Hide the welcome panel on the button press:
e Click the + to add a new action.
e Assign the Welcome Background object.
e Select the GameObiject > Set Active (bool) function, and
make sure the check box is disabled.

Explain: The
“cancel” button
should already
work as expected,
since it just
disables the panel.
Explain:
LoadSceneis a
custom script we
provided for you.

Explain: What is
the secondary
button?

Demo: Why hide
the welcome
panel? You don't
want them on top
of each other
Explain: On Button
Press is a custom
script.
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v OnButton Press (Script)

Action

I secondaryButton [XR Controller]

On Press ()

Runtime Only * GameObject.SetActive

@ Reset_Back ® | v

Runtime Only + GameObject.SetActive

@ Welcome_B. @

When you press the secondary button, the welcome panel should
disappear and the reset panel should appear.

Step 7 - Teleport to | If the player is not at the starting position when they press the Demo: Why would
the starting secondary button, they need to be teleported back to the starting you want to
position for reset position to view the Reset panel. teleport back to
Ul 1. Make sure you have a teleportation anchor at the start of your the starting
scene: position? Need to
e If you don't already have one, duplicate and reposition a control where
teleportation anchor at the position you want your player to player is relative to
start in the room. Ul in case they're
2. Make your player start at the correct location: right next to it and
e Match the position and rotation of the XR Rig object to the can'tread it or
position and rotation of the starting anchor. don't see it.
3. Add a new teleporting behavior to the XR Rig: Explain: Teleport
e On the XR Rig object, add a Teleport Player component. Player is a custom
e For the Teleport Destination property, assign the script.

teleportation anchor at the start of your scene.

e For the Provider property, assign your Teleportation
Provider.

4. Connect the teleportation action to the button click:

e In the XR Rig object’'s On Button Press component, for the
On Press event, click the + to add a new function.

e Assign the XR Rig object.

e Select the TeleportPlayer > Teleport () function.
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Recap

Extensions

Extension -
Real-world text
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v OnButton Press (Script)

Action

On Press ()
Runtime Only ¥ GameObject.SetActive
Reset_ Bacl® v
Runtime Only v GameObject.SetActive
D Welcome_E ®

Runtime Only v TeleportPlayer.Teleport
BXRRig(Tel @

On Release ()

Listis Empty

+
Teleport Player (Script) o + i

B Mat_Rect_Black (Teleportation @

XR Rig (Teleportation Provider) ®

When you press the secondary button, the player should now
teleport to the starting position of the scene in order to view the
Reset Ul.

New Functionality:
- Welcome screen with OK button
- Reset screen to reload scene

New Concepts and Skills:
- VR Ul best practices
- Worldspace vs Screenspace Ul

Next Lesson:
- Comfort & Accessibility

If you want to further develop your skills, explore new concepts, and improve your
project, check out some of the optional extension activities below.

Each one is tagged as [Easy], [Medium], [Difficult], or [Expert] and will also include a
[Requires Programming] tag if some coding is required.

1. Add real-world text to the scene [Easy]
Add text onto a real-world object like a hotebook to provide additional information to the
user:
e Make a "TexMeshPro - Text" object a child object of whatever object you want it
to display on.
e Make sure the Canvas is set to world space Render Mode
e Bonus - add audio narration that reads the text when you pick up the object.
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Extension -
Multi-step Ul

Extension -
Contextual
Tooltips
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See lesson related videos here

2. Add multi-step user interfaces [Medium]

Instead of having a single paragraph of instructions at the start of your VR room with an

"OK button,” add a “Next" button that cycles through a few shorter strings of text:
[ ]

On your “"TextMeshPro - Text” component, add the ShowMessagesFromList
component, which was provided in the Course Library, then use the

NextMessage() function to cycle through them. Note the “On Complete ()" event
on this component, which fires after there are no more messages to show.

- \JR room!
prome L - touch the
ﬁglbﬁfp primary putton Of toucl
e ays.
'nf,r-aﬁc.k 1o toggle your T-! ;d L b
lﬁ:.im .-at the Next button and p
trigger 10 continue.

L ext

See lesson related videos here

3. Add contextual tooltips [Hard]

Add a small Ul screen to guide the user in a particular task in your room:
[ ]

The Ul screen should only appear when it is relevant.

Bonus - if it is a multi-stage task like grabbing a hat and putting it on your head,
try displaying multiple messages on the Ul, depending on what stage the user is
on.
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e Bonus - ideally, the Ul should only display the first time you complete that task.

See lesson related videos of contextual tooltips on Learn here

© Unity 2021 Create with VR - Lesson Plans


https://learn.unity.com/tutorial/2-4-user-interface?uv=2020.3&courseId=60183276edbc2a2e6c4c7dae&projectId=601834b9edbc2a4418546660#602339dcedbc2a51a127ad10

Challenge 2 - 3D Painting App

Lesson Link Challenge 2 - 3D Painting - Unity Learn

Length 1Hours 30 Mins

In this challenge, you'll apply the skills you learned
while making your VR Room in a 3D painting app. In
this app, the user can choose the shape they want to
paint on, select the color and size of their brush on a
handheld palette, and then create their masterpiece!

This challenge will review your skills learned in the
following lessons:

Audio & Haptics

Activation Events

Direct & Ray Interactors

User Interface

This challenge is part of the Create with VR course.

Getting started 1. Open the broken 3D painting prototype Scene:

e From the Project window, expand, Assets > Challenges >
02_3DPainting > Scenes

e Double-click on the 3DPainting_Prototype_Broken Scene to
open it.

2. Begin working on the challenge tasks:

e Work through the tasks outlined in the steps below.

e If you want to push your skills, attempt the optional bonus
challenge tasks, as well.

e If you get stuck, there are hints for each task at the bottom of

the page.
Challenge Task Hint
1. The Canvas that allows you e This canvas should be 1. The canvas render mode
to change the shape on the stationary next to the pedestal. | needs to be in “World Space”
pedestal follows the camera. - not “Screen Space”.
2. The toggled ray and palette e The palette should move with | 2. The canvas render mode
canvas are tracking the the left hand and, when you needs to be in “World Space”
opposite hands. press the thumbstick or - not “Screen Space”.

primary button on the right
controller, the toggled ray
should emit from the right

hand.
3. The paint brush activation is e The paintbrush should create | 3. Look at the input mapping
backwards, starting when the a trail while the trigger is being | in the XR Controller
trigger is released and stopping held, stopping when the components for the LeftHand
when it's pressed. trigger is released. and the RightRay.
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4. The medium brush size
button turns invisible when
pressed and makes the trail
gigantic.

5. The paint brush sound effect
stays the same, regardless of
how far it is from you.

Bonus

6. There is no audio feedback
from the UlI.

7. There is no way to hide the
pedestal completely.

8. There is no way to save your
work. [Expert]

9. There is no way to paint on
the back or sides of the object.
[Expert]
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The button should turn the
same grey color as the other
buttons when pressed and
change the trail to a size in
between the small and large
brush sizes.

The paint brush sound should
be at full volume close to your
face, but about 50% volume

when your arm is outstretched

Add sound effects for all of the
buttons in the Ul and a
continuous sound effect that
plays while the paint brush is
in use.

Add a toggle Ul to the menu
next to the pedestal that
shows/hides the pedestal
object when toggled on/off.

Add a "Print"” button that
creates a miniature version of
your 3d creation on a table
next to you.

Add a slider to the Ul that
rotates the entire pedestal,
giving you the ability to paint
the back as well.

4. Look at the functions in
the Activated and
Deactivated events in the
paintbrush's XR Grab
Interactable component.

5. Make sure to check the
alpha (transparency) value of
the button tint. Look at the
functions on the small and
large brushes for references
on the ideal trail width.

6. Try using either the
PlayQuickSound or the
PlaySoundsFromList scripts.

7. Use the Toggle() function
in the ToggleVisibility script.

8. No hints available. Use
Google!

9. No hints available. Use
Google!
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Lab 2 - Personal Project Events & Interactions

Lesson Link Lab 2 - Personal Project Events & Interactions - Unity Learn

Length 2 Hours

By the end of this lab, your personal project will have
most of its core functionality.

This lab will draw on skills learned in the following

lessons:

This challenge is part of the Create with VR course.

Step

Audio & Haptics
Activation Events

Direct & Ray Interactors
User Interface

Instructions Teacher Notes

By the end of this lab, your personal project will have most of its core functionality.

This lab will draw on skills learned in the following lessons:

Audio & Haptics
Activation Events

Direct & Ray Interactors
User Interface

This challenge is part of the Create with VR course.

Step 1-Fillin
Design Document
for events &
interactions

© Unity 2021

Before you resume work on your project, you need a plan for what you're actually going to
work on. You will continue filling out your design document so you have a clear plan of
action for this lab.
1. Pick up where you left off with your design document:
e Re-open the document you created during Lab 1.
2. Fill out Section 4 (Events and Interactions) of the document:
e Determine if you will be using direct interactors, ray interactors, or both, including
how you would toggle between them.
e Describe the haptic / audio feedback, as well as any other 3D sounds you expect
in your scene
e List specific object Activation functionality, where if the user is holding an object
and presses the trigger, something will happen.
e Describe the main menu of the app, including what can be done from that menu.
e If relevant, describe other Ul elements in the scene.
3. (Optional) Add more specific details to your design document:
e Fill out section 6 (Other features)
e Fill out section 7 (Sketch)
e Fill out section 8 (Timeline)
You should now have section 4 of your Design Document complete, providing direction
for this lab where you will be implementing your app’s core functionality .

Related resources:
- Oculus Best Practices
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Step 2 - Add
haptics and audio

Step 3 - Implement
event-based
interactions

Step 4 - Set up
controller
interactors and
layers

Step 5 - Create a

main menu Ul

Recap
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For all of the interactors set up on our controllers, add audio and haptic feedback.
1. Add haptic feedback to your controllers:
e Follow the instructions in the Audio and Haptics tutorial.
2. Add audio feedback to your controllers:
e Follow the instructions in the Audio and Haptics tutorial..
3. Add 3D / ambient feedback to the environment, including the use of Reverb Zones:
e Follow the instructions in the Audio and Haptics tutorial..
You should now experience haptic and/or audio feedback on desired events with your
controllers. There should also be 3D environmental sound in your scene.

If you have any event-based interactions planned for your app (e.g. when you press the
trigger, when the scene loads, when you tilt an object, etc), take the time to get those
functional now.
1. To add Activation events for certain objects in your app:
e Follow the instructions in the Activation Events tutorial.
2. To add additional event-based functionality to the scene:
e Add actions to other interaction events such as OnHoverEntered,
OnSelectEntered, etc.
e Add new events from the Course Library > Scripts folder such as OnButtonPress,
OnSceneload, OnTilt, etc.
You should now have core event-based functionality implemented in your app.

If you plan on using a combination of Ray and Direct Interactors, you need to set those up
for each hand, and if relevant, the ability to toggle between them.
1. To implement interactors for each hand:

e Follow the instructions in the Direct and Ray Interactors tutorial.
2. To configure layers so that each interactor can only interact with specific
interactables:

e Follow the instructions in the Direct and Ray Interactors tutorial.
You should have the appropriate interactors implemented for each hand, including the
ability to toggle between them. Using layers, these interactors should only be able to
interact with ppropriate objects (i.e. sockets can only receive specific objects, rays not
being able to grab certain objects, etc).

One User Interface (Ul) nearly all apps should have is some kind of main menu UI.
1. Create a simple main menu Ul:
e Follow instructions in the User Interface tutorial.
2. To add areset screen Ul:
e Follow instructions in the User Interface tutorial.
3. To add additional in-world Ul screen:
e Create additional world space canvases and display them in relevant contexts for
the user.
You should now have at least one main menu Ul, which the user can click out of, a reset
screen, and any additional Uls required for the functionality of your app.

New Functionality:

Haptic and Audio feedback

3D environmental audio

Event-based interactions such as activating objects
Direct and Ray interactors on controllers
Worldspace Ul screens

New Concepts & Skills:
e Applying more complex interactions in your own VR app.

Next Lab:
e Optimization & Lighting
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Quiz 2

Lesson Link

Length 15 Mins

In this quiz, you will test the knowledge and skills you
learned in Unit 2 related to VR Events and Interactions.
This quiz is part of the Create with VR course.

This Quiz will assess the skills learned in the following

tutorials:

e Audio & Haptics
Activation Events

[ ]
e Direct & Ray Interactors
e User Interface

# | Question

1 If you set the Spatial Blend
property of an Audio Source
to be fully “3D", which two of
the following things will
happen?

Select the two correct
answers.

2 | This red line on this graph
shows the logarithmic volume
Rolloff of an Audio Source.
Distance (spread) is on the X
axis and Volume is on the Y
axis.

Approximately how loud will

the volume be when the user
is about 2 meters away from
the source?
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Quiz 2 - VR Events & Interactions - Unity Learn

Answers

A. Sound volume will be louder in the
user's ear that is closest to the
audio source.

B. Sound volume will increase as the
user gets closer to the Audio
Source.

C. Sounds coming towards the user will
be at a higher pitch and sounds
going away from the user will be at a
lower pitch.

D. The quality of the audio will change,
depending on the materials of the
space.

A. 0% volume (silent)

B. 25% volume

C. 50% volume

D. 75% volume

E. 100% volume (full volume)

Explanation

Making an audio source
“3D" makes it change in
volume in the left and right
ears, depending on the
user's position and
orientation relative to that
sound, just like in real life.
Sounds changing pitch
depending on their
direction relative to the user
is the Doppler effect, which
is another setting. To edit
the quality of the audio to
reflect a specific type of
space, you can use Reverb
Zones.

You can see that the red
line is straight at 1.0 for the
first 2 units of distance
(meters). The minimum
distance of this audio
source is set to 2.0, which
means that it will be at full
100% volume if the user is
anywhere within 2 meters,
and then drop as distance
increases beyond 2 meters.
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See high-res image here

3 | In addition to the Spatial
Blend property in an Audio
Source component, there are
additional Audio Spatializer
plugins that you can import
and enable through the

Project Settings.

]

Audio

See high-res image here.

What do these spatializer
plugins aim to do?

4 | Which of the following is NOT
true about using
TextMeshPro Text objects
over legacy Text objects?

Text
Text - TextMeshPro
Image
Camera Raw Image
Button
Button - TextMeshPro
Toggle
Slider
Scrollbar
Dropdown
Dropdown - TextMeshPro
Input Field
Input Field - TextMeshPro
Canvas
Panel
Scroll View
Event System

See high-res image_here

5 | Which of the following
definitions of Canvas Render
modes is NOT correct?
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. Apply subtle effects to the volume,

quality, and timing of the audio
between your left and right ears to
make it sound even more like
real-world audio.

Allow you to play sounds from the
controllers in addition to the headset,
which allows users to better locate
where sounds are coming from.

. Allow you to add a larger number of

background ambient sound effects
that increase the sense of immersion
in the scene.

TextMeshPro provides improved
clarity & readability at lower
resolutions.

TextMeshPro provides more control
over text formatting and layout.

. TextMeshPro objects do not require

a Canvas object to appear in your
scene.

. World Space: the Canvas follows

the user wherever they are in the
world.

Screen Space Camera: the Canvas is
placed a given distance in front of a
specified Camera.

Screen Space Overlay: places

A sound is different when
you hear it directly with
your ears than when you
hear a recording of that
same sound. Audio
Spatializers attempt to
simulate the changes in
audio that occur when you
hear sounds directly in the
world in order to allow the
VR user to better locate the
origin of sounds in 3D
virtual space.

Just like the legacy text
objects, TextMeshPro
objects also require a
Canvas object.

In the World Space render
mode, the Canvas will
behave as any other object
in the scene. The size of
the Canvas can be set
manually using its Rect
Transform, and Ul elements
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6 | Below you can see the
Activated event of a
grabbable object.

This event will fire when the
user presses a particular
button while holding this
object.

What should be assigned to
the property that currently
says "None (object)”

See high-res image here

7 | You have just added a Direct
Interactor component to one
of your controller objects,
expecting to be able to pick
up objects directly with your
hand.

However, when you try to
press the grip button near an
object, it doesn't work.

Which of the following
explanations might be
causing this issue?

Select all correct answers.

8 | True or False:
In order to add a user
interface button that works in
VR, from the Hierarchy, you
should click Create > XR >
XR Button.

9 | What does the word "haptics”
refer to?
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Oow

Canvas Ul elements on the screen
rendered on top of the scene.

The controller object that will be
holding the object.

The XR Rig object that will be
affected by the object.

The object with the script
component that contains the
function you want to run.

It should be left blank - it will be
assigned automatically when the app
is run.

You forgot to assign a Model Prefab
to represent the hand for that XR
controller.

You forgot to check the “Is Trigger”
check box on the Sphere Collider
component.

The Interaction Layer Mask
property is set to “Nothing”

The object you're trying to grab
does not have a collider on it.

True
False

The use of tactile or touch
sensations.

Tracking of hand movement in VR.
Tracking hand rotation in VR.

Audio feedback from user interfaces.

will render in front of or
behind other objects in the
scene based on 3D
placement. This is useful
for Uls that are meant to be
a part of the world. This is
also known as a "diegetic
interface".

When you are adding
actions to an event, you
first must assign the object
that contains the script you
want to access. After the
object is assigned, you can
select a script / component
and the function with that
script / component you
want to run.

For a Direct Interactor to
function, it requires a
collidere with “Is Trigger”
enabled, it must share an
interaction layer with the
object it's interacting with,
and the object it's
interacting with must also
have a collider.

Having a hand model is not
required for this interaction
to work.

The standard button object
works in VR and responds
to Raycasts just like it
would in a typical
screen-based experience.
You just need to click
Create > Ul > Button
(TextMeshPro).

Haptics, in general, is
anything related to the
sense of touch. Specific to
VR or mobile technology,
haptics usually refers to
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10 | Which of the following

statements about VR User
Interface best practices is

true?
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. Most user interfaces should use the

World Space render mode.
Most user interfaces should use the
Screen Space render mode.

. A button's Normal Color, Pressed

Color, and Highlight Color should all
be the same.

The interface and text should be as
large as possible, even if that
requires the user to bend their neck
to see it.

simulating touch sensations
through subtle physical
feedback and vibrations.

Most Ul in VR should be in
"world space”. Objects in
“screen space” can be
distracting and difficult to
interact with. A button
should have different
interaction colors so the
user knows when they've
interacted with it. The text
should be comfortable to
read within the user’s field
of view, not requiring them
to bend their necks in order
to see the whole thing.
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Unit 3 - VR Ergonomics & Optimization

Unit Link 3 - VR Optimization and Lighting - Unity Learn

Length 9 Hours15 Mins

In this unit, you will focus on ergonomics and optimization for VR in order to make your app as accessible and
comfortable as possible..

In these tutorials, you will:

Improve comfort and accessibility

Evaluate key performance metrics

Implement optimized baked lighting

Configure and build your app for sharing

In the Challenge for this unit, you will apply your skills in an industrial training simulation prototype. Then, in the
Lab, you'll implement the core functionality of your personal project. Finally, in the Quiz, you will test your new
knowledge.

This unit is part of the Create with VR course.
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Lesson 3.1-

Lesson Link

Length

Project Objectives:

In this lesson, you will learn how to reduce the risk of
simulator sickness and increase the inclusivity or your
app, allowing it to be enjoyed by as many people as
possible. By the end of this lesson, your app will be
more comfortable and accessible.

This lesson is part of the Create with VR course.

Learning Objectives:
By the end of this lesson you will be able to:
e Explain the importance of limiting a user'’s field
of view in order to reduce the risk of simulator

Comfort and Accessibility

31 - Comt U

1Hour 30 Mins

sickness, especially as it relates to locomotion.

e Recognize opportunities for improving
accessibility in an app in order to make it more
inclusive, including motor, audio, visual, and
cognitive accessibility.

e Modify a project in order to make it more
comfortable or accessible in order to allow it to
be enjoyed by as many people as possible.

Step
Step 1- Create a

black canvas
for fading
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Instructions

When the scene loads, it can be a little jarring to just appearin a
new world. It is generally good to fade into new environments.
1. Make a new Screen Space canvas to fade in from:
e In the Hierarchy, Create > Ul > Canvas and rename it
“"Fade_Canvas".
2. Make the canvas render directly in front of the camera:
e Inthe Canvas object, in the Canvas component, set the
Render Mode to Screen Space - Camera.
e Set the Render Camera property to your Main Camera.
3. Make the canvas black:
e Right-click your Fade_Canvas object and create a Ul >
Image.
e Set the Color property to black.

e Setthe X Scale and Y Scale properties to a large number
(e.g. 100) to make sure the canvas covers your whole field

of view.

4. Make the canvas appear directly in front of the Main Camera

and in front of all other objects:
e Inthe Canvas component, set the Plane Distance to 0.1.
e Then set the Order in Layer to 1.

9 snep Turning

Distance Grab

> 4

8 continyous Movement

Teacher Notes

Explain: Screen space
Camera vs Overlay vs
world space?
Warning: No need to
make an XR Canvas -
just simple canvas will
work.

Warning: You don't
want the plane
distance too small or
you might clip through
it.
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@ v Canvas

Render Mode Screen Space - Camera
Pixel Perfect
Render Camera mMain Camera (Camera)
Plane Distance 0.1

Sorting Layer Default
Order in Layer 1
Additional Shader Channels Nothing

The black canvas should now completely cover the field of view
when you run the program.

Step 2 - Fadein | Now that you have the black canvas set up, you need to fade from it | Explain: What is a

on scene load on scene load. canvas group
1. Allow the canvas and all of its elements to fade: component? It allows
e On the Fade_Canvas object, add a Canvas Group you to control all
component and a Fade Canvas component. elements within a
2. Make an event that detects when the scene has loaded: canvas.
e In the Hierarchy, add an empty object and rename it “Scene | Explain: The
Loader". It will hold your scene loading events. FadeCanvas scriptis a
e Add an On Scene Load component to the Scene Loader custom script.
object.

3. Fade in from black on Scene Load:
e On the Scene Loader object, in the On Load event, click the
+ to add a new function.
e Assign the Canvas_Fade object.
e Select the FadeCanvas > StartFadeOut () function.
4. Hide the black image in scene view by default:
e Set the Canvas Group component'’s Alpha value to 0.
The scene should now appear to fade in from black when the scene
loads. You can test this using the reset scene Ul screen you made.

On Scene Load (Script)

0 Scene Loader On Load ()

QJ Canvas_Fade Runtime Only v | FadeCanvas.StartFadeOut

B Canvas_Fade ©

Related Resources:
o S E . I .

Step 3 - Another opportunity to improve player comfort through fading is Explain: Why is this
Teleporting during teleporting. Typically, there is a short fade to reduce the more comfortable?
with fade illusion of movement (“vection”) when teleporting and improve Explain: How does
comfort. this work? It's looking
1. Add fading functionality to your Teleportation Area (rug): for the object with the
e On your Rug prefab, remove the default Teleportation Area fade canvas
component and replace it with the custom Teleport Area component in the
With Fade component. scene.

e At the bottom of the new component, assign the same
Interaction Layer Mask, Custom Reticle and Match
Orientation properties to match the original component.

2. Add fading functionality to your Teleportation Anchor (mats):

e Enter Prefab Mode on one of your mats in order to apply
changes to all mats at once.

e Remove the default Teleportation Anchor component and
replace it with the custom Teleport Anchor With Fade
component.
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e Edit the new component's properties to match the original
component.

o Note: make sure that you have applied the changes to all
mat prefabs or prefab variants.

89 Mat_Rect_Black N

7 Tag Untagged

9 Mat_Rect_Black N Transform
B Mat_A_1 (MeshFilter)
B8 v MeshRenderer
W v Box Collider
Teleport Anchor With Fade (Script)
fir Material_Main (Material)

Shader Universal Render Pipeline/Lit

Your teleportation anchors and teleportation area should now
quickly fade to black when you teleport.

Step 4 - Add a In order to add some settings, you will add a new panel that can be = Demo: You may need
settings panel accessed from the main menu panel. to re-organize your
1. Add a new settings button: welcome panel a bit to
e In the Hierarchy, right-click Welcome Background object accommodate the
and select Ul > Button - TextMeshPro to add a button. settings button.

e Rename it “Settings Button".

e Set the Source Image property to the gearicon

e Delete the default Text so that it has no text on it.

e Resize and reposition the button so it fits nicely on in the

bottom-right corner of the menu.
2. Create a new settings screen:
e In the Hierarchy, duplicate the Welcome Background
object.
e Rename the copied object “Settings Background”
e Temporarily deactivate the welcome panel so you can only
see the settings screen for easier editing.
3. Add placeholder content to the settings screen:
e Replace the contents of the panel with three placeholder
text objects (“Setting 1" / Setting 2" / “Setting 3")
e Add a Toggle object next to each setting, deleting the
default text that is generated by the toggle.
e You may want to parent each text object to group them
together.
e Note: Use TextMeshPro Text for the labels instead of the
default Text label that comes with the toggle.
4. Replace the settings gear icon with an “X" icon:
e Inthe Gearicon's Image component, change the Source
Image property from Icon_Gear to Icon_Close.
5. Allow the user to go back and forth between these menus:
e In the Settings button's On Click event, set the settings
screen as active and the welcome screen as inactive.
e In the Close button's On Click event, set the settings screen
as inactive and the welcome screen as active.
6. Make the reset menu hide the settings menu when it appears:
e In the XR Rig's On Button Press event, add a new action that
disables the settings screen.
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Setting 1
Setting 2
Setting 3

Automatic
Visualize

y v GameObject SetActive

GameObject.SetActive

Button

v

Color Tint

Il Settings Button (Image)
Welcome to your VR
Room!

Press the thumbstick or
primary button to toggle
your rays.

Automatic
Visualize

l
O
|

You should now be able to access the Settings menu from a gear
icon in the main menu, which has 3 placeholder toggle settings. You
should also be able to return to the welcome panel from the settings
by pressing a Close button.

Step5-Adda One of the easiest ways to increase accessibility is allowing for Explain: Why use the
shap turning more ways to navigate the environment. You will allow the user to dynamic bool?
setting enable or disable snap turning. Because that's tied to
1. Replace the placeholder setting: the value that's
e Edit the first setting text to say “"Snap Turning". passed in by the
e In the Toggle component, make sure the Is On property is toggle.

enabled, since Snap Turning is enabled by default.
2. Link the toggle to the Snap Turn component:

e Inthe Toggle component, for the On Value Changed event,
click the + to add a new action.

e Assign the XR Rig to the Object slot, since it contains the
Snap Turn provider component.

e Select the Action Based Snap Turn Provider > enabled
(Dynamic Bool) function .

o Note: Make sure to select the “enabled” property that is a
dynamic bool (boolean) - this means that it will be affected
dynamically by the state of the toggle.
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Step 6 - Add a
distance grab
setting
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v Toggle

v
Transition Color Tint
Target Graphic ElBackground (Image)

Normal Color

Color Multiplier
Fade Duration 0.1
Navigation Automatic
Visualize
Is On v
Toggle Transition Fade
Graphic k] Checkmark (Image)
Group None (Toggle Group)
On Value Changed (Boolean)
Runtime Only *  ActionBasedSnapTurnProvider.enal v

B XRRig(Ac ®

- -

You should now have a functional check box that enables and
disables snap turning.

Another setting that can drastically increase accessibility is the Explain: Other ideas
ability to grab objects at a distance using rays. for settings include
1. Set up how your setting should appear by default: continuous
e In the Toggle component, enable or disable the Is On movement, closed
property. captions, rig height,
e Change the text of the Toggle to “Distance Grab". tooltips, etc

2. Make sure all of your grabbable objects can be accessed on
the same layer:

e In each object's XR Grab Interactable component, make sure
the Interaction Layer Mask property includes the Default
layer.

3. Give your rays the ability to change to a different set of layers:

e Inthe Hierarchy, select both the LeftHand Ray and
RightHand Ray objects.

e Add a Set Interaction Layer component to both objects.

e Set the Target Layer property to include the Default layer
and the Raycasts layer, which would allow them to grab
objects.

4. Make the “Distance Grab" toggle trigger these target layers:

e In the Toggle component, in the On Value Changed event,
click the + two times to add two new actions (one for each
hand).

e Assign the RightHand Ray to one object slot and the
Lefthand Ray to the other object slot.

e For both actions, select the SetinteractionLayer >
ToggleTargetLayer (Dynamic bool) function.

e Note: You must select the Dynamic bool option in the upper
section of the list in order to tie the function to the value of
the toggle.
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Recap

Extensions
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B Set Interaction Layer (Script)

Target Layer

. Default-Line (Materic

v Toggle

Interactable

Transition
Target Graphic
Normal Color

Highlighted Color

Pressed Color
Selected Color
Disabled Color
Color Multiplier
Fade Duration

Navigation

Is On

Toggle Transition
Graphic

Group

Mixed...

Nothing
Everything
Default
TransparentFX
Ignore Raycast
Water

V]|

Hats

Raycasts

v
Color Tint

I=lBackground (Image)

0.1

Automatic

Visualize

Fade
=l Checkmark (Image)
None (Toggle Group)

On Value Changed (Boolean)

Runtime Only v SetinteractionLayer.ToggleTargetLayer

LeftHand Ray (Set ®

Runtime Only v SetinteractionLayer.ToggleTargetLayer

B RightHand Ray (S¢ ®

You should now have a toggle that enables and disables the ability

to grab objects with rays from a distance.

Related resources:
- VR Accessibility

New Functionality:
- Fade in from black
- Teleportation fading
- Settings menu

New Concepts and Skills:
- VR comfort
- VR accessibility

Next Lesson:
e Optimization

If you want to further develop your skills, explore new concepts, and improve your project,
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check out some of the optional extension activities below.
Each one is tagged as [Easy], [Medium], [Difficult], or [Expert] and will also include a
[Requires Programming] tag if some coding is required.

Extension - 1. Add voiceover narration [Easy]
Voiceover Add audio narration that plays at the start of your scene, reading the text on the main menu:
narration e Use the OnSceneload script to trigger this

e Bonus - the audio should only play

"o to your VR Room:
Nelcome to your V | |
4o k or primary

Press the thumbstic D
button 1O toggle your rays.

i ass the secondary
At any time, press the seco y

button to reset the room.
- £ 1
And remember: have funt

See video of audio narration in action here.

Extension - 2. Add a closed captions setting [Medium]
Closed captions | Add closed captions to improve audio accessibility:
setting e For ambient sound like the fireplace, add closed captions to indicate what the sound

is at the sound's location.

e Bonus - have the closed caption "billboard” towards the player, so that it's always
facing towards the player and is therefore always readable (use the “LookAtPlayer
script from the Course Library or write your own script).

e Bonus - for your TV, use a video with words in it and add closed captions that go
along with the words of the video (the Unity-shape-the-world video provided has
voiceover) [Requires programming].

© Unity 2021 Create with VR - Lesson Plans
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Snap Turning
. Distance Grab

. Continuous Movement

. Closed Captions

See lesson related videos here.

Extension - 3. Add a continuous movement setting [Medium]

Continuous Add a setting to toggle on and off continuous movement:

movement e Use the same technique you did to toggle snap turning.

setting You will need to add a Continuous Move Provider component and a Continuous Turn

Provider component to the XR Rig.

e Bonus - You could have a single toggle or drop-down that alternates between (a)

continuous movement and turning vs (b) snap turning and teleporting.
e

a Snap Turning
. Distance Grab

. Continuous Movement

. Closed Captions

See lesson related videos here.
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Lesson 3.2 - Optimization

Lesson Link 3.3 - Lighting - Unity Learn

Length 1Hour 30 Mins

Project Objectives:

In this lesson, you will learn about each of the key
performance metrics for VR (fps, polycount, and draw
calls) and how to ensure these metrics are optimized.
By the end of this lesson, your app will be more
optimized for performance.

This lesson is part of the Create with VR course.

Learning Objectives:
By the end of this lesson you will be able to:

e Recall the key metrics for performance,
including fps, tris, and draw calls, in order to
locate performance targets for your device.

e Explain the importance of fps as it relates to
comfort of a VR experience in order to
prioritize it appropriately in development.

e Identify key performance metrics in the Game
Stats window in order to determine whether or
not your app is currently hitting its targets.

e Understand factors that contribute to high
draw calls in your scene in order to locate
potential areas for optimization (including
static batching, sharing materials, etc).

e Understand factors that contribute to high
polycount in your scene in order to locate
potential areas for optimization (including
particles, high-poly meshes, etc).

e Understand factors that contribute to the
performance of textures in your scene in order
to locate potential areas for optimization
(including texture atlases, mip maps,
anisotropic filtering, etc.).

e Understand the impact of particle effects and
post-processing on performance in order to
avoid optimization issues.

e Set up anti-aliasing in your scene in order to
improve the appearance of jagged curves or
angles in the scene.

Step Instructions Teacher Notes
Step 1- Take | Before you start optimizing your code, you will want to identify your Explain: Importance
stock of performance goals and how to evaluate if your app is meeting them. of optimization -

current fps 1. Determine your device’s target frames per second (FPS):

© Unity 2021

similar to mobile, but
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e Use the links below as reference and write down your target
FPS.
2. Determine the frames per second (fps) running on your device:
e From the Course Library > Prefabs > Testing, drag the FPS
Overlay Ul into your Hierarchy.
e Assign your Main Camera to the Render Camera property.
e Run your application to see your FPS.
e Note: If you are running the app through the Unity editor, this
will not be an accurate prediction of the FPS.
3. View the FPS in the Unity Stats window:
e In Game View, in the top-right corner, enable the Stats window,
and locate the FPS number.
4. Explore the Unity Profiler:
e Click the Play button.
e From the top menu bar, select Window > Analysis > Profiler.
e Click the red circular record button in the Profiler window.

5. To test the true frames per second running on a mobile headset:
e Build and run the app on your device with no connection to the
computer.
You should now know where to find target metrics for your device and
how to find the frames per second on your device.

Statistics
Audio:

Level: -73.4 dB
Clipping: 0.0%

DSP load: 1.0%
Stream load: 0.0%

Graphics: 141.5 FPS (7.1ms)
CPU: main 7.1ms render thread 3.8ms
Batches: 239 Saved by batching: 0
Tris: 210.7k Verts: 353.0k
Screen: 2560x1239 - 36.3 MB
SetPass calls: 56 Shadow casters: 124
Visible skinned meshes: 0
Animation components playing: 0
Animator components playing: O

Welcome to your VR
Room!

FPS:70
MS:14.1

have to render 2x and
need high frame rate.
Explain: Everything
that you'd want to
google for “mobile
optimization” is
basically applicable
here, too

Explain: Relationship
between frame rate
and ms per frame -
just inverse (divide
1000 over fps).
Explain: You can also
download / install
apps that monitor FPS
/ GPU / CPU (e.g. ovr
metrics).
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Step 2 -
Optimize
draw calls

© Unity 2021

Related resources:
e Target performance metrics
o HTC Vive performance targets

o Oculus performance targets
e Unity Tools

o Stats window

o Frame debugger
o Profiler

In order to render a single frame, Unity "draws"” things to the screen in
"batches” of objects. Every time Unity “calls” on the engine to “draw”
something to the screen is called a “draw call”. If you can minimize draw
calls, you can improve performance.

1. Determine your device's target draw calls (batches):

e Consult your platform's website to find your target “Draw Call”
metric.

2. Find the number of draw calls in your scene:

e Open the Game Stats window and locate the “Batches"” (draw
call batches) value.

3. Visualize how batching and draw calls can affect frame rate:

e In the top menu, select Window > Analysis > Frame Debugger.

e Click Enable.

e Use the left/right arrows in the Frame Debugger window and
watch in the Game view to see the step-by-step creation of a
single frame.

4. Make sure "Static Batching” is enabled:

e From the top menu, select Edit > Project Settings > Player
panel.

e In the Other Settings foldout, make sure Static Batching is
enabled.

5. Improve batching by marking unmoving objects as "“Static":

e Make sure your Hierarchy is organized so that all static objects
can be selected easily.

e Select all static objects (including lighting objects like lamps and
chandeliers).

e At the top of the Inspector select the Static checkbox.

e When prompted, choose "Yes, change children”.

e Notice the effect this has on Batches when you click Play.

6. If your Batches number is still very high (over 175):
e Consider removing the mirror object from the scene.

© Inspector

Maximize On Play Mute Audio Stats Gizmos ¥ ” = 29) [l static
v

Statistics Layer —

Tag Untagged v

Audio:

Level:-74.8 dB
Clipping: 0.0%

Muitiple Select
DSP load: 0.9% .

Stream load: 0.0% o~ Transform

Graphics: 0.1 FPS (15609.7ms) Position
CPU: main 15609.7ms render thread 3.9ms
Batches: 338 | Saved by batching: 0

Tris: 281.4k Verts: 471.2k

Screen: 1547x747 - 13.2 MB

SetPass calls: 64 Shadow casters: 158
Visible skinned meshes: 0

Animation components playing: 0

Animator components playing: 0

Rotation

Scale

be multi-edited.

Add Component

You should have now reduced the number of draw calls through
batching objects with shared materials.

Related resources:
- Draw call batching

Components that are only on some of the selected objects cannot

Explain: What are
draw calls?

Explain: Why
"batches” instead of
draw calls? - Unity
batches things when
it draws them to be
more efficient
Explain: What does
dynamic batching do?
Good for particle
systems bc dynamic
geometry can be built
into shared vertex
buffers.

Demo: Importance of
sharing materials over
a large number of
meshes. Batching can
only be done with
shared materials. If
you don't, draw calls
go up.

Demo: Look at what
happens when you
remove the mirror .
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Step 3 - The most straight-forward performance metric is the poly (polygon)
Minimize count. The poly count is often measured in “Tris” counting triangles or
polycount “"Verts" counting vertices.

1. Determine your device's target polycount (triangles):
e Consult your platform's website to find your target “triangles”
metric.
2. Find the number of triangles in your scene:
e Open the Game Stats window and locate the "tris" (triangles)
value.
3. Visualize your triangles more clearly:
e From the Scene view, change from the “Shaded" draw mode to
the Wireframe draw mode.
e Note: In Unity 2021 LTS: the draw mode dropdown is
represented by a circular icon at the top of Scene view:

()~ 2D ®

Shading Mode

+ Shaded
Wireframe
Shaded Wireframe

4. Determine the number of triangles for an individual object:
e Select an object.
e Inits Mesh Filter component, click its Mesh.
e Select that Mesh in the Project window to view its triangle count
in the Inspector.
e Note: Anything under 1,000 tris is pretty “low poly”
5. Notice how your tris change depending on what objects are in
frame:
e Monitor the stats window as you rotate the XR Rig around.
6. If you are not hitting the suggested target for Tris:
e Remove or replace assets with high polygon counts until you
reach your target
e You can also try removing the mirror from your scene.

Statistics

Audio:

Level: -74.8dB
Clipping: 0.0%

DSP load: 0.9%
Stream load: 0.0%

Graphics: 0.0 FPS (53041.6ms
CPU: main 53041.6ms render thread 1.7ms
Batches: 166 Saved by batching: 0
Tris: 142.0k Verts: 238.6k
Screen: 1547x747 - 13.2 MB
SetPass calls: 34 Shadow casters: 74
Visible skinned meshes: O
Animation components playing: O
Animator components playing: O

© Unity 2021

Demo: Why triangles?
In wireframe mode
you can see how
Unity converts
everything into
triangles.

Demo: Duplicate a
plant a bunch of times
(like 100 times), run
your app on device
and look at the fps
drop as you look
away from vs looking
at them.

Demo: You can also
quickly see the effect
on tris by disabling
objects one at a time
to see what impact it
has.
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Step 4 -
Optimize
textures
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@ Asset Store
W & v P Y v

# Scene  o® Game
Wireframe > 2D e
Shading Moc®

Shaded
¥ Wireframe

Shaded Wireframe
Global lllumination

Contributors / Receivers
Baked Global lllumination

Baked Lightmap

Directionality

Shadowmask

Albedo

Emissive

You should now be hitting your target for Tris and have an
understanding of where you are spending your tri budget.

Related resources:
- Occlusion cullin

In addition to evaluating the draw calls Unity makes, it is also important
to consider the size of the textures used in your scene.
1. Add a painting to the scene to better analyze the impact of texture
settings:
e From the Course Library > Prefabs > Art, add a piece of Artto a
wall in your scene.
2. Access the material for the objects in your scene:
e |nthe painting's Mesh Renderer component, expand the
Material section at the bottom of the inspector..
3. Locate the texture atlas used for the material:
e From the material's Surface Inputs foldout, click the thumbnail
next to Base Map to locate the texture in the Project window.
e Click this texture to view the texture's Import Settings.
4. Experiment with the texture settings:
e At the bottom of the texture’s settings, adjust the Max Size,
Resize Algorithm, Format, and Compression properties.
e Click Apply to see the impact each setting has on the visuals in
your scene.
e Once you have observed the difference, revert back to the
original settings.
5. Enable "mip maps": to automatically reduce the resolution of
textures seen from a distance :
e Locate and select the InteriorColorSwatch texture in the Project
window.
e Inthe Inspector, expand the Advanced fold-out, and select
Generate Mip Maps.
e Click Apply. This will generate and apply lower quality textures
on farther-away objects.
6. Enable “Anisotropic Filtering"” to improve the visuals of textures
when viewed at a shallow angle:
e Locate and select the WoodFloor_Texture in the Project window.
e In the Inspector, drag to increase the Aniso Level slider.
e Click Apply. This will increase Anisotropic Filtering to improve
texture visuals when viewed at shallow angles.
You should now know which settings exist to optimize textures for
performance and/or visual quality.

Explain: Texel Density
= pixels per world
unit. You need higher
texel density for
detailed objects you
can view from close
up (e.g. a strawberry
you can grab vs a
building in the
background)

Explain: What are
mipmaps? Lists of
progressively smaller
versions of an image.
Unity automatically
uses a smaller
version of the texture
when it is far away
from the Camera.
Explain: Textures and
materials are not a
huge problem in this
project because
we've set up the
assets properly - but
could be a HUGE
problem if you
download other
assets.
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Step 5 -
Optimize
particles
and
post-proces
sing
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© Inspector
@ Interior Colour Swatch (Texture 2D) Import Settings

Texture Type
Texture Shape

sRGB (Color Texture)
Alpha Source

Alpha Is Transparency
Ignore PNG file gamma

Advanced

Default
2D

v

Input Texture Alpha

Read/Write Enabled
Streaming Mipmaps

Virtual Texture Only

Generate Mip Maps v

Border Mip Maps

Mip Map Filtering Box
Mip Maps Preserve Coverag
Fadeout Mip Maps

Wrap Mode Repeat

Filter

Mode Bilinear

Aniso Level

Related resources:

Particles and post-processing also impact performance. You will look at

Importing Textures
Texture import settings (and mip maps)
Anisotropic Filtering

how these can affect frames per second and ensure they are not
causing performance issues in the project.

1. Optimize the particle's shader so that it does not respond to
dynamic lights:

Select the Particle_Fire object.
Locate the Shader property drop-down at the bottom of the
Inspector.

Make sure your particle is using the Universal Render Pipeline >

Particles > Unlit shader.

2. Experiment with Post-processing:

In your Main Camera object's Camera component, enable the
Post-processing setting.

Add a Volume component.

Click the New button to create a new Post-Processing profile.
You can then experiment by clicking the Add Override button
and enabling new effects.

Warning: If you are going to add any post-processing effects,
color adjustments are a good option. Lens distortions and
motion blurs induce cyber sickness; avoid using these effects.

You should now have appropriate particles and post-processing for
your app.

Explain: Utilize mobile
or unlit shaders over
the standard shader if
possible

Demo: Focus camera
on fire, then increase
emission > rate over
time (with max
particles way up) and
watch tris spike.
Warning:
Post-processing can
make FPS drop
dramatically.
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Step 6 -
Enable
anti-aliasing

© Unity 2021

Bt v Camera

Render Type

Projection
Projection
FOV Axis
Field of View

Perspective
Vertical

Physical Camera

Near 0.01
Far 1000

Clipping Planes

Rendering
Renderer Default Renderer (UniversalRenderPipelineAssiv

Post Processing v

Anti-aliasing None v

Stop NaN

Dithering

Render Shadows

v Volume

Mode
Weight
Priority 0

Profile @ Main Camera Profile (Volume®© | New  Clone

v Bloom

Bloom

v Threshold
v Intensity
v Scatter

Lens Dirt

Add Override

Related resources:

- Choosing shaders in URP
- Post-processing in the Universal Render Pipeline
- Screen space processing

You may have noticed that the edges of some of the 3D objects appear
jagged. This can be immersion-breaking in VR. We can smooth these
jagged edges with anti-aliasing.

1. Access the render pipeline settings:

e In the Project window, search for
“"UniversalRenderPipelineAsset” and select it to see its
properties in the inspector.

2. Enable anti-aliasing in the Universal Render Pipeline (URP) asset:

e Inthe Quality fold-out, change the Anti-Aliasing setting from
Disabled to 4x.

3. If you want to add additional anti-aliasing on the main camera:

e On your Main Camera object, in the Camera component,
expand the Rendering fold-out.

e Change the Anti-Aliasing setting to “Fast Approximate
Anti-Aliasing (FXAA).

e Make sure the Post-Processing setting is enabled to be able to
see the effect.

Explain: What is
aliasing? What is
anti-aliasing?
Warning: Make sure
to select the _Asset
file, not the
_Asset_Renderer.
Demo: In Game view,
look at the edge of an
object and see the
difference of when it's
enabled vs disabled
Explain: SMAA
(Subpixel
Morphological
Anti-Aliasing) vs
FXAA (Fast
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e Note: This may have a significant impact on FPS. approximate
4. Apply anti-aliasing to the mirror: anti-aliasing) - just a
e Locate the “Mirror_Texture" in your project. different algorithm for
e Change the Anti-Aliasing property from “None" to "4 samples”. | calculating the pixel
colors. FXAA is better
@ Inspector 2 for performance.
@ Universal Render Pipeline Asset (Universal Render Pipeline Asset @ :

Open
General
Renderer List

0 & UniversalRenderPipelineAsset_Renderer (Forward R ® Default
+

Depth Texture
Opaque Texture

Terrain Holes

Quality
HDR
Anti Aliasing (MSAA)
Render Scale

Bt v Camera
Render Type

Projection
Projection Perspective
FOV Axis Vertical
Field of View
Physical Camera

Clipping Planes Near 0.01
Far 1000

Rendering
Renderer Default Renderer (UniversalRenderPipelineAssi

Post Processing v

Anti-aliasing Fast Approximate Anti-aliasing (FXAA)
Stop NaN

Your main camera and your mirror should now have much smoother
edges than they did before.

Related resources:
e Anti-Aliasing

Recap New Functionality:
- Higher frame rate

New Concepts and Skills:
- Target metrics for VR
- Polycount
- Draw calls
- Texture and materials optimization
- Particles and FX optimization
- Anti-aliasing

Next Lesson:
- Lighting

Extensions If you want to further develop your skills, explore new concepts, and improve your project,
check out some of the optional extension activities below.
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Extension -
Learn more
about VR
optimization

Extension -
Platform-sp
ecific tools

Extension -
Using the
Profiler
window.
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Each one is tagged as [Easy], [Medium], [Difficult], or [Expert] and will also include a [Requires
Programming] tag if some coding is required.

1. Learn more about VR optimization [Medium]
Read more about optimization techniques and strategies for VR. Note that a big part of
optimization is Lighting, which we will tackle in the next lesson:

. T .

. M&MWMELMM. — -

. mmgw imizing G ics Perf

2. Research platform-specific tools [Hard]
Depending on what platform you're using, there may be specific tools available for monitoring
performance on your device:

e If it requires a separate application download, you may need to “sideload” the app onto
your device rather than downloading it from an official store (e.g. using SideQuest for
Oculus).

e Examples:

o Oculus - Oculus Developer Hub and the OVR Metrics Tool
o HTC Vive - Android Systrace
o Valve [ SteamVR - Frame Timing Tool

3. Explore the Unity Profiler [Expert]

Get more comfortable with the Unity Profiler window.
e Unity Profiler Window manual
e Optimization guide using the Profiler
e Diagnosing performance issues
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Lesson 3.3 - Lighting

Lesson Link

Length

Project Objectives:

In this lesson, you will learn how to use light modes,
lightmapping, and light probes in order to optimize the
lighting for VR. By the end of this lesson, the lighting in
your scene will be both beautiful and performant. N

This lesson is part of the Create with VR course.

Learning Objectives:
By the end of this lesson you will be able to:
e Understand the differences between real-time,
mixed, and baked lighting in order to select a
lighting strategy that makes sense for your

app.

3.3 - Lighting - Unity Learn

1Hour 30 Mins

e Take the necessary steps required for
lightmapping in order to bake the lighting in
your scene, (i.e.setting light mode to baked
and setting objects as static).

e Add basic environmental lighting using point
lights and spot lights in order to give your
scene the desired appearance.

e Understand the effect that mixed lighting has
in a scene in order to achieve specific
real-time lighting effects (e.g. real-time
shadows).

e Implement Light Probes in order to create
optimized real-time lighting effects from baked

lights.

Step

Step 1-
Experiment
with the
lighting
settings
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Instructions

Before you start editing the lighting of the scene, you will create a
new Lighting Settings asset and get familiar with the settings at
your disposal.

1. Access the render pipeline settings:

e Inthe Project window, search for and select the
"UniversalRenderPipelineAsset”.

2. Experiment with the render pipeline settings:

e In the Inspector for the URP Asset, in the Lighting section,
play with the settings.

e Be sure to include experimenting with the Per Object Limit
slider to appreciate the limitations it places on complex
lighting.

3. Create new Lighting Settings for your scene:

e Click Window > Rendering > Lighting to open the Lighting
window.

e Dock the window next to the Inspector, then click the New
Lighting Settings button to create a new profile.

Teacher Notes

Demo: At the start of
this, demo a before/after
realtime vs baked
lighting and how with
baked lights, shadows
don't change when you
move things - don't make
shadows for dynamic
objects

Warning: This is complex
and is an entire discipline
in and of itself - we won't
be going over every
setting, but will be lots of
additional links for you to
explore if you want.
Explain: The per object
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4. Experiment with the environmental lighting in your scene:
e At the top of the Lighting window, select the Environment
tab
e Experiment with the settings to see the impact they have
on your scene.
You should now be able to locate and adjust the lighting settings
from within the Lighting window and the URP Asset.

® | ighting 3 i

© Inspector
@ Universal Render Pipeline Asset (Universal Render Pipeline Asset @

Open

General
Renderer List
Default

+

0 & UniversalRenderPipelineAsset_Renderer (Forward R ®

Depth Texture
Opaque Texture

Terrain Holes

Quality
HDR
Anti Aliasing (MSAA)
Render Scale

Lighting
Main Light Per Pixel
Cast Shadows v

Shadow Resolution 4096

Additional Lights Per Pixel

Per Object Limit
Cast Shadows
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Scene Environment Baked Lightmaps

Lighting Settings

®.New Lighting Settings

New Lighting Settings

Related resources:

e U - Pipeline A

Step 2 -

Prepare and
bake a basic
lightmap °

The time has come to attempt your first lightmap bake. There are
just a few steps you need to take beforehand.
1. Allow all of your lights to be baked:
Locate and select each light in the scene that will not move
or turn on and off. You can do this by searching “t:light" in
the Hierarchy search bar.

e In their Light components, inside the General fold-out,

change the Mode setting from Realtime to Baked.

2. Allow objects in your scene to have light baked onto them:
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limit drastically affects
how realistic the lighting
looks, but is also
extremely expensive - so
you want the realistic
light combinations, but
without the cost.
Warning: The Lighting
settings asset will be
generated in whatever
folder you're currently in
- would recommend in
the Scenes folder.

Demo: What is realtime
vs baked lighting - look
at how objects shadows /
colors brightness
changes as you move
them around the scene
Demo: Look how long it
takes when you try to
bake with background
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e In the Hierarchy, select all non-moving, static objects.
e At the top of the Inspector, make sure the Static check box
is selected.
e Note: Remember to select the objects in your Lighting
section (e.g. lamps, sconces, chandeliers, etc)
3. Remove the background and foreground objects from your
lightmap to reduce bake times:
e Select each large background object.
e In its Mesh Renderer component, for the Lightmapping
section, reduce the Scale in Lightmap property to 0.
4. Try baking your lights:
e Navigate to the Lighting window.
e At the bottom of the Scene tab, click Generate Lighting.
5. Temporarily minimize the time to generate your lightmap:
e Reducing the Lightmap Resolution to a value between
5-10.
e Reduce some of the other values which contribute to
lightmap quality (samples, bounces, etc).
You should now have a low resolution baked lightmap in your
scene.

& v Light

Type Directional

Color

Mode
Intensity
Indirect Multiplier

© Inspector ® Lighting Sl

N,
v

Tag Untagged v

Multiple

(4)] v Staticw
Layer Default

Select Overrides

Related resources:
e Light modes: Baked, Mixed, Realtime

Step 3 - Adjust
scene lighting
and re-bake

Now that you have attempted your first bake, you can take some
time to properly light your scene and try again.
1. Clear your lightmap and view lighting changes in real time:
e At the bottom of the Lighting window, click the dropdown
next to Generate Lighting.
o Select Clear Baked Data.
2. View the effect of as many lights as possible:
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buildings, then change
lightmap scale to O.
Demo: Look how when
you make something
static, Lightmapping
settings appear in Mesh
Renderer component,
allowing you to edit.
Demo: Use the
drop-down in the top-left
of Scene view to select
the “Baked Lightmap”
view - notice how the
lightmap disappears
when an object is not
marked static.

Warning: This is an
extremely finicky and
challenging art form. It
may take hours of
fiddling with values to
get it looking the way
you want.
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e Select the UniversalRenderPipelineAsset. Demo - If you forget to
e Temporarily increase the Additional Light Per Object Limit | change even a single

to the maximum. realtime light to baked, it
3. Remove the default lights that came with the Room prefab: could have a huge
e Inthe Hierarchy, expand the Room_[style] prefab. impact on performance
e Delete the two child Point Lights. (e.g. the fireplace).

e Note: you will have to open the room prefab in order to
delete the lights.

4. Add more realistic lighting from actual light sources in your
scene:

e From the Course Library > Prefabs > Lighting folder,
make sure you have enough light-emitting objects to light
your scene.

e To add child Light objects to those lighting elements,
right-click them in the Hierarchy and select Light > Point /
Spot Light.

5. Get more even, balanced lighting in the room:

e On your Directional Light, try increasing the Intensity and
Indirect Multiplier values.

e In your Lighting settings, try increasing the Indirect
Intensity value.

6. Test how your lighting looks:

e Click Generate Lighting again.

e If you have time, increase the Lightmap Resolution and
other Light settings values to see how it might look in its
final state.

o Note: if you are getting splotchy, pixelated shadows: from
the Lighting settings, set the Lightmap Compression
property to None.

You should now have rough lighting baked into your scene looking
approximately the way you want.

Related resources:
e Configuring Lightmaps

Step 4 - Add If you want your objects to cast shadows in real time, but also get | Explain: When to use
mixed lighting | the benefits of the performance from baked lightmaps, you can baked vs mixed vs
use "Mixed" lighting. realtime? If you're not
1. Get real-time shadows on top of your baked lightmaps: going to interact with
e Change the Mode of your Directional Light to “Mixed" something - definitely
(instead of "Baked"). bake it.
2. See the new mixed lighting take effect: Explain: If you want any
e Inthe Lighting window, click Generate Lighting to re-bake | of your dynamic objects
your lighting to have shadows - and
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Step 5 - Add
light probes

© Unity 2021

e Notice what effect the mixed light has on the lighting and

shadows of your dynamic objects.

You should now have real-time shadows on your dynamic objects

coming from your directional light.

& v Light

Type Directional
Color

Mode
Intensity

Indirect Multiplier

Related resources:
- Mixed Lighting

In order to get more realistic real-time lighting from all of your
baked lights in the scene, you need Light Probes.
1. Add a new Light Probe Group as a child of the Room object:
e In the Hierarchy, right-click the Room_[style] object and
select Light > Light Probe Group.
2. To be able to edit the light probes:
e Make sure Gizmos with 3D Icons are enabled from the
top-right corner of the Scene view.
e Click the Edit Light Probes button in the Inspector of the
Light Probe Group.
3. Duplicate and reposition the light probes around the room:
Drag selection boxes around probes to select them.
Use the Move tool to position the probes.
Use Ctrl/Cmd+D to duplicate selected probes.
Note: It may be helpful to switch to Isometric view by
clicking on the small icon below the axis gizmo in the
top-right corner of the Scene view.
4. To position your light probes properly:
e Make sure you have probes in areas where lighting
changes drastically either in color or intensity.
e Make sure your probes are not inside objects.
5. See the effect of your light probes:
e From the Lighting window, re-generate your lighting and
test to see the lighting on your dynamic objects.

You should now have approximate dynamic lighting in your scene

based on your baked lighting calculated by your light probes.

Duplicate Selected

Add Component

Related resources:

- Light Probes
- Light Probe Groups
- Configuring Light Probes

have baked lights - need
to set some lighting to
Mixed.

Explain: What are light
probes? How do they
work?

Demo: Show them before
and after light probes -
maybe duplicate an
object where one has
light probes Off and the
other has it to “Blend
Probes”.

Demo: Recommend
using isometric view for
duplicating probes.
Warning: It's very easy
to forget to click the "Edit
Probes"” button.
Warning: Don't position
probes inside objects.
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Step 6 - Now that your lighting is configured approximately the way you

Finalize want, you are ready for a more final higher resolution lightmap.

lighting 1. Make sure your lighting is optimized appropriately for your
target device:

e Test your app in the manner you expect it to be used by
users (i.e. if you are targeting a mobile device, test it on
the standalone device, not connected to your computer).

e Make sure you're hitting your target frame rate.

e For instructions on how to build and run your app on the
actual device, refer to the instructions in the VR Project
Setup tutorial.

2. Generate a single lightmap file rather than several smaller
onhes:

e Increase the Max Lightmap Size to 4096.

e Itis recommended to have a single lightmap file rather
than several smaller ones.

3. If you are getting splotchy or pixelated shadows:

e Set the Lightmap Compression property to None.

4. If you are happy with the general appearance of your lighting
and are ready to generate your final lightmap:

e Inthe Lighting window, increase the Lightmap Resolution
to somewhere between 20 and 80.

e If you want, continue to adjust other lighting settings
(samples, bounces, etc) to get the desired result.

Your lighting should now look the way you want and be optimized
for performance.

Lightmapping Settings

Lightmapper Progressive CPU
Progressive Updates v
Multiple Importance € v
Direct Samples 32
Indirect Samples 512
Environment Samples 256
Light Probe Sample h 4
Min Bounces 1
Max Bounces 2
Filtering

Lightmap Resolution 40 texels per unit
Lightmap Padding 2 texels

Max Lightmap Size 1024

Lightmap Compression | None

Ambient Occlusion

Directional Mode Directional

Albedo Boost

Indirect Intensity

Lightmap Parameters  Default-Medium

Related resources:
- Setting up Lighting in Unity

Recap New Functionality:
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- Complex performant lighting

New Concepts and Skills:
- Baked vs Realtime lighting
- Lightmapping
- Light probes

Next Lesson:
- Publishing

Extensions If you want to further develop your skills, explore new concepts, and improve your project,
check out some of the optional extension activities below.
Each one is tagged as [Easy], [Medium], [Difficult], or [Expert] and will also include a
[Requires Programming] tag if some coding is required.

Extension - 1. Add a new skybox [Easy]
Add a new Create or download a new skybox to enhance the look of your scene:
skybox e Learn more about Skyboxes

e You can download skyboxes on the Unity Asset Store - search for Free assets

e Add your skybox from the Lighting window in the Environment tab

e Warning: if you have a high resolution skybox, and have your skybox set as the Source
of your Environment Lighting in the Environment tab, Lightmapping may take a very
long time. You can change your Source to a Gradient to avoid this.

o
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Extension -
Continue
tweaking
lighting

Extension -
Reflection
Probes
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2. Continue tweaking lighting [Medium]
Continue to fine-tune the lighting in your scene and the lighting settings to make it as beautiful
and performant as possible:

e Try adjusting values in the The Lighting Window to see what kind of results you get.

e Learn more about lighting in Unity:

o Intro to Lighting and Rendering
We\COme to

Use the o YOur VR rgqny l

L]
stick {
CK on your lgft |I

controller to toggle your rhy.
Aim at the Next buttonangpulthe &

|
-

.‘

3. Explore Reflection Probes [Hard]
Add reflection probes into your scene in order to get more realistic reflections from metallic
objects:
e Reflection Probes Manual and all about using reflection probes
e You should probably duplicate the Material_Main to create a new
"Material_Main_Shiny", increase the material's metallic property, then assign that
material to a shiny object in your scene that should be reflective.
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Lesson 3.4 -

Lesson Link

Building and Sharing

2.4 - User Interface - Unity Learn

Length

Project Objectives:

In this lesson, you will follow guidelines for best
practices and explore options for sharing your work.
By the end of this lesson, you'll configure your app
appropriately and build a version of it that is ready to

share.

This lesson is part of the Create with VR course.

Learning Objectives:
By the end of this lesson you will be able to:
e Adjust an app's settings in alignment with
recommended best practices in order to

1Hours 30 Mins

publish it to a particular platform.

e Understand the landscape of VR app
marketplaces in order to evaluate the
appropriate distribution method for your app.

Step
Step 1- Enter the

app's hame and
version number
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Instructions

First, you want to check that the name, developer/company,
and thumbnail aren't the default placeholders.
1. Access the Player Settings:
e Click Edit > Project Settings.
e On the left side, select the Player panel.
2. Change the default app information:

e Change the Company Name, Product Name, and
Version Number to reflect the current state of your
app.

3. If you want to edit the Splash Image that appears when
the app starts up:

e Expand the Splash Image fold-out and edit its
settings.

e You will need at least a Pro license to disable the
Splash Image.

Your App should now display on your device with its proper
name, and should load with the splash image you want.

Teacher Notes

Explain: By “Player”
settings - they don't mean
the "Player” as in "User” -
they mean the Device's app
“player” (e.g. video player,
audio player).

Explain: Can just use a
made up company name -
or your name.

Explain: Version numbers -
Major#.Minor#.Revision# -
maybe 1.0.1is appropriate?
Explain: No need to do
icons here - that would be
submitted separately
through dev portal or other
platform - won't show up
on device in developer
mode anyway.
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Related resources:

- Naming Best Practices
- lcon Best Practices

Step 2 - Confirm | In addition to optimizing the performance of your app, Warning: There's lots of
recommended generally, there are also a few platform-specific stuff we're going to gloss
publish settings recommendations that will make your app build and perform over - we'll have links if you
at its best. want to learn more. Since
Since specific recommendations are platform-specific and technology and these
are changing all the time, the best way to find up-to-date and | settings are always
accurate information is searching online. changing, better to consult
online articles to get the
1. Find guidance on recommended settings for VR latest info for your specific
publication: platform.
e Explore the links under “Related Resources"” below to | Warning: Might take a
find specific recommendations. while to build after you edit
e Google "Recommended Unity settings for these settings.

[insert_device]”.
2. Configure Player Settings:
e Click Edit > Project Settings, then click Player from
the left panel.
e Scroll down to the Other Settings fold-out.
3. Configure Quality settings:
e Click Quality from the left panel of Project Settings.
4. Configure XR settings:
e Click XR Plug-in Management from the left panel of
Project Settings.
5. Configure rendering settings:
e Locate and select the UniversalRenderPipelineAsset
from the Project window.
6. Confirm shadow settings:
e For any Realtime or Mixed Lights, ensure you are
using appropriate shadows.
7. To confirm Build Settings:
e Click File > Build Settings.

Your app should now abide by all of the recommended
settings for publishing to your target platform.

Related resources:

- Configuration Settings
- Blog: Unity Settings for Mobile VR

- Stereo Rendering in VR / AR
1. To configure Player Settings:
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e Click Edit > Project settings, then click Player from the left panel.
e Scroll down to the Other Settings fold-out.
e Inthe Rendering section:
o Set the Color Space to Linear.
o Confirm the correct Graphics API (Open GL ES 3).
o Confirm Multithreaded Rendering is enabled.
e Inthe Identification section:
o Confirm the correct Minimum API Level (Marshmallow API Level 23). This is only relevant for
Android builds.
e In the Configuration section:
o Set the Scripting Backend to IL2CPP.
e In the Optimization section:
o Enable the Prebake Collision Meshes setting.
o Enable the Keep Loaded Shaders Alive setting.
2. In Quality settings, in the Rendering section:
e Confirm Texture Quality is set to “Full Res”
e Confirm Anisotropic Textures are set to "Per Texture”
3. In XR Plug-in Management settings:
e If building to Android, in the Android tab, set Stereo Rendering Mode to Multiview and enable the Low
Overhead Mode setting .
e If building to desktop, in the Desktop tab, set Stereo Rendering Mode to Single Pass Instanced.
4. In the UniversalRenderPipelineAsset:
e Confirm HDR is disabled.
e Confirm Anti Aliasing is set to 4x.
e Confirm Additional Light is set to “Per Pixel" and the Per Object Limit is set to 1.
5. For any Realtime or Mixed Lights:
e Ensure you are using either Hard Shadows or No Shadows.
6. In Build Settings:
e set the Texture Compression to "ASTC".

Step 3 - Up to this point, you have only been building and running the | Explain: How can you load
(Optional) Look app through Unity. Take a look at what it would take to your apk if your app isn't
into sharing or distribute your app outside of Unity. on the oculus store? You
publishing your 1. Explore the requirements for submitting your app to an might have to "side load" it.
app official store:

e Use the links below to read more about the process.
e Google “"Submit app to [insert_store_name]” (e.g.
Steam, Oculus Store).
2. Explore alternative platforms for distributing your App:
e Explore requirements for submitting your app to sites
like SideQuest and Jtch.io.
You should now have a sense of the various platforms
available for distributing your app and an understanding of
what it might take to have an app approved for one of those
platforms.

Related resources:

- ubmit vour to th ulus Stor
- Lifecycle of an Oculus App
- Oculus Best Practices
- Oculus VRCs
Recap New Functionality:

- App & Company name
- Recommended settings

New Concepts and Skills:

- Best practices per device
- Distribution options
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Next Lesson:
- What's next

Extensions If you want to further develop your skills, explore new concepts, and improve your project,
check out some of the optional extension activities below.
Each one is tagged as [Easy], [Medium], [Difficult], or [Expert] and will also include a
[Requires Programming] tag if some coding is required.

Extension - 1. Research the publication process [Easy]
Publication Research the requirements for submitting an app to your preferred platform:
process e This could include an official app marketplace like the Oculus Store or Steam.

e You could also submit your app to an unofficial platform like SideQuest or ltch.io.

Extension - App | 2. Create some artwork for your app [Medium]
artwork Take epic screenshots, make an app icon, hero image, or other materials to showcase your
app:
e You can use the Unity Recorder to capture high quality images of your app.
e Follow guidelines from your relevant app platform on how to make the best icon or
imagery
o E.g. Oculus Blog on How to Prep App for Submission
o E.g. Sidequest requirements on image sizes for banner images and icons
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Challenge 3 - Training Simulation App

Lesson Link

Length 1Hour

In this challenge, you'll apply the skills you learned
while making your VR Room in an industrial training
simulation. In this app, using buttons, knobs, levers,
and joysticks, the user has to collect crates dropped
into the factory and stack them on a nearby platform.

This challenge is part of the Create with VR course.

This challenge will assess skills learned in the

following lessons:
. _—
. mmw A
. Qm"mm hti

Getting started

Challenge

1. The black fade in screen
appears in the middle of the
factory.

2. The “Console Labels" toggle
makes the entire console
disappear.

3. The lighting on the floor
looks really bad.
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Task

: 2 - Training Simulation - Uni

1. Open the broken Training prototype Scene:

e From the Project window, expand, Assets > Challenges >

03_Training > Scenes

e Double-click on the Training_Prototype_Broken Scene to

open it.

2. Begin working on the challenge tasks:

e Work through the tasks outlined in the steps below.
e If you want to push your skills, attempt the optional bonus

challenge tasks, as well.

e If you get stuck, there are hints for each task at the bottom of

the page.

The black fade in screen
should cover the user's entire
field of view.

Only the labels on the console
should disappear when the
toggle is deactivated.

Make the floor lighting look as

detailed as the other surfaces.

Hint

1. To better visualize the
fade canvas, temporarily set
its Canvas Group Alpha value
to 1, then make sure it's not
too far from the camera.

2. Make sure the correct
object is being
Activated/Deactivated by the
toggle.

3. From the top of Scene
view, change the Draw Mode
from Shaded to Baked
Lightmap - you will see that
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4. The pile of boxes in the back
left corner does not have
realistic baked lighting and
shadows.

5. The console is not
responding to the baked light
above it - it looks very dark.

Bonus

6. There is no visual indicator
on the magnet when it is active
vs inactive.

7. The user has access to their
ray and direct interactors
throughout the entire app.

Expert Bonus

8. There is no way for the user
to be able to control the speed
of the magnet. [Expert}

9. There is no way for the user

to track or save their progress
in this training. [Expert]
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The shadows on all the piles
of boxes should be the same.

Keeping the light above the
console baked for
optimization, the console
should appear to be lit by the
light above it..

The magnet should turn a
different color when it is active
vs inactive.

The user should not be able to
use the console while reading
the instructions and their rays
should disappear when they
have clicked through the
instructions.

There should be a setting that
controls the speed of the
magnet.

There should be some user
interface that displays how
many boxes have been
successfully lifted and how
much time has elapsed.

the lightmap resolution on
the floor is very low
compared to other objects.

4. In order for objects to be
baked into the lightmap, they
need to be marked as
“static”.

5. Light probes allow
dynamic objects to respond
to baked lighting conditions.

6. You can use the same
function you used to change
the indicator light on the
remote.

7. In the
ShowMessageFromList
component on the welcome
Text object, there is an On
Complete () event. On this
event, you should toggle off
the rays and toggle on the
console’s functionality, which
should be disabled by
default.

8. No hints available. Use

Google!

9. No hints available. Use
Google!
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Lab 3 - Personal Project Optimization & Lighting

Lesson Link Lab 3 - Personal Project Ergonomics & Optimization - Unity Learn

Length 2 Hours

By the end of this lab, your personal project will be
filled with beautiful art, optimized for performance,
and ready to share.

This lab will draw on skills learned in the following
lessons:

e Comfort & Accessibility
e Optimization

e Lighting

e Building & Sharing

This lab is part of the Create with VR course.

Step Instructions Teacher Notes

Step 1- Fillin Before you resume work on your project, you need a plan for what you're actually going to
Desigh Document | work on. You will continue filling out your design document so you have a clear plan of
for ergonomics & action for this lab.

optimization 1. Pick up where you left off with your design document:
e Re-open the document you created during Lab 1 and continued working on during
Lab 2.

2. Fill out Section 5 (Optimization & Publishing) of the document:
e List the ways you intend to make the user experience more comfortable or
accessible.
e Write down the target performance metrics for your target device(s).
e Describe the lighting strategy you will implement.
3. (Optional) Add more specific details to your design document:
e Continue to fill out section 6 (Other features)
e Continue to fill out section 7 (Sketch)
e Continue to fill out section 8 (Timeline)
You should now have section 4 of your Design Document complete, providing direction
for this lab where you will be implementing your app’s core functionality.

Related resources:
- Oculus Best Practices

Step 2 - Replace Before we begin optimizing our app and improving the user Explain: Why use
primitive objects experience, it's time to replace some of our primitive assets with Low Poly?
with 3D art some real 3D art. Warning: This is a
1. Browse assets on the asset store: very involved step -
e Go to assetstore.unity.com. you could spend an
e Sign in to the Unity Asset Store. entire day on this!
e Search for "low poly"” assets. Explain: You don't
Tip: You can also filter by "Free". have to replace
2. Import an asset pack you like: every asset right
e Click Add to My Assets > Open in Unity. now - just get
e From the Package Manager, click Download. started.

e Then click Import to add the assets to your project.
3. To create your own 3D models inside Unity using Probuilder:
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http://assetstore.unity.com

e From the Package Manager, install the Probuilder package.
e From the top menu in Unity, click Tools > Probuilder >
Probuilder Window.
4. Replace the primitive shapes in your scene with custom or
imported 3D art:
e Add the 3D models as child objects of empty parent
objects in your scene.
e To achieve appropriate scale, adjust the scale of the child
object rather than the scale of the parent object.
e As necessary, add colliders to your objects to make them
collide appropriately.
e As necessary, adjust the attach points of your objects so
that they are grabbed appropriately.
e If possible, try to use the same shaders to reduce draw
calls.
Your scene should now look a lot nicer with some real 3D art.

Related resources:
- About Probuilder / Probuilder Docs

Step 3 - Improve You should take time to consider how comfortable and accessible
comfort and your app will be. This will allow it to be enjoyed by as many people
accessibility as possible and make sure fewer people are excluded from using

your app due to design decisions you've made.
1. Make sure your app's locomotion is as comfortable as

possible.
e Follow the instructions in the Comfort and Accessibility
tutorial.
2. Add settings and menu options that increase the accessibility
of your app:
e Follow the instructions in the Comfort and Accessibility
tutorial.

Your app should now be more comfortable and accessible,
allowing it to be enjoyed by more people than it was before.

Step 4 - Optimize Now that the app is largely functional and has some real 3d assets,
draw calls and you can attempt to optimize your app's performance to hit your
polycount target metrics.
1. Determine your app is currently performing, including fps,
draw calls (batches), and polycount (tris):
e Follow the instructions in the Optimization tutorial.
2. Reduce polycount (tris):

e Follow the instructions in the Optimization tutorial,

including replacing high-poly assets with lower-poly ones.
3. Reduce draw calls (batches):

e Follow the instructions in the Optimization tutorial,
including marking objects as static and using shared
materials.

4. Improve jagged lines with anti-aliasing:

e Follow the instructions in the Optimization tutorial.

5. Quickly experiment with changes to your app’s performance:

e Locate the UniversalRenderPipelineAsset and tweak its
settings to see what has an impact.

You should now have an understanding of how your app is
performing and, if it is performing poorly, what the cause of that
poor performance might be. You should not be discouraged if your
frames per second is still too high, though, since you have not yet
optimized lighting.
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Related resources:
e Seven stages of optimizing mobile VR content in Unity
Optimizing your VR/AR Experiences
Unit 9 - Optimizing VR Apps
VR Best Practice

Optimizing graphics performance

Step 5 - Optimize In VR, performance is critical to the user experience and lighting is | / - This is not your
lighting one of the biggest components of performance. In order to final lighting - just a
optimize performance for VR, baking most of the lighting is highly | first broad attempt
recommended, using a minimal number of real-time or mixed
lights.
1. Add and bake environmental lighting in your scene:
e Follow the instructions in the Lighting tutorial.
2. Improve realtime lighting with mixed lights and light probes:
e Follow the instructions in the Lighting tutorial.
You should now have baked lighting in your scene with realtime
effects on dynamic objects from mixed lights and light probes.

Step 6 - Confirm The final step before building a version of an app that you would °
settings and build | consider sharing or publishing is double-checking that you are
your app using all of the recommended build settings for your target

platform.

1. Confirm that your app's project settings are following best
practices for VR:

e Follow the instructions in the Building and Sharing tutorial,
including Player settings, Quality settings, Build settings,
Render Pipeline Asset properties, Lighting and shadow
settings

2. Build a version of your app that can be shared or published:

e Follow the instructions in the Building and Sharing tutorial.

You should now have a built app, ready for distribution, following
all best practices for build settings.

Recap New Functionality:

New art

Improved comfort and accessibility
Optimized key metrics

Improved, baked lighting

Built app

New Concepts & Skills:
e Optimizing and publishing your own VR app.

Next Lab:
e Next Steps and the rest of your VR development life!
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Quiz 3

Lesson Link

Length

In this quiz, you will test the knowledge and skills you
learned in Unit 3 related to VR Lighting and

15 Mins

Optimization.

This quiz is part of the Create with VR course.

This quiz will assess skills learned in the following

lessons:

Comfort & Accessibility
Optimization

Lighting

Building & Sharing

# | Question

1 | Which of the following
would make your app
LESS comfortable for
users?

2 | True or False:
Providing users options
to choose between
several types of
locomotion increases
accessibility.

3 | Which one of the
following tends to
improve performance?

4 | Which one of the

following Unity tools is
NOT used to diagnose
performance problems.
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Quiz 3 - VR Ergonomics & Optimization - Unity Learn

Answers

A.

COm> DO®P

During continuous motion, apply a
black vignette around the edge of
the screen to reduce the field of
view.

During teleportation, fade to black
to reduce the sense of vection.
Slowly fade in at the start of the
scene so that the user does not
suddenly find themselves in a new
room.

Decrease the frames per second
(FPS) so that the image does not
change as quickly.

True
False

Post-processing
Real-time lighting
Static batching
Fog

The Rendering statistics window
The Profiler

The Frame Debugger

The Timeline

Explanation

Decreasing the FPS will make your
app much less comfortable. If the
user’s brain is not “tricked’ into
thinking they are looking at a real
visual field, they are likely to get
simulator sickness.

It is hard to anticipate how people
will use your app. Providing more
options for how users can engage
with your app increases the
likelihood that it will be accessible
to more people.

Static batching combines static
(not moving) GameObjects into
big Meshes, and renders them in a
faster way.

Timeline is used to create
cinematic content, game-play
sequences, audio sequences, and
complex particle effects.

All the other tools can be used for
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Which of the following
techniques would likely
DECREASE draw calls
(batches)?

Which of the following
are true about lighting
modes?

Select all correct
answers.

Looking at the two
images below, what can
you tell about their
lighting settings?

See high-res image here

Which of the following
are true about graphic
quality optimization in
Unity?

Select all correct
answers.
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Oow

Sharing one material over many
objects.

Using anti-aliasing.

Using anisotropic filtering.
Increasing your number of
triangles.

Objects must be set to static for
lightmapping.

Lights must be set to Realtime
mode for lightmapping.

Mixed Lighting allows for
real-time shadows.

To see the effect of Light Probes,
you have to bake your lighting.

Image 1has a lower Lightmap
Resolution than Image 2.
Image 1 will take longer to bake
than Image 2.

Image 1 has a lower number of
Direct Samples than Image 2.
Image 1 has a lower number of
Bounces than Image 2.

Mip maps should be used for
high-resolution textures that
might be seen from far away.
Anisotropic filtering should be
used to improve the quality of
textures seen at an angle.
Texture Atlases help make images
clearer when they are moving at
high speeds.

Using lower resolution images can

diagnosing performance
problems.

One of the best ways to reduce
draw calls is to use a shared
texture atlas for many objects and
to have those objects also share
the same material and shader.
Unity cannot batch objects if they
are using different shaders.

Lightmapping is only possible with
static objects. Realtime lights
cannot be baked. You can use
Mixed Lights to combine dynamic
shadows with baked lighting from
the same light source. Similar to
lightmaps, light probes store
"baked" information about lighting
in your scene. The difference is
that while lightmaps store lighting
information about light hitting the
surfaces in your scene, light
probes store information about
light passing through empty space
in your scene.

Increasing the Lightmap
Resolution will produce a more
detailed lightmap, which will take
longer to bake. From this image
alone, you cannot tell anything
about the Direct Samples or
Bounces.

Mip maps are smaller versions of
the texture that get used when the
texture is very small on screen.
Anisotropic filtering makes
textures look better when viewed
at a shallow angle, but comes at a
performance cost in the graphics
hardware. A Texture atlas is a
larger texture containing many
smaller textures or color swatches
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9 | What does Anti-aliasing
do?

10 | Which of the following
would actually
DECREASE the
accessibility of your VR

app?
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decrease the number of triangles
in your scene.

It optimizes your textures to
improve frame rate.

It simplifies far-away objects to
reduce the number of triangles.

It optimizes draw calls by batching
together objects that share the
same texture.

It smooths out jagged edges on
curved and diagonal lines.

. For mobility / motor accessibility,

make sure all actions require two
hands.

For hearing / audio accessibility,
add closed captions to any critical
audio instructions.

. For vision accessibility, make text

instructions large and clear.

For cognitive accessibility, include
directions or tutorials for how to
use your app.

- this does not have anything to
do with fast-moving objects.
Changing the resolution of your
images will not affect your
polycount number of triangles).

Anti-aliasing reduces the
prominence of these jagged lines
by surrounding them with
intermediate shades of color.
Although this reduces the jagged
appearance of the lines, it also
makes them blurrier.

Requiring two-handed interactions
would actually decrease motor
accessibility. Ideally, actions could
be completed with either or both
hands.
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Other tutorials

VR Next Steps
LessonLink VR Next Steps - Unity Learn

Length

In this lesson, you will be provided with potential next
steps, now that you have completed this course.
Whether you are more interested in art or
programming, there is so much more you can learn in
order to take your skills to the next level and create
even more custom, unique VR experiences.

If you have completed either the Unity Certified User:
Programmer exam or the Unity Certified User: Artist
exam, you are also eligible to take the Unity Certified
User: VR Developer exam.

45 Mins

This lesson is part of the Create with VR course.

Step

Continue
working on
your
Personal
Projects

Learn more
about
Programming
for VR
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Instructions Teacher Notes

Maybe the most effective way to gain new VR development skills is actually building something
new in VR. Luckily, you already have a personal project in development, which is the ideal
opportunity for you to expand your skills.

Dream up some new ambitious features for your personal project and try to implement them. As
you do this, not only will you improve the project that you can share and add to your portfolio,
you will also very quickly take your VR skills to the next level.

As you continue developing your project, please share it with the Unity community! We'd love to
see what you're working on.

In this course, you used the default behaviors included in the XR Interaction Toolkit and some
pre-built scripts that were provided to you in the course. However, if you want to continue
developing unique interactions in VR, especially if you are interested in doing VR development
professionally, you should be comfortable programming and debugging custom VR
interactions.

1. Solidify your programming fundamentals:

If you are not already confident with your programming, you may find programming for VR
somewhat challenging since it is a rapidly evolving technology with more limited
documentation. For that reason, it is recommended that you start with the Junior Programmer
Pathway, which will give you the foundational skills needed to jump-start your VR development.

2. Implement some VR-specific functionality:
Once you are already comfortable with programming, you should attempt to follow some VR
development tutorials to apply your programming skills on custom VR interactions. We highly
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Learn more
about Art for
VR

Take the VR
Developer
certification
exam
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recommend the VR with Andrew YouTube channel.

3. Get comfortable with the Profiler:

Since performance is so critical for VR, it is important for any VR developer to be comfortable
using the Profiler window. This is a very complex tool, which allows you to pinpoint things like
how your code, assets, scene settings, camera rendering, and build settings affect your
application’s performance.

4. Complete the VR Development Pathway

This learning pathway is designed for anyone interested in learning to create experiences for
VR using their knowledge of programming. By the end of this pathway, you will be ready to get
a job in VR development.

If you are interested in getting an entry level job doing development for VR, what's most
important is a portfolio showcasing your experience developing custom VR interactions. As you
expand your skills, develop small prototypes that you can share with potential employers or
institutions.

In this course, all of the art assets and environments were pre-built for you, optimized for
performance on mobile VR headsets. If you want to create environments in VR that are
completely your own or to get a job creating art for a VR project, there is a lot more you can
learn to build your skills.

1. Understand the Universal Render Pipeline:

The Universal Render Pipelin RP) provides artist-friendly workflows that let you quickly and
easily create optimized graphics across a range of platforms, from mobile to high-end consoles
and PCs. For this reason, it is incredibly useful for VR development, where you will be
developing for devices with a wide range of processing power.

2. Develop Low Poly assets:
Since performance is so critical in VR, it is important that you are comfortable developing nice,
low poly assets that will perform well on mobile VR headsets.

3. Create custom materials and shaders:

You did briefly explore materials and shaders in this course, but if you are going to develop
your own custom VR art, it's important that you can develop your own materials and shaders
that are optimized for VR.

4. Learn more about lighting:

You learned some of the basics for optimized lighting in this course, but that was only the
surface of a very deep and complex topic. It is recommended that you explore lighting more
thoroughly to be able to achieve desired lighting in the most performant way possible.

These are just some of the most important skills for art in VR. As you actually attempt to
implement your art into VR environments, you will learn additional critical skills in the VR art
pipeline.

If you have already earned the Unity Certified User: Programmer or the Unity Certified User:
Artist certification, you are eligible to take the The Unity Certified User VR Developer
certification exam. You can find the objectives for the exams here.

This certification can be used to prove to potential employers or educational institutions that
you are capable of developing VR experiences. It tests your ability to create VR experiences in
Unity and assumes you have accumulated about 200 hours of experience with Unity.

If you completed the entirety of this course, you should be able to pass this exam. However, if
you want to ensure you are ready for it, there is additional courseware you can purchase to help
with your preparation.
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Consider Research the requirements for submitting an app to your preferred platform:
publishing This could include an official app marketplace like the Quest Store or Steam.

your work You could also submit your app to an unofficial platform like SideQuest or ltch.io.
Submission: | If you have continued to develop your personal project, developed new prototypes, or created
Show us custom art for VR, please share it with us here.

what you're

working on Take screenshots, videos, or post links of what you're working on!
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How to set up a VR Project from Scratch

Step 1- Install
the correct
version of
Unity

Step 2 -
Create a new
URP Project

Step 3 -
Create a new
empty scene.

Step 4 -
Install XR

plugin
packages.
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Before you make a project, make sure you have the correct version of Unity installed, which
can support stable VR development:

1. From Unity Hub, install Unity 2021 LTS (long-term support).

2. If developing for mobile VR (e.g. Oculus Quest), make sure to download the Android export
module.

You should now have the correct Long-Term Support version of Unity installed with the
appropriate export modules.

Now that we have the correct version of Unity installed, we need to make a new project on that
version configured for VR.

1. Open the Projects tab in Unity Hub

2. Select New Project

3. Make sure the Editor Version of your new project is set to the recommended version from
the previous step.

3. From the list of templates, select 3D (URP), then set the Project Name, and the Location to
save it.

4. Click Create and wait for your project to open.

You should now have a new empty URP project open.

Before we do anything related to VR, let's set ourselves up with a simple empty scene.
1. Make a new Scene:
e In the Project window, right-click on the Scenes folder and select Create > Scene.
e Rename the new scene “VR Starter Scene”.
e Open the new scene
2. Add a simple ground object:
e In the Hierarchy, right-click to create a 3D > Plane object.
e Rename the Plane object “Ground.”
e Inthe Inspector, make sure its XYZ coordinates are set to X=0, Y=0, Z=0.
You should now have a new empty scene open with a simple ground object.

Before we can begin developing for a particular device, we need to make sure we can interface
with different devices.
1. Enable XR plug-ins:

e From the top menu select Edit > Project Settings.

e In the XR Plugin Management panel, select the Install XR Plugin Management button.
2. Install the OpenXR package:

e From within the XR Plugin Management panel, in the PC, Mac, Linux & Standalone tab,
select OpenXR from the list of available Plug-in Providers to install the plug-in.

e This will allow you to publish to a wide range of devices using a single plugin.

e If you are prompted to restart your project in order to switch to the new input system,
select Yes.

3. Resolve warnings by setting up an interaction profile.

e After adding the OpenXR plugin, notice the warning or error icon that appears next to
the plugin Name

e Click on the warning or error icon to open the OpenXR Project Validation window,
which will tell you that you need to add an "interaction profile” for the device you're
using, select the Edit button to do that. This will open the OpenXR settings panel.

e Inthe Windows, Mac, Linux tab, make sure the Oculus Touch Controller Profile
appears in the list of Interaction Profiles, then enable all available OpenXR Feature
Groups.

e If you are using a different device, such as the Valve Index or HTC Vive, select that
interaction profile instead.

e There should no longer be any warnings in the XR Plugin Management panel. If there
are, select them and follow the recommended steps to resolve them.
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e If you are having trouble resolving warnings or errors, or if you need help
troubleshooting, check out this detailed documentation on configuring the OpenXR

plugin.
You should now have the appropriate plugins installed for your target device.

Step 5 - It would technically be possible to deploy to a device now if we already had a functioning
Install the XR | project, but in order to actually develop the project, we need to install the XR Interaction Toolkit
Interaction XRIT.
Toolkit and 1. Allow the installation of “Pre-release"” packages:
samples e |nthe Project Settings window, in the Package Manager panel, select the option to
Enable Pre-release Packages and then select “I Understand”.
2. Browse preview packages in the Package Manager:
e From the top menu, select Window > Package Manager.
e To be able to search through all packages, from the drop-down in the top-left, change
the scope from “In Project” to "Unity Registry”.
3. Install the XR Interaction Toolkit package:
e Search for and select the XR Interaction Toolkit package.
If you don't see it in the list, you can select the + button and choose to Add Project by
Name, then enter “com.unity.xr.interaction.toolkit".
e Click Install.
e This will allow you to quickly develop XR interactions.
4. Install helpful samples for quick development:
e After the XR Interaction Toolkit package has installed, a new Samples fold-out should
appear at the bottom of the description.
e Click to Import the Starter Assets.
o This provides a set of Default Input Action presets for mapping specific buttons
to actions using the action-based input system
e Click to Import the XR Device Simulator
o This allows you to test your VR app using keyboard and mouse controls rather
than an actual headset.
You should now have the XR Interaction Toolkit package installed, including helpful samples,
and have a new XR option when creating new objects in the Hierarchy.

Step 6 - Add Now that you have all of the packages and samples you need to get started, you can set up
an your scene for XR Development. If you require additional information after trying this step,
Action-based | check out the Samples Documentation.
XRRigtothe | 1. Set up the action-based input system in your scene:
scene. e In the Hierarchy, right-click to create a Empty GameObject, then rename it “"XR Input
Action Manager”

e Add an Input Action Manager component to the object.

e Expand the Action Assets fold-out and click the + to add a new asset.

e Select the object picker for Element 0 and assign the XRI Default Input Actions preset.
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2. Apply action presets automatically when you add XR components:
In the Project window, navigate to Samples > XR Interaction Toolkit > [version] >

Starter Assets.
Select each default action preset in this folder and, at the top of the Inspector for each

one, select Add to [component] Default.
Now, whenever you add a new XR component, these presets will be applied.

© Inspector

s X R| Default Continuous Move (Preset)
1

Add to ActionBasedContinuousMoveProvider default

3. Make sure that new XR GameObjects use the appropriate presets:

From Project Settings, open the Preset Manager panel, then locate the
ActionBasedController section

e For the XRI Default Right Controller, type the Filter value “Right”

e For the XRI Default Left Controller, type the Filter value “Left”
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4. Add an action-based XR Rig to your scene:
e Inthe Hierarchy, right-click to create an XR > XR Origin (VR).
o This object contains the camera and controllers for the user.
e In the Hierarchy, expand XR Origin > Camera Offset, then select one of the controller
objects.
o Notice how the Action references are already assigned by default.
You should now have an XR Origin in your scene set up with action-based inputs already
configured.

Before running your project, you should also make sure the project’s quality and rendering
settings are appropriate for VR.
1. If you are building to Android (for a Quest):

e Still in the Project Settings window, in the Player settings panel, in the Android tab, in
the Other settings fold-out, locate the Minimum API Level.

e Set the Minimum API Level to Android 10 (API level 29) (or whatever is recommended in
this Quest Documentation).

2. Make sure your graphics quality settings are appropriate for VR.

e Still in Project Settings, click the Graphics panel on the left.

e For the Scriptable Render Pipeline Settings property, use the object picker to select
the URP-Balanced option.

o This will ensure your graphics are not too intensive for mobile VR.
3. Remove post-processing from your scene:

e Inthe Hierarchy, select the Global Volume GameObject and set it as Inactive.

e This object adds post-processing to your scene, which you will learn about in later
tutorials - to start and to keep things as performant as possible, it's best to remove
post-processing for now.

You should now have critical settings configured properly for running VR projects.

With your project now completely set up for VR, you can import the course-specific assets and
scenes.
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course
assets 1. Click to download the_zip file that contains the assets.
2. Extract the zip file and open the folder inside to locate the .unitypackage within.
3. Import the .unitypackage into your project.

You should now see _Course Library and Challenges folders in your assets

Next steps You now have the project set up for VR development.
Next, you can continue on to Lesson 1.1 - VR Project Setup | Step 2 in order to add the
appropriate device-specific plug-ins and build your project for the first time.
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